1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

05 Pulls Right

Discussion in '2nd Gen. Tacomas (2005-2015)' started by cdub105, Jan 6, 2008.

  1. Jan 6, 2008 at 7:45 PM
    #1
    cdub105

    cdub105 [OP] Active Member

    Joined:
    Dec 11, 2007
    Member:
    #3803
    Messages:
    42
    Florida
    Vehicle:
    05 Tacoma Access Cab 4x4
    My 05 tacoma pulled right so i had it aligned still did it. put lift kit on then had it aligned again and still pulls right, anyone else have this prob?
     
  2. Jan 6, 2008 at 8:40 PM
    #2
    piercedtiger

    piercedtiger Devout Atheist

    Joined:
    Oct 29, 2007
    Member:
    #3284
    Messages:
    6,446
    Gender:
    Male
    First Name:
    Jon
    Southern Tier, NY
    Vehicle:
    2015 F150 3.5EB SCEW 6.5ft
    Bad tire maybe? Have you rotated them? Just wondering if one of the right ones being worn more would make it pull to the right...
     
  3. Jan 7, 2008 at 2:34 AM
    #3
    concrete jedi

    concrete jedi Well-Known Member

    Joined:
    Oct 20, 2007
    Member:
    #3142
    Messages:
    2,741
    Rochester N.Y
    Vehicle:
    06 Tacoma 4 door indigo blue
    Broken and scratched tailgate, cracked rear tail light lens, coffee stain in driver seat.
    Take your truck to a different shop and have them confirm that the alignment was done correctly.
     
  4. Jan 9, 2008 at 6:03 PM
    #4
    surfsupl

    surfsupl Well-Known Member

    Joined:
    Jan 8, 2008
    Member:
    #4161
    Messages:
    8,572
    Gender:
    Male
    First Name:
    Gregg
    WestCoast
    Vehicle:
    I DONT CARE IF IT'S A RE-POST
    Rear Diff Breather~ 5100's ~Fog Light Anytime~Tint~TRD Seat Covers~Weather Tech's~Pioneer H.U.~Lift~Eibach Springs~LED's......blah...blah...blah
    Mine pulled right from the start. Did the alignment thing and still pulling right. What finallt did it for me was endless play with tire psi. Took a while and alot of patience but now smooth sailing!
     
  5. Apr 22, 2009 at 1:11 PM
    #5
    Richman21

    Richman21 I think therefore I'm a Democrat

    Joined:
    Jan 15, 2009
    Member:
    #12603
    Messages:
    442
    Gender:
    Male
    First Name:
    Jeff
    Albuquerque, NM
    Vehicle:
    09 DC Sport PreRunner
    Hardwire radar detector. Tube steps.
    Mine is doing the same. But I have a brand new 09. I bought it with 18 miles on with the Bridgestone Duelers 684II, swaps those out at 350 miles, now I have a pull to the right. Before the new tires no pull, after new tires I have a pull. The tires are Michelins Cross Terrains. Same size tire as stock with the same stock wheel. I bought the tires at Costco, had them rebalance and rotate the tires, still the same. Yesterday, I took it to the dealer, sure enough, the alignment was off, performed a alignment. Today, it still pulls to the right and now my steering wheel is off to the left. I called the dealer, they said to bring it back in. Anyone else have issues like this?
     
  6. Apr 22, 2009 at 2:30 PM
    #6
    LBtaco

    LBtaco Thread killer

    Joined:
    Jan 23, 2009
    Member:
    #12893
    Messages:
    1,242
    Gender:
    Male
    Long Beach , CA
    Vehicle:
    15 Nissan Leaf
    Jetsons mod
    when i got new tires at sears, yes sears (dad payed for work I did) It took them 3 times to get the alignment right. I have to go back in since I changed the rear leafs and I'm probly going to lower the front just a bit and I pull to the right.
    Hope they get it right lol.Im still on their alignment "warranty" so It's free, but after this I'm going to a real alignment shop.
     
  7. Apr 22, 2009 at 3:32 PM
    #7
    Richman21

    Richman21 I think therefore I'm a Democrat

    Joined:
    Jan 15, 2009
    Member:
    #12603
    Messages:
    442
    Gender:
    Male
    First Name:
    Jeff
    Albuquerque, NM
    Vehicle:
    09 DC Sport PreRunner
    Hardwire radar detector. Tube steps.
    You took it to Sears or the dealer for the alignment? Well tomorrow I wil be up to two times, hopefully no third!:)
     
  8. Apr 24, 2009 at 11:15 AM
    #8
    Richman21

    Richman21 I think therefore I'm a Democrat

    Joined:
    Jan 15, 2009
    Member:
    #12603
    Messages:
    442
    Gender:
    Male
    First Name:
    Jeff
    Albuquerque, NM
    Vehicle:
    09 DC Sport PreRunner
    Hardwire radar detector. Tube steps.
    Well I took it in for a second time for the alignment. I think it still pulls slightly to the right. I've tried it in parking lots and it seems ok. But when I get up to 60-70 on the freeway, center lane, it still slightly pulls to the right. Am I crazy? Tire pressure is all the same. I know roads have somewhat of a crown to them, but I don't remember the pull like this in my 06 Tacoma I had. I'm thinking about asking Costco to swap out the tires. Does anyone else have issues with pulling to the right?
     
  9. Apr 24, 2009 at 11:32 AM
    #9
    TEX357

    TEX357 TX

    Joined:
    Jan 10, 2009
    Member:
    #12438
    Messages:
    2,149
    Gender:
    Male
    Vehicle:
    05 TACOMA
    285\70-17 BFGoodrich KM2's 17x8 Pro Comp 7089
To Top