1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

05 Taco Front End Problems

Discussion in 'Technical Chat' started by 05TACO112, Jan 30, 2012.

  1. Jan 30, 2012 at 8:59 PM
    #1
    05TACO112

    05TACO112 [OP] SouthernBuckeye

    Joined:
    Jan 30, 2012
    Member:
    #71794
    Messages:
    62
    Gender:
    Male
    First Name:
    Joe
    Dothan, AL.
    Vehicle:
    05 TRD Sport 4.0L 4x4 Access Cab
    throttle body spacer, k&n cold air intake, led tail lights, bull bar, chrome 16" off road wheels
    Ok, I have a 2005 Access Cab Toyota Tacoma SR5-TRD Sport 4x4 4.0L. In the last 18 months I have replaced both front hub assemblies, all shocks, (FL) CV shaft, break pads/rotors, drum pads/ drums turned, kept oil changed, and had transmission fluid changed. Engine mods include K&N Cold Air Intake and throttle body spacer.Recently had new 265/75-16 A/T's put on my truck and had it aligned.**(NOTE: when I put back on "FL" hub assembly I forgot to put back on brake shield and its still that way)**
    Now for the problems... I'll start off with warning indicators which consist of " ABS and Emergency Brake Light" "Airbag light" " check engine light".
    ABS LIGHT- when front left hub bearing went bad, it got so chewed up it broke off the sensor.
    EMERGENCY BRAKE LIGHT- not a clue what it is, mazda mechanic said it could be tied in with ABS and thats why it's on.
    AIRBAG LIGHT- again no idea, but it does seem to be common
    CHECK ENGINE LIGHT- had it ran and came back the catalyitic converter was bad. Should I suck it up and get a new one, or would just cutting it off do?
    OTHER- believe I have a couple bad sway bar links, and was told I had warped rotors by Firestone which being around them doesn't seem like a reliable source. Also, have a shake in my steering which seems to be worse in the cold or when I dont drive it for a while and first get in to drive it. But does not worsen when brake is applied which if rotors were warped, you would think it would right? Almost done, there is a slight vibration at the feet as if a couple dry gears were running right below the floor board. Lastly would be the slip when I accelerate from a dead stop and when I come to a red light and slow down it hits when I stop. Mechanic buddy said he thought the rear end was loose and just needed tightened.
    ANY IDEA'S, SUGGESTIONS, PAST EXPERIENCE STORIES
    OR HELP I CAN GET WOULD BE GREATLY APPRECIATED!
     
To Top