1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

06 v6 mileage

Discussion in 'Technical Chat' started by mattnetz, May 3, 2009.

  1. May 3, 2009 at 10:25 PM
    #1
    mattnetz

    mattnetz [OP] Member

    Joined:
    May 3, 2009
    Member:
    #16755
    Messages:
    14
    Gender:
    Male
    socal
    Vehicle:
    06 prerunner doublecab lb 2wd
    bfg all terrains!!!
    im sure this has been covered 10000 times but im new and cant find much. i have a 06 doublecab v6 trd sport auto. with 40k on it and i cant seem to get over 14mpg. i do drive pretty aggressive , but my 5.0 stang gets better than this thing.The dealers been jacking me around telling me its the way i drive or its not broken in....its rated at 22 and the best ive ever seen is 17...downhill with the wind to its back,no ac, and 65 mph. what mods are out there and whats the dealer doing for this? any helps needed!...i have a k&n filter but didnt help any...
     
  2. May 4, 2009 at 12:09 AM
    #2
    Rangerpeterson

    Rangerpeterson Well-Known Member

    Joined:
    Jan 20, 2008
    Member:
    #4353
    Messages:
    513
    Gender:
    Male
    Jacksonville, FL
    Vehicle:
    06 Tacoma
    Get a CAI.... and a new exhaust... It took mine from 15 to 16 mpg and i drive much more like an asshole now. I've got a 6'' lift and 35's thou.
     
  3. May 4, 2009 at 2:54 AM
    #3
    DDD

    DDD Shine bright like a hymen

    Joined:
    Mar 6, 2009
    Member:
    #14416
    Messages:
    2,254
    Gender:
    Male
    First Name:
    Derek
    Santa Clarita, CA
    Vehicle:
    06 DC 4x4 TRD Off-Road
    I get 17mpg driving a mix of city & Hwy.

    Thats with M/T tires, oh and I have a 4x4.

    I run my tires at 40psi when I am not off road. With my tires at 28psi I only get 15-16mpg.
     
  4. May 4, 2009 at 2:59 AM
    #4
    genxer36

    genxer36 Lord of Tomfoolery

    Joined:
    Nov 13, 2007
    Member:
    #3442
    Messages:
    10,581
    Gender:
    Male
    First Name:
    Sean
    Bethlehem,GA
    Tow package, XM Satellite radio, K & N Air filter, & Channel Vent Visors
    I have the v6 2wd DC, drive 80+ on the highway & get 18-20 mpg. I do have a K&N air filter, 20" wheels, A tonneau cover. You should be getting better than that.
     
  5. May 4, 2009 at 3:35 AM
    #5
    mattnetz

    mattnetz [OP] Member

    Joined:
    May 3, 2009
    Member:
    #16755
    Messages:
    14
    Gender:
    Male
    socal
    Vehicle:
    06 prerunner doublecab lb 2wd
    bfg all terrains!!!
    whats a cai?
     
  6. May 4, 2009 at 7:34 AM
    #6
    Simon's Mom

    Simon's Mom Wag More Bark Less

    Joined:
    Apr 12, 2007
    Member:
    #1297
    Messages:
    9,321
    Gender:
    Female
    First Name:
    Judy or Jude :)
    SBurl Vermont
    Vehicle:
    13 TRD OR DC MGM
    Stock for now
    cold air intake

    my 06 4x4 DC auto w/30k gets around 17-18 consistantly mix city/hwy & a thule roof rack. Truck is stock except for TRD exhaust & drop in AFE Prodry filter fwiw. Oils all synthetic & just had the spark plugs changed per mnt schedule. My scangauge really helped my mileage showing me how a heavy right foot makes the truck love the gas.

    Welcome to the forum btw.
     
  7. May 4, 2009 at 7:37 AM
    #7
    Jester243

    Jester243 mod status????

    Joined:
    Jun 25, 2008
    Member:
    #7552
    Messages:
    10,004
    Gender:
    Male
    First Name:
    Dan
    Spokane, WA
    Vehicle:
    2016 Trail Premium 4Runner w/ KDSS
    I get a constant 16-17 completely in the city, you are probably driving to aggressively. Try backing off the gas a little and see what happens, also when is the last time you changed your air filter and whats your tire pressure at?
     
  8. May 4, 2009 at 8:50 AM
    #8
    mattnetz

    mattnetz [OP] Member

    Joined:
    May 3, 2009
    Member:
    #16755
    Messages:
    14
    Gender:
    Male
    socal
    Vehicle:
    06 prerunner doublecab lb 2wd
    bfg all terrains!!!
    i never put an intake cause i didnt want to mess with the warranty and personally i dont care to hear a v6 with exhaust and intake. ive had enough trouble with cops and that b4 (probabaly goes back to the lead foot problem lol) if i BABY it....like drive to the river on a fresh tank and dont let the rpm get over 2500, no ac, i might get 16mpg (with a 300 pound ski in the bed). in the summer i clock it at 12.5.-14.5. also whats with this thing when you let off the gas on the freeway it like slows down not cruises? is there a way to shut that off? i think its a engine brake or something
     
  9. May 4, 2009 at 11:20 AM
    #9
    TacoTycoon

    TacoTycoon Well-Known Member

    Joined:
    Apr 1, 2008
    Member:
    #5653
    Messages:
    401
    Gender:
    Male
    First Name:
    Justin
    Hayes, VA
    Vehicle:
    07 TRD Sport 4WD Indigo Ink
    Bilstein 5100 Coilovers, Diff Drop Kit, TSB AAL, 285/70/17 BFG A/T Tires, 17X8 Helo HE835 Wheels, Rear Bilstein 5100s, Dual Flowmaster 50 series, TRD CAI, TRD Front Seat Covers, Rear Suspension TSB, 35% Tint, Redline Hood Struts, MagLite Mod
    well I would run some seafoam, clean the maf sensor, have you changed plugs? Premium gas nets me an average of 1-2 mpg increase. I hope that helps. Oh and yeah make sure you tires are good on psi. I have the 07 double cab long bed v6 4X4 and get around 20 city with a light foot. The scanguage really improved my driving habits
     
To Top