1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

07 brake issues

Discussion in '2nd Gen. Tacomas (2005-2015)' started by afalex1, Dec 6, 2009.

  1. Dec 6, 2009 at 8:26 PM
    #1
    afalex1

    afalex1 [OP] Member

    Joined:
    Mar 9, 2008
    Member:
    #5179
    Messages:
    11
    Arkansas
    Vehicle:
    07 PreRunner 2wd Auto
    I have had my 07 since Feb of last year. it has performed well for me, but the brakes have always sucked. When I first get in the truck in the morning it squals horribly as I back out of the driveway. Then when I slow to a stop between 20-0 it has two different squeaking noises. Plus the brakes are mushy! they always have been. The weird thing is this. When it has rained the brakes act completely different. After a hard rain the brakes almost lock up with a tiny touch of the pedal. After a m;ile or two of driving they go back to being soft. I can't figure this out. Any ideas?
     
  2. Dec 6, 2009 at 8:30 PM
    #2
    seksilumpia

    seksilumpia Well-Known Member

    Joined:
    Oct 25, 2009
    Member:
    #24905
    Messages:
    592
    Gender:
    Male
    First Name:
    Brandon
    El Dorado Hills
    Vehicle:
    05 TRD Sport DCSB
    Performance mods: TRD CAI, AFE throttle body spacer, Doug Thorley headers, TRD exhaust. Cosmetic mods: HID 10k head+3k fog lights, BHLM, T-rex 2 eyelids, billet grill (5 piece), 20% front window tint, 4% back window tint, tinted 3rd brake light, altezza tail lights, LED license plate lights, door skid protectors, slotted drilled rotors,plasti dip rims,painted rotor and drums. Interior mods: TRD seat covers, LED map and dome lights, 2 kicker 10' w/ 500 watt amp, pioneer door speakers,and Pioneer AVIC X930BT.
    check if the shims are on the pads..if you have the shims,then the rotor or caliper is prolly dirty with all that ceramic brake dust..if neither, then your taco is SOL,brake change time
     
To Top