1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

07 PreRunner Questions

Discussion in '2nd Gen. Tacomas' started by TacomaRebel, Aug 10, 2011.

  1. TacomaRebel

    TacomaRebel [OP] Member

    Joined:
    Aug 10, 2011
    Member:
    #61510
    Messages:
    14
    Gender:
    Male
    S. Mississippi
    Vehicle:
    07 PreRunner TRD OffRoad
    Newbie here just bought a used 07 PreRunner TRD OffRoad SR5 Quad cab.
    I have a couple questions about possible brake noise and AT shifting.
    When I apply brakes with the windows up I hear a noise that sounds like the brakes are grinding and need replacing. When I roll down the window I don't hear the noise. I have looked the best I can at the front disc pads and they appear to have about 1/4" or so of pad left. Is this noise from the brakes or maybe the drive train?
    Second ?. When I am drive in town and keep the speed around 40mph and foot on pedal the at is smooth, same on highway at 65-70 mph. But if I let off the gas to slow down, no brake the truck feels like it is shifting to a lower gear or running out of gas. My guess is downshifting. I am not used to a 5 speed auto. My older 98 PreRunner is only a 4 speed and doesn't do this.
    If anyone has any experience with these 2 items I would appreciate the input.
    Thanks.
     
  2. senor taco

    senor taco ROLLIN ON RUST

    Joined:
    Jan 7, 2009
    Member:
    #12330
    Messages:
    2,343
    Gender:
    Male
    First Name:
    Steve
    Monterey Bay, Ca
    Vehicle:
    O7 Tacoma PreRunner SR5
    17in fj cruiser wheels satoshi grille with devil horns emblem Single in double out 50 series flowmaster with stainless tips Kenwod ddx512 double din touch screen DVD reciver with a single Rockford fosgate 12 in sub with an alpine amp tinted tail and third break light silverstar head and fog lights k&n drop in Billy 5100's on all 4 corners with a 2"AAL
    I'm not familiar with your first problem with the brakes, but the second issue you have is perfectly normal. My truck does the same thing. And its been doing it since I drove it off the lot in 07.
     
  3. TacomaRebel

    TacomaRebel [OP] Member

    Joined:
    Aug 10, 2011
    Member:
    #61510
    Messages:
    14
    Gender:
    Male
    S. Mississippi
    Vehicle:
    07 PreRunner TRD OffRoad
    Thanks for the reply.
     
  4. colder

    colder Well-Known Member

    Joined:
    Jul 17, 2011
    Member:
    #60063
    Messages:
    324
    Gender:
    Male
    MN
    Vehicle:
    2011 Access Cab TRD Sport
    I think it's just engine braking. My truck does that and it's new. It felt different to me, since I had been driving an I-6 4spd for 5 years or so.
     
To Top