1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

150k miles and starting to show a little aging

Discussion in '2nd Gen. Tacomas (2005-2015)' started by tacoman00, Oct 13, 2016.

  1. Oct 13, 2016 at 10:33 AM
    #1
    tacoman00

    tacoman00 [OP] Your Average Joe

    Joined:
    Mar 9, 2011
    Member:
    #52689
    Messages:
    459
    Gender:
    Male
    Rockville, MD
    Vehicle:
    2021 TRD Off-Road DCSB
    Toytec BOSS 2.0 lift, 18x9 Fuel Rebels, 32” BFG AT K02.
    Alright guys, I know these trucks last forever and I haven't lost confidence in mine, but it's starting to have a few issues.

    -just replaced sway bar links
    - blower motor is working intermittently
    -truck often cuts off immediately after starting it
    -truck won't start on first key turn, but will after I give it a break and try again

    The bottom 3 points are obviously unsolved issues. As for the blower motor, I just replaced a very old and dirty CAF thinking that would fix the issue, but the motor is still intermittent. I'm thinking ill just replace that.

    As for the bottom two bullets, any recommendations would be greatly appreciated. I was told the fuel filter is not something to consider in these trucks.

    Lastly, any recommendations for routine maintenance at 150k are greatly appreciated!
     
  2. Oct 13, 2016 at 10:39 AM
    #2
    FFBlack

    FFBlack Well-Known Member

    Joined:
    Jun 4, 2016
    Member:
    #188730
    Messages:
    1,214
    Gender:
    Male
    First Name:
    Mike
    Vehicle:
    2019 TRD OFF ROAD
    Sounds like your blower motor resistor is going bad, id replace that first before replacing the motor.
     
    Shark18 and timbobzimbob like this.
  3. Oct 13, 2016 at 10:45 AM
    #3
    Clearwater Bill

    Clearwater Bill Never answer an anonymous letter

    Joined:
    Oct 11, 2014
    Member:
    #140097
    Messages:
    22,761
    Gender:
    Male
    First Name:
    Billy
    Largo Florida
    Vehicle:
    '13 5 lug AC w/convenience package
    A few OE parts from fancy trucks
    When was the last tune up?

    Any pending CELs? (you have to hook a gauge up and check)
     
  4. Oct 13, 2016 at 2:53 PM
    #4
    rnish

    rnish Well-Known Member

    Joined:
    May 9, 2014
    Member:
    #129450
    Messages:
    8,334
    Gender:
    Male
    Peoples Republic of Maryland (USA)
    Vehicle:
    Tacoma 2nd gen
    King's, Camburg UCA, Dirt King LCA, armor
    Throttle body & MAF cleaning, spark plug change, bottle of injector cleaner in the next gas fill up. All fairly simple and cheep to do.
     
    jmich2001, Shark18 and timbobzimbob like this.
  5. Oct 13, 2016 at 3:02 PM
    #5
    Benzdriver81

    Benzdriver81 Making it fool-proof will just make a better fool

    Joined:
    Aug 1, 2016
    Member:
    #193495
    Messages:
    6,090
    Gender:
    Male
    First Name:
    Kevin
    PNW
    Vehicle:
    05 DCLB Sport
    Every time I'm on Amazon looking for Tacoma stuff for fun, I always see this in the "What Other Customers Have Bought" section, so I'm thinking this is a popular item to replace.
     
  6. Oct 13, 2016 at 3:06 PM
    #6
    Jimmyh

    Jimmyh Well-Known Member

    Joined:
    May 16, 2012
    Member:
    #78991
    Messages:
    13,829
    Gender:
    Male
    SC
    Vehicle:
    2012 Prerunner SR5
    Also check the connectors to see if you have a loose, burned female pin.

    This is what you need to fix your problems with the blower: A new resistor assembly and a connector plug, with part numbers on the package. See image below.

    Plug Number 82141-04M40
    Resistor Number 87138-04052

    [​IMG]
     
  7. Oct 13, 2016 at 7:09 PM
    #7
    Pork Chopper

    Pork Chopper Well-Known Member

    Joined:
    Dec 5, 2014
    Member:
    #143709
    Messages:
    408
    Gender:
    Male
    Dallas, TX
    Vehicle:
    07 DC 4x4
    Check the plug for the blower motor resistor first, it's in the passenger floorboard up against the firewall. Sometimes people will shove my floor mat up and that causes it to stop. I replaced the plug, repinned the terminal, and have a spare set for about $12.

    https://www.tacomaworld.com/threads/before-you-replace-the-blower-resistor.107093/

    For #4, have you tried turning the key to "On" and waiting a few seconds before you try to crank?
     
  8. Oct 13, 2016 at 8:12 PM
    #8
    Notoneiota

    Notoneiota Claud Bawls molested my cat.

    Joined:
    Aug 24, 2014
    Member:
    #136871
    Messages:
    1,248
    Gender:
    Male
    First Name:
    Mike
    Oakdale & Grand Rapids, MN
    Vehicle:
    14 Tacoma DCLB TRD Sport
    Mostly stock with a few minor mods.
    #2 blower motor resistor.
    #3&4 fuel pump and/or pressure regulator
     
  9. Jan 17, 2017 at 8:30 PM
    #9
    Rabicano

    Rabicano Member

    Joined:
    Jul 29, 2016
    Member:
    #193193
    Messages:
    23
    Gender:
    Male
    Napa, CA
    Vehicle:
    2007 TRD OR, DCSB

    Wish I had found this thread before buying a new climate control panel. Bought these two parts on Amazon for about $50 and installed them in an hour. It's a bit tricky to get to the screw that's farthest in there, but a smaller ratchet wrench will get it done. Works great now.

    Anyone want to buy a used climate control panel?
     

Products Discussed in

To Top