1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

1996 tacoma 2.7 4X4,no power? engine problems?

Discussion in 'New Members' started by beestrom650, Mar 19, 2010.

  1. Mar 19, 2010 at 1:40 AM

    beestrom650 [OP] Member

    Mar 19, 2010
    i recently bought a very used 1996 2.7L 4X4
    the engine does not seem to turn over much power at all. ppl have said you arent used to a 4 cyl, so i tested that theory and went to a used lot and drove a 1994 toyo 4x4 with smaller engine, it would blow the doors off mine.
    so i took mine to garage, they said it probly just needs a tune up,
    after replacing fuel,air,oil filters, new plugs, wires, cap, rotor, belts.
    nothing has changed. it seems to really lag hard. there is no way it would be able to tow anything. one guy at the garage said the timing chain may be the problem, one guy said it might be low on cylinder compression. I dont know but all that cost me 300.00 ? and it has been through several tanks of fuel already and lucas injector cleaner one time. it is avg 21 mpg, but then again it is not making any power. it feels like when you shift into 3 gear there is no more power. when i took it off road it had difficulty pulling hills due to the fact the engine could not rev up much over 2,000 rpm's to turn over more power. I don't know what the problem is. if the engine was bad would it run so well otherwise. no rough idle or mis or backfire. no use of oil or smoke. It does have 190,000 miles but truck is in good condition. I have checked into other engines just in case, whew they are expensive. I would appreciate any help. i love the truck and want to keep it, i just want it to run the way it should. i will come back to site tomorrrow to see your suggestions. By the way the mechanic that worked on it offered to buy it off of me. Makes me wonder, but it had the problem when i took it to him. I guess he thinks i will give up and he can buy cheap and fix it right for himself, good strategy, i am not going back there. but dealership garages are too costly.
  2. Mar 22, 2011 at 3:36 PM

    krypton New Member

    Mar 22, 2011
    96 toyota tacoma
    I had a similar problem were my truck would seem to be without power or want to turn off unless i gave it gas. I took it to a shop and they had it for 2 days and after checking everything they finally told me that the catalytic converters guts had broken down and got blown into my muffler causing it to become very clogged. after replacing both it ran with a renewed energy. might be that. just sharing the experience.

  3. Sep 26, 2011 at 2:39 PM
    96 tacomaPtown

    96 tacomaPtown Well-Known Member

    Aug 28, 2009
    First Name:
    96 ext cab 4x4 taco
    3 inch spacer lift,pro comp addaleaf, 1 inch diff drop kyb shock/struts, Lc engineering header, stock muffler, hollowed cat, 2 1/4 exhaust, o2simulator , 31 10.50 15 wranglers on stock. Hella 500 headlamps, bug gaurd, vent visors, bed caps, bed liner, Volant cai intake.
    i had the same issue i was driving up a hill and was in third gear and couldnt get past 35 miles per hour speed limit was 40 and found broken catalyst jammd against my o2 sensor
To Top