1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

1996 tacoma airbag light does not come on after an hour or so

Discussion in '1st Gen. Tacomas (1995-2004)' started by intermodal, Aug 4, 2019.

  1. Aug 4, 2019 at 10:45 AM
    #1
    intermodal

    intermodal [OP] New Member

    Joined:
    Aug 4, 2019
    Member:
    #301174
    Messages:
    4
    Gender:
    Male
    Simple SRS with sensor/control module under center ash try. Steering wheel airbag only system. No accident, I am only owner, and only 144,000 miles. Great shape. Failed inspection after sitting for 2 weeks due to SRS light being on. Drove for while and light went off. Now light will not come on at all. After research, I drained the electrons from everything by removing battery and connecting both (+) and (-) to ground rod and let sit over night. Morning the light comes on and goes out after 6 seconds like it should. But after sometime, less than hour, the start up procedure will no longer include the srs light as it stays dark. I am trying to isolate the time involved so I can get it to operate correctly to will pass rejected inspection and then better address problem in future. Recently replaced battery and alternator. Never paid attention before to light possibly not coming on in past.
     
    CS_AR and GQ7227 like this.
  2. Aug 5, 2019 at 4:32 AM
    #2
    intermodal

    intermodal [OP] New Member

    Joined:
    Aug 4, 2019
    Member:
    #301174
    Messages:
    4
    Gender:
    Male
    No clues anyone? Anything?
     
    CS_AR likes this.
  3. Aug 5, 2019 at 4:41 AM
    #3
    CS_AR

    CS_AR Well-Known Member

    Joined:
    Apr 3, 2019
    Member:
    #289019
    Messages:
    1,616
    Gender:
    Male
    First Name:
    Craig
    Central AR
    Vehicle:
    1999 Tacoma PreRunner SR5 TRD
    None yet.
    As a cheap first step, I would check, clean, and use a small amount of diaelectric grease on any connector in the SRS system with the yellow plug. This may be as simple as a loose or weathered connection. Be sure to have your battery disconnected any time you touch anything SRS related.
     
  4. Aug 5, 2019 at 4:51 AM
    #4
    Blue92

    Blue92 Well-Known Member

    Joined:
    Aug 26, 2017
    Member:
    #228071
    Messages:
    7,696
    Gender:
    Male
    First Name:
    Daniel
    North Carolina
    Vehicle:
    2004 4x4 2.7L. 1992 Pickup 22RE. 2008 DCSB 4.0L
    Long shot here, but easy to check. Bulb bad in the cluster?
     
  5. Aug 5, 2019 at 12:20 PM
    #5
    intermodal

    intermodal [OP] New Member

    Joined:
    Aug 4, 2019
    Member:
    #301174
    Messages:
    4
    Gender:
    Male
    As to blue92, bulb comes on after I drain whole truck system to ground. It lights and goes off after 6 seconds like should, but this only works correctly for 5 to 15 minutes. The airbag light goes out until I drain system again.
    As to CS_AR, all connections clean and solid.
     
  6. Aug 13, 2019 at 12:31 PM
    #6
    96towcoma

    96towcoma Active Member

    Joined:
    Jul 7, 2019
    Member:
    #298538
    Messages:
    38
    Gender:
    Male
    First Name:
    james
    Vehicle:
    1996 single cab 4x4
    Drain the system while in the inspection station parking Lot and then take it to get it reinspected while it’s still working right.

    Idk if this helps you but I have a 97 similar to yours, steering airbag only, and my airbag light hangs on for about 3 minutes after start up... but only after it rains. On a normal dry day it works as it should. So I suspect somewhere in the system is succeptable to moisture.
     
  7. Aug 13, 2019 at 4:01 PM
    #7
    intermodal

    intermodal [OP] New Member

    Joined:
    Aug 4, 2019
    Member:
    #301174
    Messages:
    4
    Gender:
    Male
    Thanks. Basically did that and passed. My Auto Tech teacher in my Tech school will have students scan and diagnose when school starts up.
     

Products Discussed in

To Top