1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

1997 Tacoma A Lot of Problems No CEL (SOLVED)

Discussion in '1st Gen. Tacomas (1995-2004)' started by Tacoma1997White4x4, Dec 7, 2019.

  1. Dec 7, 2019 at 8:58 PM
    #1
    Tacoma1997White4x4

    Tacoma1997White4x4 [OP] Well-Known Member

    Joined:
    Sep 15, 2019
    Member:
    #305397
    Messages:
    197
    Gender:
    Male
    West Covina, California
    Vehicle:
    1997 white 4x4 auto 4cylinder Singlecab, 2001 auto rwd 2.4l single cab
    1997 Toyota Tacoma
    Single Cab
    4Cylinder
    2.7L
    4x4
    auto
    220xxx
    I live in Los Angeles

    Issues:
    -Rough idle
    -Hesitation on take off
    -muffler keeps making noise

    What ive done:
    -Radiator, thermostat, trans oil cjange, plugs, wires, coils, pcv, valve check, conpression good, leak down good, new brakes rotors calipers, changed oil synth, air filter, cleaned iac and throttle, replaced maf, no exhaust or vac leaks, new trans solenoids(only cel i wver got), new tires, stock wheels, new muffler but i think this muffler shop sells crappy mifflers this is the 3 rd one they put on and they all rattle on throttle, cleaned fuel injectors, i checked all the fuses, checked battery and alternator, changed power steerin pump, chamged cv axle, cat is new, changed 02 sensors both



    Ive took it to 3 mechanics and they cant figuire it out, I’m really getting sad about this because this was supposed to be my dream vehicle and is turning into a nightmare


    Things I will do (literally left to do) or I suspect:

    -ecm (i ordered oned coming monday)

    -tps (i just bought one, gotta install)
    -fuel pump
    -oem muffler(dont want no “performance” muffler i enjoy a nice quiet ride)
    -egr

    I still love this truck, I believe one day itll be all good, I mean i put everything into it except a new motor, any help will be appreciated

    my mpg 16, I do a lot of city driving, but can get 19mpg 25%highway

    truck has never ever left me stranded turns on everytime, never has stalled out once
     
  2. Dec 7, 2019 at 9:11 PM
    #2
    TacoBike

    TacoBike The Lurker

    Joined:
    Jul 27, 2018
    Member:
    #260787
    Messages:
    175
    Gender:
    Male
    First Name:
    Mason
    Shingle Springs, California
    Vehicle:
    Red 2000 3.4L Ext Cab SR5 4WD
    Replaced supercharger with N/A (For Now)
    I don't think you missed anything to fix but the only thing that you might want to replace anyway would be the lower ball joints? No idea on the idle and hesitation, normally those would be from dirty throttle body or MAF so I'm stumped.
     
    cruxofthebisquit likes this.
  3. Dec 7, 2019 at 9:13 PM
    #3
    Tacoma1997White4x4

    Tacoma1997White4x4 [OP] Well-Known Member

    Joined:
    Sep 15, 2019
    Member:
    #305397
    Messages:
    197
    Gender:
    Male
    West Covina, California
    Vehicle:
    1997 white 4x4 auto 4cylinder Singlecab, 2001 auto rwd 2.4l single cab
    I knew I forgot to lost something ALREADY CHANGED the ball joints aswell
     
    TacoBike likes this.
  4. Dec 7, 2019 at 9:15 PM
    #4
    Tacoma1997White4x4

    Tacoma1997White4x4 [OP] Well-Known Member

    Joined:
    Sep 15, 2019
    Member:
    #305397
    Messages:
    197
    Gender:
    Male
    West Covina, California
    Vehicle:
    1997 white 4x4 auto 4cylinder Singlecab, 2001 auto rwd 2.4l single cab
    I would like to mention that I am getting a new ecm because in 1999 toyota issued a tsb on the vehicle i have, ‘revised ecm :improve engine smoothness’ whatever that means
     
    Stout890 likes this.
  5. Dec 7, 2019 at 9:15 PM
    #5
    Tacoma1997White4x4

    Tacoma1997White4x4 [OP] Well-Known Member

    Joined:
    Sep 15, 2019
    Member:
    #305397
    Messages:
    197
    Gender:
    Male
    West Covina, California
    Vehicle:
    1997 white 4x4 auto 4cylinder Singlecab, 2001 auto rwd 2.4l single cab
    Also ive tried the whole disconnect battery and fuse thingy
     
  6. Dec 7, 2019 at 9:20 PM
    #6
    black coffee

    black coffee A is A.

    Joined:
    Aug 4, 2017
    Member:
    #225972
    Messages:
    5,049
    Gender:
    Male
    First Name:
    Glenn
    509
    Vehicle:
    2010 AC 4x4 SR5 V6
    Have you tried running Seafoam through the engine?
     
  7. Dec 7, 2019 at 9:24 PM
    #7
    Tacoma1997White4x4

    Tacoma1997White4x4 [OP] Well-Known Member

    Joined:
    Sep 15, 2019
    Member:
    #305397
    Messages:
    197
    Gender:
    Male
    West Covina, California
    Vehicle:
    1997 white 4x4 auto 4cylinder Singlecab, 2001 auto rwd 2.4l single cab
    No, but I’m at the point to where ill try anything

    sPeaking of that I even tried 91 “vpowah” from Shell I didnt and dont have pinging but hey I tried, Ill try seafoaming, but This monday i recieve new ecm, its plug n play, if that doesnt do it well ill drive it till i get a cel, i must be the most weirdest person to pray for a cel

    but yeah ill try seafoam
     
  8. Dec 7, 2019 at 9:24 PM
    #8
    10MGM

    10MGM Well-Known Member

    Joined:
    Dec 13, 2009
    Member:
    #27475
    Messages:
    161
    Gender:
    Male
    Vehicle:
    2010 AC MGM 4x4
    Fuel filter?
     
  9. Dec 7, 2019 at 9:25 PM
    #9
    Tacoma1997White4x4

    Tacoma1997White4x4 [OP] Well-Known Member

    Joined:
    Sep 15, 2019
    Member:
    #305397
    Messages:
    197
    Gender:
    Male
    West Covina, California
    Vehicle:
    1997 white 4x4 auto 4cylinder Singlecab, 2001 auto rwd 2.4l single cab
    Forgot to lost that aswell already changed it
     
  10. Dec 8, 2019 at 12:13 AM
    #10
    sandsloth

    sandsloth Observing

    Joined:
    Oct 14, 2012
    Member:
    #88995
    Messages:
    728
    Gender:
    Male
    Vehicle:
    97 regular cab
    Check fpr
     
  11. Dec 8, 2019 at 2:03 AM
    #11
    TacoBike

    TacoBike The Lurker

    Joined:
    Jul 27, 2018
    Member:
    #260787
    Messages:
    175
    Gender:
    Male
    First Name:
    Mason
    Shingle Springs, California
    Vehicle:
    Red 2000 3.4L Ext Cab SR5 4WD
    Replaced supercharger with N/A (For Now)
    Have you changed every sensor on the engine? They are what control idle etc. for the most part. you might have one that just isnt sending a code, not sure if that is even possible.
     
  12. Dec 8, 2019 at 2:55 AM
    #12
    Rachelsdaddy

    Rachelsdaddy Well-Known Member

    Joined:
    Jun 17, 2017
    Member:
    #221707
    Messages:
    591
    Gender:
    Male
    Vehicle:
    99 PreRunner 4x4 2.7
    Has anyone actually run across one that was bad on a 2.7? I keep wondering about mine....
     
  13. Dec 8, 2019 at 5:25 AM
    #13
    04TRDV6

    04TRDV6 Well-Known Member

    Joined:
    Sep 30, 2018
    Member:
    #267867
    Messages:
    250
    Gender:
    Male
    First Name:
    Lynn
    Houston, TX
    Vehicle:
    2004 TRD V6 XtraCab
    Do you know that the bulb for the CEL is good?

    Should be OBDII being a 97 right? Have you tried plugging a scanner into the port and seeing if there are any codes? If you don't have one, they'll do it at an auto parts store.

    Although, if you've taken it to 3 mechanics surely at least one of them would have scanned it even if the light wasn't on.
     
    cruxofthebisquit likes this.
  14. Dec 8, 2019 at 6:43 AM
    #14
    Glamisman

    Glamisman Well-Known Member

    Joined:
    Oct 22, 2016
    Member:
    #200436
    Messages:
    2,455
    Gender:
    Male
    improve engine smoothness means that Toyota has raised the idle rpm for the 4 cyls some 50 rpm.
     
    cruiserguy likes this.
  15. Dec 8, 2019 at 7:35 AM
    #15
    cruiserguy

    cruiserguy Well-Known Member

    Joined:
    Jul 31, 2016
    Member:
    #193416
    Messages:
    16,422
    Gender:
    Male
    First Name:
    Elijah
    SLC
    Vehicle:
    2000 ext cab, 2.7L, auto, 4x4
    If I memba right, he had to replace his to get his running correctly. But I hadn't heard of one on these tacos going bad before.
     
  16. Dec 8, 2019 at 7:40 AM
    #16
    Tacoma1997White4x4

    Tacoma1997White4x4 [OP] Well-Known Member

    Joined:
    Sep 15, 2019
    Member:
    #305397
    Messages:
    197
    Gender:
    Male
    West Covina, California
    Vehicle:
    1997 white 4x4 auto 4cylinder Singlecab, 2001 auto rwd 2.4l single cab
    Whats fpr?
     
  17. Dec 8, 2019 at 7:41 AM
    #17
    cruiserguy

    cruiserguy Well-Known Member

    Joined:
    Jul 31, 2016
    Member:
    #193416
    Messages:
    16,422
    Gender:
    Male
    First Name:
    Elijah
    SLC
    Vehicle:
    2000 ext cab, 2.7L, auto, 4x4
    Fuel pressure regulator
     
  18. Dec 8, 2019 at 7:41 AM
    #18
    Tacoma1997White4x4

    Tacoma1997White4x4 [OP] Well-Known Member

    Joined:
    Sep 15, 2019
    Member:
    #305397
    Messages:
    197
    Gender:
    Male
    West Covina, California
    Vehicle:
    1997 white 4x4 auto 4cylinder Singlecab, 2001 auto rwd 2.4l single cab
    no, like the fuses?
     
  19. Dec 8, 2019 at 7:42 AM
    #19
    Tacoma1997White4x4

    Tacoma1997White4x4 [OP] Well-Known Member

    Joined:
    Sep 15, 2019
    Member:
    #305397
    Messages:
    197
    Gender:
    Male
    West Covina, California
    Vehicle:
    1997 white 4x4 auto 4cylinder Singlecab, 2001 auto rwd 2.4l single cab
    wouldnt that throw a code?
     
  20. Dec 8, 2019 at 7:44 AM
    #20
    Tacoma1997White4x4

    Tacoma1997White4x4 [OP] Well-Known Member

    Joined:
    Sep 15, 2019
    Member:
    #305397
    Messages:
    197
    Gender:
    Male
    West Covina, California
    Vehicle:
    1997 white 4x4 auto 4cylinder Singlecab, 2001 auto rwd 2.4l single cab
    yes the cel bulb does work, 3 mechanics have scanned it....nothin
     

Products Discussed in

To Top