1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

1997 Tacoma A Lot of Problems No CEL (SOLVED)

Discussion in '1st Gen. Tacomas (1995-2004)' started by Tacoma1997White4x4, Dec 7, 2019.

  1. Dec 12, 2019 at 10:38 AM
    #41
    ireymon

    ireymon Unknown Member

    Joined:
    Oct 19, 2017
    Member:
    #233460
    Messages:
    304
    Gender:
    Male
    First Name:
    Kenneth
    Winston-Salem, NC
    Vehicle:
    99 X-Cab 5 lug 5 speed
    clearcoat failure, dings and dents...
    I know you said you checked the battery and alternator but I came across the thread below and sounds like a new battery fixed his "shaking at startup" issue. Might be worth checking the battery again if its more than a few years old. Maybe the voltage isn't where it should be? I need to check mine when I get home because it's almost 7 years old.

    https://www.tacomaworld.com/threads/shaking-at-startup-and-delay.641009/
     
  2. Dec 12, 2019 at 1:47 PM
    #42
    Rachelsdaddy

    Rachelsdaddy Well-Known Member

    Joined:
    Jun 17, 2017
    Member:
    #221707
    Messages:
    591
    Gender:
    Male
    Vehicle:
    99 PreRunner 4x4 2.7
    Hmmmmmmmmmmm
     
  3. Dec 12, 2019 at 6:55 PM
    #43
    Tacoma1997White4x4

    Tacoma1997White4x4 [OP] Well-Known Member

    Joined:
    Sep 15, 2019
    Member:
    #305397
    Messages:
    197
    Gender:
    Male
    West Covina, California
    Vehicle:
    1997 white 4x4 auto 4cylinder Singlecab, 2001 auto rwd 2.4l single cab
    ima buy one, and funny enough i already read your post about a month ago lol ive tooken it to muff shop and they said its nit rattling
     
  4. Dec 12, 2019 at 6:56 PM
    #44
    Tacoma1997White4x4

    Tacoma1997White4x4 [OP] Well-Known Member

    Joined:
    Sep 15, 2019
    Member:
    #305397
    Messages:
    197
    Gender:
    Male
    West Covina, California
    Vehicle:
    1997 white 4x4 auto 4cylinder Singlecab, 2001 auto rwd 2.4l single cab
    I tried that aswell, same thing
     
  5. Dec 12, 2019 at 6:59 PM
    #45
    Tacoma1997White4x4

    Tacoma1997White4x4 [OP] Well-Known Member

    Joined:
    Sep 15, 2019
    Member:
    #305397
    Messages:
    197
    Gender:
    Male
    West Covina, California
    Vehicle:
    1997 white 4x4 auto 4cylinder Singlecab, 2001 auto rwd 2.4l single cab
    So I booked an appointment at the stealership on Saturday @7am, ill keep updating to help someone else down the road, thx everyone
     
  6. Dec 12, 2019 at 7:01 PM
    #46
    Rachelsdaddy

    Rachelsdaddy Well-Known Member

    Joined:
    Jun 17, 2017
    Member:
    #221707
    Messages:
    591
    Gender:
    Male
    Vehicle:
    99 PreRunner 4x4 2.7
    Thank you. I’m dying to hear what is found. Maybe you should start a gofund me to pay the dealership....
     
  7. Dec 12, 2019 at 7:57 PM
    #47
    Tacoma1997White4x4

    Tacoma1997White4x4 [OP] Well-Known Member

    Joined:
    Sep 15, 2019
    Member:
    #305397
    Messages:
    197
    Gender:
    Male
    West Covina, California
    Vehicle:
    1997 white 4x4 auto 4cylinder Singlecab, 2001 auto rwd 2.4l single cab
    Yeah I’m also curious to see what theyll find...if anything, I’m keeping my hopes not too high cus i wouldnt be surprised if they say “we dont know”, but yeah stay tuned i’ll update
     
  8. Dec 13, 2019 at 9:10 AM
    #48
    ireymon

    ireymon Unknown Member

    Joined:
    Oct 19, 2017
    Member:
    #233460
    Messages:
    304
    Gender:
    Male
    First Name:
    Kenneth
    Winston-Salem, NC
    Vehicle:
    99 X-Cab 5 lug 5 speed
    clearcoat failure, dings and dents...
    I checked my battery voltage last night hoping it was drastically low and would give me something else to try - nope... 12.58 v
     
  9. Dec 14, 2019 at 2:34 PM
    #49
    Tacoma1997White4x4

    Tacoma1997White4x4 [OP] Well-Known Member

    Joined:
    Sep 15, 2019
    Member:
    #305397
    Messages:
    197
    Gender:
    Male
    West Covina, California
    Vehicle:
    1997 white 4x4 auto 4cylinder Singlecab, 2001 auto rwd 2.4l single cab
    So I went to the stealership today @7:30am and boy am I glad i booked an appointment cus when I got there it looked like a line before the dmv opens, so 7hours later they told me from what they gathered was OEM trans and engine mounts and the hesitation was from my driveshaft, what do yall think? I checked my transmounts myself got like 3 different opinions on mechanics said they looked good,i changed the engine mounts myself a month ago, so thats what they told me.....

    I’ll update as I will get these installed
     
  10. Dec 14, 2019 at 4:15 PM
    #50
    ireymon

    ireymon Unknown Member

    Joined:
    Oct 19, 2017
    Member:
    #233460
    Messages:
    304
    Gender:
    Male
    First Name:
    Kenneth
    Winston-Salem, NC
    Vehicle:
    99 X-Cab 5 lug 5 speed
    clearcoat failure, dings and dents...
    I'm definitely curious if mounts fixes your situation. I've wondered that for myself. I bought Beck Arnley mounts thinking they would be OK but I've read people having issues with non-OEM mounts so ‍I dunno
     
  11. Dec 14, 2019 at 4:26 PM
    #51
    Rachelsdaddy

    Rachelsdaddy Well-Known Member

    Joined:
    Jun 17, 2017
    Member:
    #221707
    Messages:
    591
    Gender:
    Male
    Vehicle:
    99 PreRunner 4x4 2.7
    Really.... well, that’s why they get 125hr but it ain’t my problem for sure. Normally runs generally crappy (by my standards anyway) then, out of the blue it begins running like an entirely different truck but only for a short time then it’s back to usual... I hope it solves your problems though
     
  12. Dec 14, 2019 at 4:26 PM
    #52
    Tacoma1997White4x4

    Tacoma1997White4x4 [OP] Well-Known Member

    Joined:
    Sep 15, 2019
    Member:
    #305397
    Messages:
    197
    Gender:
    Male
    West Covina, California
    Vehicle:
    1997 white 4x4 auto 4cylinder Singlecab, 2001 auto rwd 2.4l single cab
    They said needed oem mounts, also drive shaft was giving me hesititation from takeoff even after greasing, I just ordered the engine mounts and trans mount online oem should be here 12/20 I should have them installed next week Saturday, I also will have my new muffler installed this coming weekday, as far as the driveshaft its about $500 for part, ima take it to a shop first and see what they can do
     
  13. Dec 20, 2019 at 4:14 PM
    #53
    Tacoma1997White4x4

    Tacoma1997White4x4 [OP] Well-Known Member

    Joined:
    Sep 15, 2019
    Member:
    #305397
    Messages:
    197
    Gender:
    Male
    West Covina, California
    Vehicle:
    1997 white 4x4 auto 4cylinder Singlecab, 2001 auto rwd 2.4l single cab
    So after ordering the oem transmount toyotapartsdeal cancelled on me because it was discontinued aswell as dealer, so I bought one off of oreilly and when getting ready to install you can clearly see they were different, i returned the part told the guy the part was wrong, but the part number12371-035090 was the correct one the one on mine looks like a v6 one but i have a 4cylinder auto..........im stumped, helpD6F17E7B-1AE2-466C-BD64-C851282C8FC1.jpg 2262D6DC-B1AF-492D-9676-80F660DB1119.jpg EB429A1E-1A5B-4171-B113-92B3B329B833.jpg
     
  14. Dec 26, 2019 at 5:45 PM
    #54
    nzbrock

    nzbrock Well-Known Member

    Joined:
    Jan 6, 2013
    Member:
    #94572
    Messages:
    2,187
    Gender:
    Male
    First Name:
    Noah
    San Marcos, TX
    Vehicle:
    99 TRD Prerunner 3RZ
    SAW 2.0 Coilovers Wheeler's 5 Leaf + 3 AAL Bilstein 5100s LCE long tube header Flowmaster Delta 50 Muffler FJ Trail Team Wheels 255/85/16 Cooper ST Maxx 4Runner overhead sunglass console 4Runner leather seats All LED lights Red/Clear Tail Light Tundra Brakes HID Projector Retrofits 4Runner Auto Up/Down Windows Bullet Liner Cargo tie down system E-locker axle swap w/4.56 Gears ARE MX Cap Prinsu Toprac Custom heated turn signal/puddle light mirrors Volant Intake Tube
    not sure if this helps but 1237175090 is the part number for my 99 4cyl auto 2WD PRERUNNER.

    if you want to find the right one for your truck go to toyodiy.com and plug in your vin.

    the part is called “INSULATOR, ENGINE MOUNTING, REAR NO.1”
     
  15. Dec 28, 2019 at 7:06 PM
    #55
    Tacoma1997White4x4

    Tacoma1997White4x4 [OP] Well-Known Member

    Joined:
    Sep 15, 2019
    Member:
    #305397
    Messages:
    197
    Gender:
    Male
    West Covina, California
    Vehicle:
    1997 white 4x4 auto 4cylinder Singlecab, 2001 auto rwd 2.4l single cab
    I did purchase the correct part for the truck turns out it’s discontinued nationwide, went on Amazon and Toyota sells it, but when checking fitment it says wont fit, well it will because they just have a picture of part number, but the funny thing is that theyre not gonna ship it till March 26, 2020 .....so yeah gotta wait, but thanks
     
  16. Mar 4, 2020 at 3:19 PM
    #56
    Rachelsdaddy

    Rachelsdaddy Well-Known Member

    Joined:
    Jun 17, 2017
    Member:
    #221707
    Messages:
    591
    Gender:
    Male
    Vehicle:
    99 PreRunner 4x4 2.7
    What was the outcome of all of this? Is it finally running right or was it burned beneath an overpass in Philadelphia?
     
    det107 likes this.
  17. Mar 4, 2020 at 6:42 PM
    #57
    Stout890

    Stout890 Well-Known Member

    Joined:
    May 8, 2011
    Member:
    #56287
    Messages:
    860
    Gender:
    Male
    First Name:
    Jason
    Palmdale ca
    Vehicle:
    99 prerunner sr5
    Navigation, 10" sub, ome881 on billies 3" all-pro leaf springs with billies, taneau cover, k&n intake,axle swap with a E locker. 31" BFG A/T on KMC XD wheels, hoola girl air freshener and a broadie knob!
    where and how much was the ECM? i got on off ebay for my truck but didnt know about this TSB. is it for any 2.7 ECM ex. automatic or manual, federal or california emissions?
     
  18. Mar 4, 2020 at 8:15 PM
    #58
    Glamisman

    Glamisman Well-Known Member

    Joined:
    Oct 22, 2016
    Member:
    #200436
    Messages:
    2,455
    Gender:
    Male
    if possible take the exhaust off after the cat / before the muffler... I am thinking the reason the previous owner replaced the cat might be because it broke apart and the bits could be plugging the exhaust.
     
  19. Mar 4, 2020 at 8:58 PM
    #59
    jbrandt

    jbrandt Well-Known Member

    Joined:
    Feb 12, 2011
    Member:
    #51038
    Messages:
    12,100
    Gender:
    Male
    Sacramento, CA
    Vehicle:
    '04 TRD Tacoma 4x4 DC
    King ext travel coils Total Chaos UCAs Custom skids Sticker mod
    I would say have the dealer throw as many parts at it that they are willing to try, but be sure to tell them you're only paying for the parts that actually FIX the problem.
     
  20. Mar 5, 2020 at 4:52 PM
    #60
    Tacoma1997White4x4

    Tacoma1997White4x4 [OP] Well-Known Member

    Joined:
    Sep 15, 2019
    Member:
    #305397
    Messages:
    197
    Gender:
    Male
    West Covina, California
    Vehicle:
    1997 white 4x4 auto 4cylinder Singlecab, 2001 auto rwd 2.4l single cab
    Truck still shakes at idle but ive learned to live with it, hey it still turns on everytime and has NEVER LEFT ME so im good with that, but i would say i will eventually get a cel or it probbly is my exhaust but it looks good
     

Products Discussed in

To Top