1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2002 Tacoma/Prerunner 2.7 liter auto 2WD

Discussion in '1st Gen. Tacomas' started by davidwilliams788, Oct 18, 2013.

  1. Oct 18, 2013 at 5:51 PM
    #1
    davidwilliams788

    davidwilliams788 [OP] Member

    Joined:
    Jun 25, 2013
    Member:
    #107051
    Messages:
    6
    Gender:
    Male
    Vehicle:
    02 2wd prerunner auto 2.7 liter
    Very odd problems. Had the truck a few months...working great, even though the rpm guage was dead, engine light on, & after a minute of driving from cold the temp guage pegs. All of a sudden it started to run rough..cut out restarted ok, I noticed a small transmission leak, got it fixed, & topped off, but that was just a lucky find, & hasn't helped the problem. The truck has been running very bad, & backfiring, my mechanic had it three weeks, & has no clue what it is. He cut a small hole in the exhaust to see if it was blocked..(the convertor).He said it had emission codes, but it shouldn't make it run so bad as it is, & had replaced the rear heated O2 sensor, & can't find anything wrong. He's stumped. I took it back unhooked the battery & did lots of static checks, & found nothing bad. I found the front most injector had the two wires taped up, but it was fine. I removed ECU behind glove box, wiring, ECU look fine, all coil over plugs, TPS measure ok, no vacuum leaks, after my troubleshooting, it ran almost perfect for three days, now it's back again. I have removed the EFI fuse for a while, cleared the codes....just so I could use the truck. I just now bought an OBD11 code reader, & will look closer next day or so. Has anyone seen this type of odd problem? Also, I want to buy a Tacoma, or four runner for parts. Which one would have the same TPS, ECU, EGR valve etc? I mean what year, & model? Has to be a 2.7 liter right? Thanks, in advance.
     
To Top