1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2003-04 Tacoma TPS

Discussion in '1st Gen. Tacomas' started by beantown, Jun 27, 2014.

  1. Jun 27, 2014 at 6:00 AM
    #1
    beantown

    beantown [OP] Active Member

    Joined:
    Feb 4, 2014
    Member:
    #122242
    Messages:
    32
    Gender:
    Male
    Hello,

    I have a 2004 DC 4X4 3.4 and am having some problems with stuttering at a light or even some RPM fluttering at like 55 or 60. Someone on here suggested I change the TPS. So I read some forums and it seemed like that is what my problem is. I am also having a EVAP problem, some leak in the gas line, since I do not get suction when I open the gas cap and a CEL light(Po446 and Po442) Are they related? I don't know. Anyway, I wanted to replace the TPS. So, I went to the dealer and they told me that I could not get the TPS for a 03-04, I had to buy the whole TB. $1300 bucks! So, I went on line and found a TPS for an 2004 my style for 68.00, ordered it and it did not fit. The wire plug had 3 prongs and the receiver had 4. Anyway, I was just wondering if anyone with a 03-04 had replaced their TPS? Or for that matter had problems like I am having with mine.

    Thanks for all your help.
     
  2. Jun 27, 2014 at 10:24 AM
    #2
    Rons01TRD

    Rons01TRD Well-Known Member

    Joined:
    May 30, 2012
    Member:
    #79732
    Messages:
    732
    Gender:
    Male
    First Name:
    Ron
    Virginia Beach, VA
    Vehicle:
    2003 4Runner 4WD
    I bought just the TPS sensor mine's an 01' ........I would call other dealerships and see if they would sell just the sensor.
     
  3. Jun 27, 2014 at 10:27 AM
    #3
    frizzman

    frizzman Well-Known Member

    Joined:
    Sep 25, 2013
    Member:
    #113212
    Messages:
    890
    Gender:
    Male
    da 'burgh, PA
    Vehicle:
    04 XCab 4x4 TRD/OR
    hitch w/ 7-pin (custom wired), Leer cap (LMM), Green Filter, JVC head unit (orange color to match), Infinity amp/10" subs. Undercover tonneau.
    sub'd for info. I have high and low rpm fluctuations out of gear and sometimes driving. no codes tho :(
     
  4. Jun 28, 2014 at 10:20 AM
    #4
    chowwwww

    chowwwww Well-Known Member

    Joined:
    Jun 9, 2014
    Member:
    #131583
    Messages:
    406
    Gender:
    Male
    Orange County
    Vehicle:
    03 Doublecab 4x4
    Billys 5100/Eibach and Wheelers Progressive 1.5 AAL with overload in
    Same issue. I ordered the tps and also received a 3 prong. Gonna try to return it today and see if they have a 4 prong
     
  5. Jun 28, 2014 at 1:03 PM
    #5
    chowwwww

    chowwwww Well-Known Member

    Joined:
    Jun 9, 2014
    Member:
    #131583
    Messages:
    406
    Gender:
    Male
    Orange County
    Vehicle:
    03 Doublecab 4x4
    Billys 5100/Eibach and Wheelers Progressive 1.5 AAL with overload in
    Still can't find the right sensor, but I read on another forum that taking it off and reinstalling it might work.
     
  6. Jun 28, 2014 at 1:16 PM
    #6
    meatman

    meatman I deal with dead animals

    Joined:
    Mar 24, 2011
    Member:
    #53630
    Messages:
    2,668
    Gender:
    Male
    First Name:
    Greg
    Murphy N.C.
    Vehicle:
    01 Tacoma TRD SR5
    More than the wife knows!
    01-02 had the 3 prong TPS while the 03-04 were the 4 wire ones and no you can't buy one from the dealer (have to get the whole TB). There was someone who sourced some from overseas but had to get 5 of them at a time. I think the difference is that the 03-04 are a drive by wire throttle body.
     
  7. Jun 28, 2014 at 1:27 PM
    #7
    chowwwww

    chowwwww Well-Known Member

    Joined:
    Jun 9, 2014
    Member:
    #131583
    Messages:
    406
    Gender:
    Male
    Orange County
    Vehicle:
    03 Doublecab 4x4
    Billys 5100/Eibach and Wheelers Progressive 1.5 AAL with overload in
    Yup. That's what I read and was told. Trucks not throwing any coded yet so I'm hopyng taking the tps off and readjusting it will work. What are the correct ohms suppose to be at so I can check mine.
     
  8. Jun 28, 2014 at 1:44 PM
    #8
    chowwwww

    chowwwww Well-Known Member

    Joined:
    Jun 9, 2014
    Member:
    #131583
    Messages:
    406
    Gender:
    Male
    Orange County
    Vehicle:
    03 Doublecab 4x4
    Billys 5100/Eibach and Wheelers Progressive 1.5 AAL with overload in
  9. Jun 28, 2014 at 2:01 PM
    #9
    newertoy

    newertoy Well-Known Member

    Joined:
    Feb 27, 2010
    Member:
    #32204
    Messages:
    1,505
    Gender:
    Male
    First Name:
    Kevin
    East Tn
    Vehicle:
    2003 4x4 extra cab
    2" lift AAL and Bilstiens-front-rear,front diff drop. main drive drop
    someone was selling them here a while ago-you might need to do a search. Cannot remember who it was.
     
  10. Jun 30, 2014 at 6:33 AM
    #10
    beantown

    beantown [OP] Active Member

    Joined:
    Feb 4, 2014
    Member:
    #122242
    Messages:
    32
    Gender:
    Male
  11. Jul 10, 2014 at 3:00 PM
    #11
    chowwwww

    chowwwww Well-Known Member

    Joined:
    Jun 9, 2014
    Member:
    #131583
    Messages:
    406
    Gender:
    Male
    Orange County
    Vehicle:
    03 Doublecab 4x4
    Billys 5100/Eibach and Wheelers Progressive 1.5 AAL with overload in
    any updates? Would like to know so that once i take my cast off and have two hands, i can change mine.
     
  12. Jul 15, 2014 at 9:59 AM
    #12
    beantown

    beantown [OP] Active Member

    Joined:
    Feb 4, 2014
    Member:
    #122242
    Messages:
    32
    Gender:
    Male
    Hello all,

    I just wanted to give an update on this problem. I bought two different TPS off the internet to replace mine. The first was a 3 wire one, that was wrong, the 2003 and 2004 have a 4 wire TPS. So I found a 4 Wire TPS and bought that, it was right about 68 bucks and change. It looked to be the correct one with the 4 wire and the correct plug. So I installed it, not really looking it over, and started the car. It idled fine, but would only respond to the HEAVY push of the accelerator. So I took it out and really looked at it, and it seems the internal moving parts worked opposite to original part. It basically twisted counter clockwise and the original twisted clockwise. So, I took it and put the original part back on. Now the truck runs great! Maybe it just needed a little of adjustment. Just got back from a 7 hour trip each way, and I didnt feel the hesitation once. (Knock on wood) So if anyone is having the symptoms that I had, just pull it off and reinstall.

    Thanks so much.
     
  13. Jul 15, 2014 at 10:01 AM
    #13
    beantown

    beantown [OP] Active Member

    Joined:
    Feb 4, 2014
    Member:
    #122242
    Messages:
    32
    Gender:
    Male
    Here is the 4 wire TPS, so you can see the insides...

    photo[2].jpg
     
  14. Jul 16, 2014 at 7:42 AM
    #14
    chowwwww

    chowwwww Well-Known Member

    Joined:
    Jun 9, 2014
    Member:
    #131583
    Messages:
    406
    Gender:
    Male
    Orange County
    Vehicle:
    03 Doublecab 4x4
    Billys 5100/Eibach and Wheelers Progressive 1.5 AAL with overload in
    Thats great. I read in another forum to do the same thing. Did you take your whole TB off to get the TPS off or were you ale to get the bottom screw off fine? Once I get my cast off i will be taking off my TPS and reinstalling it.
     
  15. Jul 17, 2014 at 5:49 AM
    #15
    beantown

    beantown [OP] Active Member

    Joined:
    Feb 4, 2014
    Member:
    #122242
    Messages:
    32
    Gender:
    Male
    I had to use some visegrips to get the bottom screw off, I really can't believe they use Philips head screws. I went to ace and bought some Allen head screws and washers to replace both screws... It worked great, and now I can get it off when ever I need to, for re-adjusting.How this helps...
     
  16. Jul 17, 2014 at 7:03 AM
    #16
    MadMtnMikey

    MadMtnMikey Well-Known Member

    Joined:
    Aug 22, 2011
    Member:
    #62120
    Messages:
    1,476
    Gender:
    Male
    First Name:
    Mike
    Richmond/VaBeach
    Vehicle:
    03 DC 4x4 SR5 TRD
    For some reason the dealerships do not source this part individually, but Toyota does distribute them. I replaced mine back in early spring. I was able to source it at CarQuest autoparts, and it's a genuine toyota part. The price was a bit more steep, at $95.
     
  17. Jul 17, 2014 at 7:10 AM
    #17
    chowwwww

    chowwwww Well-Known Member

    Joined:
    Jun 9, 2014
    Member:
    #131583
    Messages:
    406
    Gender:
    Male
    Orange County
    Vehicle:
    03 Doublecab 4x4
    Billys 5100/Eibach and Wheelers Progressive 1.5 AAL with overload in
    I was able to remove the top screw with a vicescrip. Hard to get my cast down low enough to reach the bottom one. I will most likely take your idea with the allen head screws. If it does not work, I will try CarQuest.
     
  18. Jul 21, 2014 at 12:08 PM
    #18
    2k4Taco

    2k4Taco Well-Known Member

    Joined:
    Oct 13, 2011
    Member:
    #65119
    Messages:
    323
    Gender:
    Male
    First Name:
    Swanny
    Kailua, HI
    Vehicle:
    04 DC TRD Prerunner
    265/75/16 Falken Wild Peaks, 5100/5125 Billys,ToyTec/Eibach Coils, Wheelers 3 Leaf, ToyTec U Bolt Flip, TopGunzCustoms 1.5in Lift Shackles, Deckplate, Tint, Jeraco Topper.
    OP did you put it back on at the prior position? Or actually adjust it?
     
  19. Jul 22, 2014 at 4:49 PM
    #19
    beantown

    beantown [OP] Active Member

    Joined:
    Feb 4, 2014
    Member:
    #122242
    Messages:
    32
    Gender:
    Male
    I just kind of centered it. It moved around pretty easily. I really didn't check where it was when i took it off. I just made sure there was no play on the spring inside....
     
  20. Jul 23, 2014 at 7:54 AM
    #20
    chowwwww

    chowwwww Well-Known Member

    Joined:
    Jun 9, 2014
    Member:
    #131583
    Messages:
    406
    Gender:
    Male
    Orange County
    Vehicle:
    03 Doublecab 4x4
    Billys 5100/Eibach and Wheelers Progressive 1.5 AAL with overload in
    Do you remember what size the screws you bought were?
     
To Top