1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2005 PreRunner TRD Sport wont start

Discussion in '2nd Gen. Tacomas (2005-2015)' started by yaroshc, Apr 23, 2008.

  1. Apr 23, 2008 at 9:21 AM
    #1
    yaroshc

    yaroshc [OP] Member

    Joined:
    Apr 2, 2008
    Member:
    #5694
    Messages:
    10
    Austin
    Vehicle:
    Tacoma Sport
    Alpine Stero, Front Grill Guard, KC lights
    At a loss??? Parked truck on slight angle rd and wont start. Took it out of park and put back in park and it started. Shut it off and it wont start again. Tried this again, and it did not start.
    Here is the low down.
    2 weeks ago dealer performed a 60K Fuel Injector Cleaning.. No problems during last 2 weeks.
    Here is what I did when it did not start
    Checked the Relay (removed the cover and noticed that the relay was not closing) during cranking. It is getting 12v, but I do not see the ground to close the relay
    Engine does turn over, but no gas is being delivered to the engine. (hence I thought it was an elect problem with the relay. Pulled the relay and it is working properly when out of the truck but not when its in the truck.
    Towed it to dealer, and they say its the fuel pump...... Going to tow it back tonight and order a pump... That relay just has me stumped.

    Anyone know where to get a good pump... dealer wants over $600
     
  2. Apr 23, 2008 at 11:49 AM
    #2
    ANDYTACOMA

    ANDYTACOMA NOMAD

    Joined:
    Sep 21, 2007
    Member:
    #2760
    Messages:
    270
    Vehicle:
    2006 access cab trd offroad 4x4 black sand pe
    fog light mod /parking light mod /after market stereo /bed lights/yeasu ft8700/uniden bct15
  3. Apr 23, 2008 at 12:07 PM
    #3
    yaroshc

    yaroshc [OP] Member

    Joined:
    Apr 2, 2008
    Member:
    #5694
    Messages:
    10
    Austin
    Vehicle:
    Tacoma Sport
    Alpine Stero, Front Grill Guard, KC lights
    Found this one for 419.00

    http://www.toyota-parts.com/oem_parts.html

    Just hate to spend 400 plus and towing, and it be something else.

    Has anyone else had fuel delivery issues? BTW mine is at 70K miles. and out of warranty :(
     
To Top