1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2005 Xrunner- NO POWER and Black smoke.

Discussion in 'Underdog Racing Development' started by rockstar626, Aug 8, 2012.

  1. Aug 8, 2012 at 7:16 AM
    #1
    rockstar626

    rockstar626 [OP] Member

    Joined:
    Aug 8, 2012
    Member:
    #84328
    Messages:
    13
    Gender:
    Male
    Virginia
    Vehicle:
    05 XRUNNER-URD
    URD supercharger
    Hi,

    First post here, but could really use some help right now. I work for a small auto dealership and we recently sold a 2005 Toyota Tacoma Xrunner. It has a URD Supercharger on it, what stage, I do not know.

    It has been running great until now. We sold it about 1 month ago and it only has 27k miles on it.

    The customer had it towed it because there was black smoke coming from the tailpipe and absolutely no power at all!! I dont even know where to start. I have tried calling URD and they have not gotten back to us yet, so I am reaching out to the community to see what we should do first. I wanna take care of this customer and the local Toyota Dealer is scared to mess with it. Any advice would be appreciated.

    ps Traction oil is full. Belt seems OK. We obviously do not have the scan tool to talk to the truck.
     
  2. Aug 8, 2012 at 7:24 AM
    #2
    98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,164
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
    Sounds like too much fuel. What else is on the truck as far as URD and aftermarket components?

    Also, you can try these guys. You may get a faster response or possibly the previous owner...

    http://www.xr-underground.com/
     
  3. Aug 8, 2012 at 7:42 AM
    #3
    rockstar626

    rockstar626 [OP] Member

    Joined:
    Aug 8, 2012
    Member:
    #84328
    Messages:
    13
    Gender:
    Male
    Virginia
    Vehicle:
    05 XRUNNER-URD
    URD supercharger
    Not sure. It looks like its pretty stock. No exhaust work appears to have been done either. Ill try to get a pic on here soon.

    When we took it to Toyota, they said that when they "clear" the codes, the truck runs good for 3- 4 minutes, then goes back into a closed loop. Thats when the problems begin again. I have been told that Toyotas scan tool can not talk to the URD set up. Is this correct?
     
  4. Aug 8, 2012 at 7:47 AM
    #4
    98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,164
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
    That, I do not know. What code(s) does it throw? Or is it spefically a URD code?
     
  5. Aug 8, 2012 at 7:53 AM
    #5
    chadderkdawg

    chadderkdawg Don't ask questions you don't want the answer to..

    Joined:
    Apr 29, 2011
    Member:
    #55763
    Messages:
    8,184
    Gender:
    Male
    Des Moines, Iowa
    Vehicle:
    09 FX4 F150
    How can you be absolutely sure the URD is to blame?
     
  6. Aug 8, 2012 at 7:57 AM
    #6
    TRD6Speed

    TRD6Speed senior member

    Joined:
    Apr 29, 2011
    Member:
    #55779
    Messages:
    756
    Gender:
    Male
    First Name:
    Bill
    East Hartford, CT
    Vehicle:
    08 TRD Sport Access Cab
    885x with 5100s and top plate spacer for full 3", RCD extended 5100s in rear, dakars, flip kit, LR UCAs, tint, shorty antenna, in channel rain guards,BHLM, blacked out emblem, OEM side steps, weathertechs, debadged, rear diff breather
    :rolleyes:
    is blame being tossed or help being requested by someone that may have the knowledge to help? like the maker of the SC?
     
  7. Aug 8, 2012 at 7:59 AM
    #7
    chadderkdawg

    chadderkdawg Don't ask questions you don't want the answer to..

    Joined:
    Apr 29, 2011
    Member:
    #55763
    Messages:
    8,184
    Gender:
    Male
    Des Moines, Iowa
    Vehicle:
    09 FX4 F150
    I just ask because OP stated he doesn't know where to begin, but it seems as if the only thing he is concerned with is the URD.... Just trying to help think outside of the box a little.
     
  8. Aug 8, 2012 at 8:03 AM
    #8
    babytruck

    babytruck Babytruck, babytruck...I've got a babytruck :)

    Joined:
    May 17, 2011
    Member:
    #56797
    Messages:
    9,005
    Gender:
    Female
    NorCal
    Vehicle:
    2010 Barcelona AC 4x4 4.0 6spd
    Oh I feel so confident now.
     
  9. Aug 8, 2012 at 8:05 AM
    #9
    rockstar626

    rockstar626 [OP] Member

    Joined:
    Aug 8, 2012
    Member:
    #84328
    Messages:
    13
    Gender:
    Male
    Virginia
    Vehicle:
    05 XRUNNER-URD
    URD supercharger
    We dont know the SC is to blame. All I can give is symptoms. No check engine light. No nothing other than symptoms and a modded truck that we can not talk too or reset. If it was stock this would be a whole lot easier, but I have faith that someone in this community can say"start here".
     
  10. Aug 8, 2012 at 8:05 AM
    #10
    TRD6Speed

    TRD6Speed senior member

    Joined:
    Apr 29, 2011
    Member:
    #55779
    Messages:
    756
    Gender:
    Male
    First Name:
    Bill
    East Hartford, CT
    Vehicle:
    08 TRD Sport Access Cab
    885x with 5100s and top plate spacer for full 3", RCD extended 5100s in rear, dakars, flip kit, LR UCAs, tint, shorty antenna, in channel rain guards,BHLM, blacked out emblem, OEM side steps, weathertechs, debadged, rear diff breather
    I think he is troubleshooting and seeing that the only visible mod is the SC he is "beginning" correctly by trying to contact Gadget or others with the knowledge to prob help before he starts wrenching or causing more damage.

    OP.....nice to see you taking care of the your customer. GL with fix
     
  11. Aug 8, 2012 at 8:07 AM
    #11
    TRD6Speed

    TRD6Speed senior member

    Joined:
    Apr 29, 2011
    Member:
    #55779
    Messages:
    756
    Gender:
    Male
    First Name:
    Bill
    East Hartford, CT
    Vehicle:
    08 TRD Sport Access Cab
    885x with 5100s and top plate spacer for full 3", RCD extended 5100s in rear, dakars, flip kit, LR UCAs, tint, shorty antenna, in channel rain guards,BHLM, blacked out emblem, OEM side steps, weathertechs, debadged, rear diff breather
    beat me to it.......good stuff
     
  12. Aug 8, 2012 at 8:17 AM
    #12
    rockstar626

    rockstar626 [OP] Member

    Joined:
    Aug 8, 2012
    Member:
    #84328
    Messages:
    13
    Gender:
    Male
    Virginia
    Vehicle:
    05 XRUNNER-URD
    URD supercharger
    No check engine light is on and I am being told that there are no codes in "Toyotas ECM". I am being told that there is a seperate programmer to adjust the URD to make it do different things. So perhaps there is an error code in the URD. Does this make sense?

    One more thing. Toyota has said that when they "clear" the ECM, the truck runs fine for 3-5 minutes, and then right back where we started, bogging down and black smoke.
     
  13. Aug 8, 2012 at 8:19 AM
    #13
    whippersnapper02

    whippersnapper02 Well-Known Member

    Joined:
    Dec 20, 2009
    Member:
    #27905
    Messages:
    35,214
    Gender:
    Male
    First Name:
    Christian
    Yorba Linda, CA
    Vehicle:
    10 MGM TRD OR 4wd Auto DCSB
    Banks Monster Exhaust, Pop n Lock tailgate lock, Hook-Ups tie down brackets, USA Spec Ipod adaptor, WO seat covers, color matched grill with Grillcraft insert, Tuffy locking bed box
    Did a boost pipe come off?
     
  14. Aug 8, 2012 at 8:20 AM
    #14
    98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,164
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
    Yes, it makes sense. They come with fuel management controllers. Just need to know which one and perhaps we can find the software for it.
     
  15. Aug 8, 2012 at 8:25 AM
    #15
    TRD6Speed

    TRD6Speed senior member

    Joined:
    Apr 29, 2011
    Member:
    #55779
    Messages:
    756
    Gender:
    Male
    First Name:
    Bill
    East Hartford, CT
    Vehicle:
    08 TRD Sport Access Cab
    885x with 5100s and top plate spacer for full 3", RCD extended 5100s in rear, dakars, flip kit, LR UCAs, tint, shorty antenna, in channel rain guards,BHLM, blacked out emblem, OEM side steps, weathertechs, debadged, rear diff breather
    ya...they have fuel and igntion controllers.........If it runs fine for 3 to 5 minutes then bogs it def sounds like gas/air ratio is getting fubar'd. I think you are on the right path with getting the controller identified then programmed correctly.

    dammit.....98 tacome was faster....damn BF! flying the chopper
     
  16. Aug 8, 2012 at 8:26 AM
    #16
    98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,164
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
    I think it should be kept simple too and look for a loose vacuum or pipe as Whipper asked. Maybe even a loose wiring connection for the controller.
     
  17. Aug 8, 2012 at 8:29 AM
    #17
    TRD6Speed

    TRD6Speed senior member

    Joined:
    Apr 29, 2011
    Member:
    #55779
    Messages:
    756
    Gender:
    Male
    First Name:
    Bill
    East Hartford, CT
    Vehicle:
    08 TRD Sport Access Cab
    885x with 5100s and top plate spacer for full 3", RCD extended 5100s in rear, dakars, flip kit, LR UCAs, tint, shorty antenna, in channel rain guards,BHLM, blacked out emblem, OEM side steps, weathertechs, debadged, rear diff breather
    But wouldnt that cause issues right from startup......if a vac or hose was loose it wouldnt run right for a few then bog and start choking. It would have no pressure from the get go.
     
  18. Aug 8, 2012 at 8:32 AM
    #18
    98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,164
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
    That all depends on what is exactly wrong with it. It runs in open loop but "dies" when it hits closed loop.
     
  19. Aug 8, 2012 at 8:40 AM
    #19
    whippersnapper02

    whippersnapper02 Well-Known Member

    Joined:
    Dec 20, 2009
    Member:
    #27905
    Messages:
    35,214
    Gender:
    Male
    First Name:
    Christian
    Yorba Linda, CA
    Vehicle:
    10 MGM TRD OR 4wd Auto DCSB
    Banks Monster Exhaust, Pop n Lock tailgate lock, Hook-Ups tie down brackets, USA Spec Ipod adaptor, WO seat covers, color matched grill with Grillcraft insert, Tuffy locking bed box
    Idea! Are the bypass valve hoses still connected? If it is venting to the atmosphere that could cause issues.

    Ricers that buy the noisy ones usually end up looking like a diesel because all that metered air gets dumped while the ECU still thinks ot is going into the engine.
     
  20. Aug 8, 2012 at 8:47 AM
    #20
    tostidos

    tostidos Well-Known Member

    Joined:
    Dec 24, 2010
    Member:
    #48149
    Messages:
    4,742
    Gender:
    Male
    First Name:
    Chris
    Apple Valley, CA
    Vehicle:
    07 LT 6spd
    where the injectors changed out? maybe pull them and see what they are looking like. Ive been running into a very similar problem on my aircraft and the injectors are clogged from shitty fuel.
     
To Top