1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2005 Xrunner- NO POWER and Black smoke.

Discussion in 'Underdog Racing Development' started by rockstar626, Aug 8, 2012.

  1. Aug 9, 2012 at 12:07 PM
    #41
    chadderkdawg

    chadderkdawg Don't ask questions you don't want the answer to..

    Joined:
    Apr 29, 2011
    Member:
    #55763
    Messages:
    8,161
    Gender:
    Male
    Des Moines, Iowa
    Vehicle:
    09 FX4 F150
    With all due respect, we are just attempting to help...

    Number 1: you will get more help on xru, not many URD's around here.

    Number 2: If you need to talk to Gadget, then bombard him relentlessly.
     
  2. Aug 9, 2012 at 12:17 PM
    #42
    GodHatesUsAll

    GodHatesUsAll Reign in Blood

    Joined:
    Oct 11, 2009
    Member:
    #24126
    Messages:
    88
    Gender:
    Male
    First Name:
    Satan
    Six Feet Under
    Vehicle:
    05' Black Sand Pearl XRunner
    TRD Blower//APR X-1//668cc Primaries & 7th inj//URD 2.8"&NST OD Pulleys//AFE StageII Si CAI//URD Fuel Pump//JBA GenII lT's//URD S/S//URD Lite Flywheel//Competition Clutch StageIII//NST Lite Pulleys//Sittin Sic Front coils/Rear Mono leafs//
    So ur saying ur managers cell phone doesn't have voicemail?
     
  3. Aug 9, 2012 at 12:18 PM
    #43
    Steves104x4

    Steves104x4 Well-Known Member

    Joined:
    Apr 17, 2010
    Member:
    #35468
    Messages:
    6,912
    Gender:
    Male
    First Name:
    Steve
    Buffalo NY
    Vehicle:
    2010 RC 2.7 4x4
    BUCKLE UP! It makes it harder for Aliens to pull you out of your Truck.
    Make sure the Supercharger is torqued correctly on the manifold; it wouldn't be the first time the bolts loosen up. These things really don't like vacuum leaks.
     
  4. Aug 9, 2012 at 12:19 PM
    #44
    Pugga

    Pugga Pasti-Dip Free 1983 - 2015... It was a good run

    Joined:
    Jun 18, 2010
    Member:
    #39131
    Messages:
    30,174
    Gender:
    Male
    First Name:
    Mike
    Massachusetts
    Vehicle:
    '13 Ford F-150 SCREW
    F-150 Mod
    Did you try the part about unplugging the 7th injector or were you too busy trying to blast him for his post?

    Ever hear the phrase, 'don't kill the messenger'? :rolleyes:
     
  5. Aug 9, 2012 at 12:25 PM
    #45
    GodHatesUsAll

    GodHatesUsAll Reign in Blood

    Joined:
    Oct 11, 2009
    Member:
    #24126
    Messages:
    88
    Gender:
    Male
    First Name:
    Satan
    Six Feet Under
    Vehicle:
    05' Black Sand Pearl XRunner
    TRD Blower//APR X-1//668cc Primaries & 7th inj//URD 2.8"&NST OD Pulleys//AFE StageII Si CAI//URD Fuel Pump//JBA GenII lT's//URD S/S//URD Lite Flywheel//Competition Clutch StageIII//NST Lite Pulleys//Sittin Sic Front coils/Rear Mono leafs//
    None of URDs mki's or mkiis mount to any manifold
     
  6. Aug 9, 2012 at 12:29 PM
    #46
    Steves104x4

    Steves104x4 Well-Known Member

    Joined:
    Apr 17, 2010
    Member:
    #35468
    Messages:
    6,912
    Gender:
    Male
    First Name:
    Steve
    Buffalo NY
    Vehicle:
    2010 RC 2.7 4x4
    BUCKLE UP! It makes it harder for Aliens to pull you out of your Truck.
    Oh, ok. Still sounds like a massive vacuum leak to me. Also and I know this is simple but with the engine running tap the MAF sensor lightly with the handle of a screw driver; if the idle fluctuates you need a new MAF but then you already knew that...right? Could be the EGR system, too.
     
  7. Aug 9, 2012 at 1:05 PM
    #47
    rexrunner

    rexrunner Member

    Joined:
    May 19, 2009
    Member:
    #17415
    Messages:
    10
    Gender:
    Male
    gt35r
    don't blame gadget. Your dealership sold the truck and made the profit. Not gadget. Your techs need some training. There is.no reason why a regular scan tool can't read from the ecm. The urd psc does not affect that. Its a piggyback. You need to see what the maf is seeing. Open loop/closed loop function.

    What codes are you throwing?please don't tell me you keep erasing them without reading them. So what codes?

    The urd psc goes inline between the sensors. Check the voltage at the psc to make sure its hot.
     
  8. Aug 9, 2012 at 1:31 PM
    #48
    Gadget@URD

    Gadget@URD Well-Known Member Vendor

    Joined:
    Sep 12, 2008
    Member:
    #9183
    Messages:
    653
    Southern Maryland USA
    Vehicle:
    URD Supercharged XRunner
    Thanks for all the help folks.

    I have been in touch with the OP.

    We will get it sorted out.

    Lets turn down the wick here. I know everyone is doing their best to help and have the greatest intentions and in no way meant any harm.

    G
     
  9. Aug 16, 2012 at 5:17 PM
    #49
    Nathan88

    Nathan88 Member

    Joined:
    Sep 25, 2011
    Member:
    #64094
    Messages:
    15
    Gender:
    Male
    First Name:
    Nathan
    Ga
    Vehicle:
    06 PreRunner SR5 TRD Sport
    DoubleDin Pioneer P3200 dvd headunit, Big Country chrome side step bars, 25% tint windows, Bak rollbak bed cover.
    Sounds like if it had an supercharger installed and with the problems stated. You may need to get the ECU reflashed. That's a must after installing a supercharger.
     
  10. Aug 16, 2012 at 5:19 PM
    #50
    Nathan88

    Nathan88 Member

    Joined:
    Sep 25, 2011
    Member:
    #64094
    Messages:
    15
    Gender:
    Male
    First Name:
    Nathan
    Ga
    Vehicle:
    06 PreRunner SR5 TRD Sport
    DoubleDin Pioneer P3200 dvd headunit, Big Country chrome side step bars, 25% tint windows, Bak rollbak bed cover.
    Another idea is to check the plugs and make sure they installed the correct type of plug for the supercharger.
     
  11. Aug 16, 2012 at 6:10 PM
    #51
    tostidos

    tostidos Well-Known Member

    Joined:
    Dec 24, 2010
    Member:
    #48149
    Messages:
    4,769
    Gender:
    Male
    First Name:
    Chris
    Apple Valley, CA
    Vehicle:
    07 LT 6spd
    update?
     
  12. Aug 16, 2012 at 6:30 PM
    #52
    GodHatesUsAll

    GodHatesUsAll Reign in Blood

    Joined:
    Oct 11, 2009
    Member:
    #24126
    Messages:
    88
    Gender:
    Male
    First Name:
    Satan
    Six Feet Under
    Vehicle:
    05' Black Sand Pearl XRunner
    TRD Blower//APR X-1//668cc Primaries & 7th inj//URD 2.8"&NST OD Pulleys//AFE StageII Si CAI//URD Fuel Pump//JBA GenII lT's//URD S/S//URD Lite Flywheel//Competition Clutch StageIII//NST Lite Pulleys//Sittin Sic Front coils/Rear Mono leafs//
    This has the URD blower installed not TRD, no ECU reflash needed
     
  13. Nov 29, 2012 at 8:01 AM
    #53
    rubenc87

    rubenc87 Cobra

    Joined:
    Feb 2, 2009
    Member:
    #13214
    Messages:
    1,549
    Gender:
    Male
    Texas
    Vehicle:
    2013 Tacoma DCSB 4x4
    DTRL,HID's, Redline Elite Hood Struts,IVD Coilovers and Rear Shocks W/ Ext. Res.,N-FAB Light Bar W/ KC Titanium Lights, Alcan AAL,Wet Okole's, URD T.C.A.I. M/T Classic Lock's BFG AT, Chrome TC UCA'S,TRD Exhaust, Bed Mat,Painted Roof Rack,Access LE,Weathertech's F&R,P&L Lock
    Was it fixed?
     
  14. Nov 29, 2012 at 11:45 AM
    #54
    rubenc87

    rubenc87 Cobra

    Joined:
    Feb 2, 2009
    Member:
    #13214
    Messages:
    1,549
    Gender:
    Male
    Texas
    Vehicle:
    2013 Tacoma DCSB 4x4
    DTRL,HID's, Redline Elite Hood Struts,IVD Coilovers and Rear Shocks W/ Ext. Res.,N-FAB Light Bar W/ KC Titanium Lights, Alcan AAL,Wet Okole's, URD T.C.A.I. M/T Classic Lock's BFG AT, Chrome TC UCA'S,TRD Exhaust, Bed Mat,Painted Roof Rack,Access LE,Weathertech's F&R,P&L Lock
    That makes sense. Since they are not MFG specific.
     
To Top