1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2007 Steering issue

Discussion in '2nd Gen. Tacomas (2005-2015)' started by mdcteague, Feb 14, 2011.

  1. Feb 14, 2011 at 7:10 AM
    #1
    mdcteague

    mdcteague [OP] Member

    Joined:
    Aug 17, 2010
    Member:
    #41830
    Messages:
    5
    Gender:
    Male
    Cape Cod
    Vehicle:
    07' SR5 Access cab-4cyl
    Steering - Issue
    2007 SR5 - 4cyl - standard - 68,000mi - A few weeks ago I had some issues with hard steering - (during some really cold weather - 10deg) - checked ps pump and it was very low on fluid - I got some dexron ATF as recommended and topped it off - now a few weeks later - the steering is hard to turn- and it almost won't return to straight after making a turn. I have checked the gear box and rack & pinion - no leaks--- very strange - I really hope I don't need a new rack
     
  2. Feb 15, 2011 at 6:24 PM
    #2
    MushyB

    MushyB Well-Known Member

    Joined:
    Mar 2, 2009
    Member:
    #14242
    Messages:
    49
    Gender:
    Male
    MA/CT
    Vehicle:
    05 Taco TRD Off-Road
    check your steering shaft u-joint. it's located on the driver's side of the engine bay, you can follow it from where the shaft comes out of your firewall and down to the u-joint. spray it with some pb blaster and work it with the wheels off the ground or just by driving it. if that's the problem you can either spray it down a lot to make it really clean and lubed, or replace it. i found it easiest to spray the u-joint from under the vehicle from the side of the skid plate. this happened to me a couple years ago and after this remedy it happened once again last year. this year it hasn't happened again (knock on wood) haha. my friends dad had the same problem and opted to have the shaft replaced for x amount of dollars. me... i'd rather spray it for a 5 dollar can of weasel piss. the salt and corrosion up here in mass really gets to that thing! good luck, hope that works for ya, keep us posted if that's the problem.
     
  3. Feb 16, 2011 at 7:40 AM
    #3
    mdcteague

    mdcteague [OP] Member

    Joined:
    Aug 17, 2010
    Member:
    #41830
    Messages:
    5
    Gender:
    Male
    Cape Cod
    Vehicle:
    07' SR5 Access cab-4cyl
    Thanks - that was exactly the problem - $3 woth of kroil and problem solved
     
  4. Feb 16, 2011 at 8:19 AM
    #4
    MushyB

    MushyB Well-Known Member

    Joined:
    Mar 2, 2009
    Member:
    #14242
    Messages:
    49
    Gender:
    Male
    MA/CT
    Vehicle:
    05 Taco TRD Off-Road
    good deal. let me know if you come up with any ideas for a boot or cover for this.
     
  5. Apr 28, 2011 at 5:16 PM
    #5
    FLyhighdp

    FLyhighdp Member

    Joined:
    Apr 25, 2011
    Member:
    #55500
    Messages:
    16
    Gender:
    Male
    flyhighdp@gmail.com
    Vehicle:
    flyhighdp@gmail.com
    same problem for myself... I was actually more surprised that I found write-up so quick. I'm lovin "tacomaworld" more and more everyday! Thanks for the help guys!!
     
  6. May 2, 2011 at 10:12 PM
    #6
    MushyB

    MushyB Well-Known Member

    Joined:
    Mar 2, 2009
    Member:
    #14242
    Messages:
    49
    Gender:
    Male
    MA/CT
    Vehicle:
    05 Taco TRD Off-Road
    glad we could help!
     
To Top