1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2010 paint rust!

Discussion in '2nd Gen. Tacomas (2005-2015)' started by 357sig, May 17, 2011.

  1. May 17, 2011 at 3:27 PM
    #1
    357sig

    357sig [OP] Donut king

    Joined:
    Feb 14, 2010
    Member:
    #31343
    Messages:
    32,134
    Gender:
    Male
    First Name:
    dough boy
    donut shop
    Vehicle:
    Gold digger
    Hey guy,

    I was wondering if anyone is having the same problem I am having with my truck. I have 2010 tacoma. I washed my truck two days ago and notices I have small rust spot coming through the paint. Some of the spots have already broke through the paint. All rust spots are about the size of a pen tip, but rust is rust non the less. I called the dealer and they asked if it was rock chips. I told them that even the rock chips do not have rust on it. So tomorrow morning I will be showing up at the dealer.
     
  2. May 17, 2011 at 3:29 PM
    #2
    OZ-T

    OZ-T Did you get your precious photos ?

    Joined:
    Dec 15, 2009
    Member:
    #27584
    Messages:
    24,816
    Gender:
    Male
    First Name:
    Peter North
    British Columbia
    Vehicle:
    Mag Grey 09 Trd Sport DCLB 4x4
    OME 885x , OME shocks and Dakars , Wheelers SuperBumps front and rear , 275/70/17 Hankook ATm , OEM bed mat , Weathertech digifit floor liners , Weathertech in-channel vents , headache rack , Leer 100RCC commercial canopy , TRD bedside decals removed , Devil Horns by Andres , HomerTaco Satoshi
    Rail dust
     
  3. Jun 10, 2011 at 12:00 PM
    #3
    GoatFiddyone

    GoatFiddyone Well-Known Member

    Joined:
    Feb 15, 2010
    Member:
    #31464
    Messages:
    258
    Gender:
    Male
    Orlando, FL
    Vehicle:
    '11 DC/ LB, 4x4, TRD Sport
    I noticed this today on my Tacoma. The service writer said it is probably rail dust and that they will buff it out for me. I guess this is pretty common.
     
  4. Jun 10, 2011 at 12:02 PM
    #4
    MountainEarth

    MountainEarth Well-Known Member

    Joined:
    Feb 1, 2010
    Member:
    #30519
    Messages:
    2,494
    Gender:
    Male
    First Name:
    Bryan
    CO
    Vehicle:
    2010 TRD OR Access
    Leer 100XR Shell, BedRug mat - comfy sleeping, GT Covers microfiber seat covers, BFG All Terrains 265/70r16, Dashmat, Antennax 13" shorty antenna, Weathertech liners, Ultra Gauge, Avid Light Bar, PIAA 520 ATPs, one old dog
    WTF is "rail dust"?
     
  5. Jun 10, 2011 at 12:03 PM
    #5
    mjohn617

    mjohn617 Well-Known Member

    Joined:
    Mar 15, 2010
    Member:
    #33314
    Messages:
    719
    Gender:
    Male
    Petaluma, CA
    Vehicle:
    05 DC TRD sprt silver
    Toytec ULK, OME Dakar leafs, LED conversion, RBP sidesteps, Nitto Trail Grapplers, AR ATX Artillery 16" wheels, Doug Thorley LTH/Pipe Bomb, TRD Exhaust W/Classic Chambered Powerstick, Lightend Flywheel
    From the rails...trains yo!
     
  6. Jun 10, 2011 at 12:09 PM
    #6
    mjohn617

    mjohn617 Well-Known Member

    Joined:
    Mar 15, 2010
    Member:
    #33314
    Messages:
    719
    Gender:
    Male
    Petaluma, CA
    Vehicle:
    05 DC TRD sprt silver
    Toytec ULK, OME Dakar leafs, LED conversion, RBP sidesteps, Nitto Trail Grapplers, AR ATX Artillery 16" wheels, Doug Thorley LTH/Pipe Bomb, TRD Exhaust W/Classic Chambered Powerstick, Lightend Flywheel
    That is exactly what I was thinking, do that shit yourself.
     
To Top