1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2013 tacoma only 2 fm stations come in on a scan search

Discussion in '2nd Gen. Tacomas (2005-2015)' started by mcl77, Jun 11, 2022.

  1. Jun 11, 2022 at 2:48 PM
    #1
    mcl77

    mcl77 [OP] Well-Known Member

    Joined:
    Jul 15, 2020
    Member:
    #334572
    Messages:
    116
    Gender:
    Male
    Radio is what came with truck.
    2013 tacoma.
    bluetooth works fine.
    only 2 fm stations come in good.

    seems worse when vehicle is moving
     
  2. Jun 11, 2022 at 2:58 PM
    #2
    rnish

    rnish Well-Known Member

    Joined:
    May 9, 2014
    Member:
    #129450
    Messages:
    6,757
    Gender:
    Male
    Peoples Republic of Maryland (USA)
    Vehicle:
    Tacoma 2nd gen
    Pro Suspension (Bilstein), OME Dakar (med), armor
    Has it ever worked?
     
  3. Jun 11, 2022 at 3:00 PM
    #3
    VXEric

    VXEric Well-Known Member

    Joined:
    Dec 6, 2020
    Member:
    #348871
    Messages:
    273
    Gender:
    Male
    First Name:
    Eric
    Worcester, PA
    Vehicle:
    07 ACS V6 6 Spd TRD Sport
    265/70/17 ATs on 17x8"wheels and 0 offset Morimoto XB LED Fogs Reinforced tailgate 2011 Honeycomb grille URD Short Shifter and cue- ball style knob
    Try unscrewing the antenna and cleaning up any corrosion/dirt build up then put it back together
     
    PzTank likes this.
  4. Jun 11, 2022 at 3:04 PM
    #4
    Rock Lobster

    Rock Lobster knows nothing, yet an expert in everything.

    Joined:
    Dec 14, 2018
    Member:
    #275833
    Messages:
    7,053
    Gender:
    Male
    First Name:
    Ryan
    Dee Eff Dub
    Vehicle:
    Sport Crew represent
    Install any aftermarket items recently?

    I lost radio after putting in a cheap dashcam. Turns out the wire harness was causing interference.

    Pull the fuses on any aftermarket, then check the antenna connection in the back of your head unit.
     
  5. Jun 11, 2022 at 4:21 PM
    #5
    potstech

    potstech Well-Known Member

    Joined:
    Nov 19, 2013
    Member:
    #116891
    Messages:
    391
    Gender:
    Male
    Midlothian, Va
    Vehicle:
    2013 DCLB
    Also check to see if the antenna is actually connected to the radio and it is not cut somewhere.
     
    JustJon, wi_taco and SR-71A like this.
  6. Jun 11, 2022 at 4:45 PM
    #6
    mcl77

    mcl77 [OP] Well-Known Member

    Joined:
    Jul 15, 2020
    Member:
    #334572
    Messages:
    116
    Gender:
    Male
    as far as reception on fm radio. it has never worked goid since getting the truck.
    i unscrewed antenna and blew out a bunch of crap thst was in tgere but it didnt seem to improve anything.
    literally only 2 station on fm come in clearly as it should.
     
  7. Jun 11, 2022 at 4:49 PM
    #7
    mcl77

    mcl77 [OP] Well-Known Member

    Joined:
    Jul 15, 2020
    Member:
    #334572
    Messages:
    116
    Gender:
    Male
    i found a thread on here to test by disconnecting at connection behind side pillar and try using a wire at connection. that didnt seem to improve anything either.
    When i put connections back together signal definitely better but still only 2 stations come up on fm scan. weird
     
  8. Jun 11, 2022 at 6:04 PM
    #8
    TnShooter

    TnShooter Well-Known Member

    Joined:
    Sep 2, 2010
    Member:
    #42625
    Messages:
    8,849
    Gender:
    Male
    Vehicle:
    07' TRD Off-Road, Auto
    STOCK
    The corrosion starts and is primarily under the black cover of the antenna base.
    upload_2022-6-11_21-4-50.jpg
     
    PzTank likes this.
  9. Jun 23, 2022 at 4:54 AM
    #9
    mcl77

    mcl77 [OP] Well-Known Member

    Joined:
    Jul 15, 2020
    Member:
    #334572
    Messages:
    116
    Gender:
    Male
    so i am going to try and fix this today. i have the day off.
    im hoping i get get the castle nut off with vice grips. i dont want to get the drill out around my hood.
    i have all the parts im just waiting on the fender liner clips. i was just going to break them off and replace with new ones.
    do i need the clips to hold the liner on or are there bolts that hold it on until my clips come in.
     
  10. Jun 23, 2022 at 5:24 AM
    #10
    SR-71A

    SR-71A Define "Well-Known Member"

    Joined:
    Jun 1, 2018
    Member:
    #255145
    Messages:
    5,901
    Gender:
    Male
    First Name:
    Zack
    Southern Maine
    Vehicle:
    2012 DCSB, TX Baja Edition. Barcelona Red
    Mobtown sliders, ARB bar, Icon RXT leafs, extended & adjustable Kings, JBA UCAs, Tepui Ayer 2, dual batteries, Gen2 xrc9.5 winch, CB, GMRS, S1 ditch lights...
    Sub'd for the outcome. Im 99% sure Im going to have to do this at some point
     
  11. Jun 23, 2022 at 7:12 AM
    #11
    Saskabush

    Saskabush Well-Known Member

    Joined:
    Aug 16, 2013
    Member:
    #110569
    Messages:
    144
    Gender:
    Male
    First Name:
    Adam
    Saskatchewan, Canada
    Vehicle:
    2013 TRD Sport
    Elka 2.5" DSC w/ Dakars, Archive Hammer Hangers, SPC UCAs, Timbren bumps, 16" TRD baja wheels, 265/75r16 BFG K02, 1.25" wheel spacers, TRD skid plate, N-Fab spare tire box mount.
    The antenna may also be disconnected from the back of the stereo head unit. Sometimes those are a pain in the ass to keep connected when putting the head unit back in.
     
  12. Jun 23, 2022 at 10:25 AM
    #12
    mcl77

    mcl77 [OP] Well-Known Member

    Joined:
    Jul 15, 2020
    Member:
    #334572
    Messages:
    116
    Gender:
    Male
    i checked that just in case and it was connected.
     
    PzTank and Saskabush like this.
  13. Jun 23, 2022 at 11:24 AM
    #13
    mcl77

    mcl77 [OP] Well-Known Member

    Joined:
    Jul 15, 2020
    Member:
    #334572
    Messages:
    116
    Gender:
    Male
    20220623_143054.jpg
    so i started working on this but im going to need the clips. they arent coming in until saturday.
    i did manage to get the castle nut and bezel off. used a 3/8 drill bit. then went a size bigger and went slow at an angle and it all broke off
     
    Last edited: Jun 23, 2022
    TnShooter likes this.
  14. Jun 24, 2022 at 5:57 AM
    #14
    SR-71A

    SR-71A Define "Well-Known Member"

    Joined:
    Jun 1, 2018
    Member:
    #255145
    Messages:
    5,901
    Gender:
    Male
    First Name:
    Zack
    Southern Maine
    Vehicle:
    2012 DCSB, TX Baja Edition. Barcelona Red
    Mobtown sliders, ARB bar, Icon RXT leafs, extended & adjustable Kings, JBA UCAs, Tepui Ayer 2, dual batteries, Gen2 xrc9.5 winch, CB, GMRS, S1 ditch lights...
    well then :eek:
     
  15. Jun 24, 2022 at 7:19 AM
    #15
    EdgemanVA

    EdgemanVA Well-Known Member

    Joined:
    Nov 18, 2013
    Member:
    #116820
    Messages:
    1,067
    Gender:
    Male
    Virginia Beach
    Vehicle:
    2008 X-Runner
    Several
    Just curious...are you still getting 2 FM channels with the antenna removed?
     
  16. Jun 24, 2022 at 7:23 AM
    #16
    mcl77

    mcl77 [OP] Well-Known Member

    Joined:
    Jul 15, 2020
    Member:
    #334572
    Messages:
    116
    Gender:
    Male
    i get one that comes in a bit still. especially when stopped and not driving
     
    EdgemanVA likes this.
  17. Jun 24, 2022 at 9:21 AM
    #17
    EdgemanVA

    EdgemanVA Well-Known Member

    Joined:
    Nov 18, 2013
    Member:
    #116820
    Messages:
    1,067
    Gender:
    Male
    Virginia Beach
    Vehicle:
    2008 X-Runner
    Several
    Pretty clear you found the problem.
     
    PzTank likes this.
  18. Jun 24, 2022 at 10:10 AM
    #18
    Sprig

    Sprig Well-Known Member

    Joined:
    Sep 28, 2017
    Member:
    #231426
    Messages:
    1,576
    Gender:
    Male
    First Name:
    Ken
    N. Calif. The Twilight Zone
    Vehicle:
    Tacoma TRD double cab 4x4, Barcelona Red
    Taco OEM radios are not known for longevity, often only last 8 to 10 years before they start having problems. Rather than spend hours and hours of your time trying to fix the problem on an old radio that’s probably going to crap out anyway sooner than later, you are better off biting the bullet and getting a new radio. You can get a decent replacement for a decent price. I’d rather spend my time fishing than messing with an old malfunctioning radio..
     
  19. Jun 24, 2022 at 11:53 AM
    #19
    TnShooter

    TnShooter Well-Known Member

    Joined:
    Sep 2, 2010
    Member:
    #42625
    Messages:
    8,849
    Gender:
    Male
    Vehicle:
    07' TRD Off-Road, Auto
    STOCK
    A new radio will still have the antenna plugged into it.
    OP has a bad antenna base mount. A new radio will still result in only 2 stations unless the base is fixed.
    I wish the 2nd had a shark fin like the 3rd Gen. They don’t have this issue and you don’t have to take the antenna off when going through a car wash.
     
    EdgemanVA and SR-71A like this.
  20. Jun 24, 2022 at 12:11 PM
    #20
    mcl77

    mcl77 [OP] Well-Known Member

    Joined:
    Jul 15, 2020
    Member:
    #334572
    Messages:
    116
    Gender:
    Male
    after you fixed yours did you put any silicone around the base? anything to prevent it from having this issue again?
     

Products Discussed in

To Top