1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

3.4L V6 guru? cam plug help

Discussion in '1st Gen. Tacomas (1995-2004)' started by derekp, Jan 2, 2010.

  1. Jan 2, 2010 at 3:35 PM
    #1
    derekp

    derekp [OP] giddy up!

    Joined:
    May 16, 2009
    Member:
    #17281
    Messages:
    437
    Gender:
    Male
    First Name:
    Derek
    Grand Forks, ND
    Vehicle:
    2001 X-Cab 4x4 TRD V6 5Spd
    Deck plate, Flowmaster Delta-Flow 40 series, 265/75-16 Wrangler TDs, more to come...
    Is there a V6 guru around? I think the cam plug (top of the motor, back side near the firewall?) on the passenger side is leaking a bit. Nothing horrible at this time, but makes me a bit concerned. Anyone else face similar issues?

    Derek P
    Germantown, MD
     
  2. Jan 2, 2010 at 4:14 PM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,153
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Can you post pics of the leak?
     
  3. Jan 2, 2010 at 4:19 PM
    #3
    derekp

    derekp [OP] giddy up!

    Joined:
    May 16, 2009
    Member:
    #17281
    Messages:
    437
    Gender:
    Male
    First Name:
    Derek
    Grand Forks, ND
    Vehicle:
    2001 X-Cab 4x4 TRD V6 5Spd
    Deck plate, Flowmaster Delta-Flow 40 series, 265/75-16 Wrangler TDs, more to come...
  4. Jan 2, 2010 at 4:26 PM
    #4
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,153
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    There is a Semi Circular plug (s) in the back....They are between the Valve cover, and the head....Is that whats leaking? They look like a half circle.
     
  5. Jan 2, 2010 at 4:29 PM
    #5
    derekp

    derekp [OP] giddy up!

    Joined:
    May 16, 2009
    Member:
    #17281
    Messages:
    437
    Gender:
    Male
    First Name:
    Derek
    Grand Forks, ND
    Vehicle:
    2001 X-Cab 4x4 TRD V6 5Spd
    Deck plate, Flowmaster Delta-Flow 40 series, 265/75-16 Wrangler TDs, more to come...
    Correct...but I *think* it was a full circle. I could very well be wrong on that though. It looked like a mounting plate bolted over it or right next to it. It was difficult to see via a small mirror and flashlight though.
     
  6. Jan 2, 2010 at 4:37 PM
    #6
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,153
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Thats all I can think it would be......You can remove the valve cover, and pull the semi Circle plug out, clean the old gasket off, install new gasket, and re install.
     
  7. Jan 2, 2010 at 4:55 PM
    #7
    derekp

    derekp [OP] giddy up!

    Joined:
    May 16, 2009
    Member:
    #17281
    Messages:
    437
    Gender:
    Male
    First Name:
    Derek
    Grand Forks, ND
    Vehicle:
    2001 X-Cab 4x4 TRD V6 5Spd
    Deck plate, Flowmaster Delta-Flow 40 series, 265/75-16 Wrangler TDs, more to come...
    Thanks, *sounds* pretty straight forward. Probably need to replace the valve cover gasket as well, correct? I still need to find some folks to help with the timing belt/water pump replacement. I am around 122k miles.

    Derek P
    Germantown, MD
     
  8. Jan 2, 2010 at 5:45 PM
    #8
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,153
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Yeah, The Valve cover gasket will need to be changed too. Maybe find some folks on TW that live near ya for some help.
     
  9. Jan 2, 2010 at 5:46 PM
    #9
    derekp

    derekp [OP] giddy up!

    Joined:
    May 16, 2009
    Member:
    #17281
    Messages:
    437
    Gender:
    Male
    First Name:
    Derek
    Grand Forks, ND
    Vehicle:
    2001 X-Cab 4x4 TRD V6 5Spd
    Deck plate, Flowmaster Delta-Flow 40 series, 265/75-16 Wrangler TDs, more to come...
    Thanks, Chris!
     
  10. Jan 2, 2010 at 5:52 PM
    #10
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,153
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Glad to help :)
     
To Top