1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

95 tacoma

Discussion in 'New Members' started by Roger Cook, Apr 22, 2010.

  1. Apr 22, 2010 at 12:52 PM
    #1
    Roger Cook

    Roger Cook [OP] New Member

    Joined:
    Apr 21, 2010
    Member:
    #35724
    Messages:
    1
    Gender:
    Male
    Ut
    Vehicle:
    95 Tacoma 4x4
    R Cook;
    I have a 95 Tacom with a 2.7 engine and when I throtle down on it I have now power. The shop where I took it thought that it was a Mass Air Flow meter, but after putting on a used one it still does the same thing. He still thinks the problem is the same, because if he blows air accross the maf it picks right up. It does okay when it is cold but it is after it warms up that it dogs out. I have been told that it might be a computer problem also. The thing I don't undersand is why is it not giving a code? If anyone has any idea please let me know.
     
  2. Apr 23, 2010 at 12:14 AM
    #2
    Justin626

    Justin626 Well-Known Member

    Joined:
    Sep 27, 2007
    Member:
    #2838
    Messages:
    931
    Gender:
    Male
    Palmer, Alaska
    Vehicle:
    2007 4x4 TRD Sport DC Super White
    Toytec 3" w/ AAL, N-Fab Nerf Bars, Lightforce 170mm Strikers, N-Fab Light Bar, Metra Ipod Adapter, Scosche Auto Start
    I know it's a bit of a retarded question,....but have you taken a look at your air filter yet? or the tube that draws air into your filter housing,....for clogs??
     
  3. Apr 23, 2010 at 11:49 AM
    #3
    neontrail

    neontrail ✈ ✈ ✈ ✈ ✈ ✈ ✈

    Joined:
    Apr 9, 2008
    Member:
    #5844
    Messages:
    10,128
    Gender:
    Male
    Idaho
    Vehicle:
    2004 NISSAN XTERRA XE/SE
    De-badged, Tint 20%, Blue 48 LED dome-light, .......
    HellO Roger Cook, Welcome to the forum! Glad to have ya
     
To Top