1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

96 v6 running weird. Couple pf question a before going to mechanic

Discussion in 'Technical Chat' started by dustinJ, Dec 11, 2010.

  1. Dec 11, 2010 at 7:00 AM
    #1
    dustinJ

    dustinJ [OP] Taco abuser

    Joined:
    Dec 7, 2010
    Member:
    #47331
    Messages:
    166
    Gender:
    Male
    First Name:
    Dustin
    Amarillo tx
    Vehicle:
    09 dcsb Super white 4x4 sr5. Stock, but not for long.
    None yet
    On first startup, every time warm or not, the motor runs like its flooded. Idles very rough, almost dying, belts squeaking, then I hear a rattle that seems to be in the top somewhere. Sounds like a rock flies through the runners after the throttle body. Then, all of a sudden it smooths out and seems to be running fine save for one little ticking on the drivers side. Timing belt maybe? But it wouldn't slip then all of a sudden catch in just the right spot every time to get back in time. At least I wouldn't think so.

    I though I'd go for a tune up, plugs, wires, oil, fuel filter air filter.

    Let me know what you guys think. I'm not to familiar with these motors. Been driving diesels for a while now. Gonna stop and get a manual today.

    Thanks in advance
    Dustin
     
To Top