1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

ABS and traction control lights on after Leveling kit install

Discussion in 'Suspension' started by Chipguy113, Apr 4, 2013.

  1. Apr 4, 2013 at 3:47 AM
    #1
    Chipguy113

    Chipguy113 [OP] New Member

    Joined:
    Apr 4, 2013
    Member:
    #101298
    Messages:
    2
    Gender:
    Male
    Vehicle:
    2012 sport
    ARB Front Bumper, leveling kit
    Does anyone know why my ABS light and Traction Control light would be on after putting a leveling kit on? Any help would be great. Thanks
     
  2. Apr 4, 2013 at 4:59 AM
    #2
    Mr. Derek

    Mr. Derek Member

    Joined:
    Jan 28, 2013
    Member:
    #96287
    Messages:
    8
    Gender:
    Male
    Minnesota
    Vehicle:
    '12 Tacoma TRD OR
  3. Apr 4, 2013 at 5:19 AM
    #3
    Large

    Large Red

    Joined:
    Sep 10, 2011
    Member:
    #63268
    Messages:
    15,603
    Gender:
    Male
    Mine has done this after every lift, and after every lift, either disconnecting the battery for 10 minutes, or an alignment will fix the issue.
     
  4. Apr 7, 2013 at 7:26 PM
    #4
    Chipguy113

    Chipguy113 [OP] New Member

    Joined:
    Apr 4, 2013
    Member:
    #101298
    Messages:
    2
    Gender:
    Male
    Vehicle:
    2012 sport
    ARB Front Bumper, leveling kit
    I tried disconnecting the battery and the lights are still on. I will try an alignment next. Thanks for the help.
     
To Top