1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

After Market Mirrors with Turn Signal Lights

Discussion in '2nd Gen. Tacomas (2005-2015)' started by MC68440, Apr 26, 2014.

  1. Apr 26, 2014 at 7:18 PM
    #1
    MC68440

    MC68440 [OP] Member

    Joined:
    Apr 22, 2014
    Member:
    #128235
    Messages:
    21
    Gender:
    Male
    Los Angeles CA
    Vehicle:
    2013, 4x4 Access, TRD Dark Blue
    No Mods, more of add-ons.
    My 2013 Access TRD came with sock non turn signal side mirrors. I wanted to put mirrors with turn signals on it so I checked here. There were a few posts here but the jest of it was as long as you have 5 wires at the connector, then the harness supports side mirrors with turn lights. :D

    Well I ordered the mirrors and installed them - but of course, the turn signal lights don't light. :mad:

    Any one add these types off mirrors on a 2013 Access TRD?

    I checked for any blank fuse slots that may need a fuse but did not find a single one. :confused:

    Any suggestions??
     
  2. Apr 26, 2014 at 8:42 PM
    #2
    File IFR

    File IFR "... Intercepting The Localizer"

    Joined:
    Mar 4, 2012
    Member:
    #74145
    Messages:
    4,512
    Gender:
    Male
    First Name:
    Mike
    Central MA
    Vehicle:
    2012 MGM 4X4 DC-LB TRD Sport
    Do you have voltage to the wires (truck's connector side) when you use the turn signals?
     
  3. Apr 26, 2014 at 8:57 PM
    #3
    MC68440

    MC68440 [OP] Member

    Joined:
    Apr 22, 2014
    Member:
    #128235
    Messages:
    21
    Gender:
    Male
    Los Angeles CA
    Vehicle:
    2013, 4x4 Access, TRD Dark Blue
    No Mods, more of add-ons.
    I'll check that tomorrow but I suspect not.

    So it sounds like:

    If voltage - no bulbs in the mirrors :eek: or plugs on mirrors not wired correctly :eek: but the power mirrors do work :confused:

    If no voltage - the other end of the wiring harness isn't hooked up :eek::eek: or there's a fuse that's needed?
     
  4. Apr 26, 2014 at 9:06 PM
    #4
    File IFR

    File IFR "... Intercepting The Localizer"

    Joined:
    Mar 4, 2012
    Member:
    #74145
    Messages:
    4,512
    Gender:
    Male
    First Name:
    Mike
    Central MA
    Vehicle:
    2012 MGM 4X4 DC-LB TRD Sport
    Did you buy a Toyota mirror housing/signal unit or an aftermarket... what brand? If you have a Toyota unit, they have LEDs in them (3 each side), so no 'bulb' is needed.
     
  5. Apr 26, 2014 at 9:22 PM
    #5
    MC68440

    MC68440 [OP] Member

    Joined:
    Apr 22, 2014
    Member:
    #128235
    Messages:
    21
    Gender:
    Male
    Los Angeles CA
    Vehicle:
    2013, 4x4 Access, TRD Dark Blue
    No Mods, more of add-ons.

    They are after markets - have no idea if they are LED or not. No instructions or anything supplied, fit perfectly but I'll take them apart tomorrow.

    These are them:

    http://www.ebay.com/itm/37092594313...l?_from=R40&_sacat=0&_nkw=370925943132&_rdc=1
     
  6. Apr 26, 2014 at 9:48 PM
    #6
    File IFR

    File IFR "... Intercepting The Localizer"

    Joined:
    Mar 4, 2012
    Member:
    #74145
    Messages:
    4,512
    Gender:
    Male
    First Name:
    Mike
    Central MA
    Vehicle:
    2012 MGM 4X4 DC-LB TRD Sport
    At the truck's connector, how many wires are enclosed in the cable... not the pins at the connector, but the wires in the cable?

    This will determine if your truck has it wired for future turn signals.

    3 wires run the power mirror, one (-) and two (+).... IIRC. Then you need 2 more for the LEDs/lamps.
     
  7. Apr 27, 2014 at 7:22 AM
    #7
    MC68440

    MC68440 [OP] Member

    Joined:
    Apr 22, 2014
    Member:
    #128235
    Messages:
    21
    Gender:
    Male
    Los Angeles CA
    Vehicle:
    2013, 4x4 Access, TRD Dark Blue
    No Mods, more of add-ons.
    There are 5 wires at the connector in the door and 5 wires in the mirror's connector.

    I'll verify and post pictures in a few.
     
  8. Apr 27, 2014 at 7:59 AM
    #8
    MC68440

    MC68440 [OP] Member

    Joined:
    Apr 22, 2014
    Member:
    #128235
    Messages:
    21
    Gender:
    Male
    Los Angeles CA
    Vehicle:
    2013, 4x4 Access, TRD Dark Blue
    No Mods, more of add-ons.
    So the connectors have 5 wires each. I also measured the voltage at the two additional wires for the lamps / LEDs - no voltage present when signal is on :mad:

    Mirror Con.jpg
     
  9. Apr 27, 2014 at 11:12 AM
    #9
    MC68440

    MC68440 [OP] Member

    Joined:
    Apr 22, 2014
    Member:
    #128235
    Messages:
    21
    Gender:
    Male
    Los Angeles CA
    Vehicle:
    2013, 4x4 Access, TRD Dark Blue
    No Mods, more of add-ons.
    Ya, OK, I found the problem with these signal mirror not working...:mad:

    So, there are 5 wires in the harness AT THE MIRROR CONNECTOR :D

    but not on the other end of the harness :eek:

    So, the door wiring harness is wired for turn signal mirrors, but the wiring harness in the cab is not!

    Traced the wires back through the door and to the passenger's kick panel. Found the interconnection plug and saw that while the wires from the mirror lamps go in the plug, but the mating socket doesn't have them coming out. Also, there are no loose wires near the connectors to tap ...the main wiring harness doesn't have them wired.

    I guess I could run wires myself but at this time I'm not in the mood - oh well :(

    Harness.jpg
     
    Last edited: Apr 27, 2014
    Norton likes this.
  10. Apr 27, 2014 at 12:25 PM
    #10
    File IFR

    File IFR "... Intercepting The Localizer"

    Joined:
    Mar 4, 2012
    Member:
    #74145
    Messages:
    4,512
    Gender:
    Male
    First Name:
    Mike
    Central MA
    Vehicle:
    2012 MGM 4X4 DC-LB TRD Sport
    It seems like you know whats going on now.

    Find the harness/wires from the turn signal stalk on the column, splice in and bring new wires to the empty harness under the dash.... or something like that.

    :thumbsup:

    ** Edit. LEDs take 3 volts, I'm sure the LED board on the mirror already has resistors to knock the voltage down from 12v to 3 v. I haven't heard of any issues there, so you'd be fine as it is.
     
    Last edited: Apr 27, 2014
  11. Apr 27, 2014 at 2:09 PM
    #11
    MarkH

    MarkH Well-Known Member

    Joined:
    Aug 24, 2013
    Member:
    #111055
    Messages:
    158
    Gender:
    Male
    First Name:
    Mark
    San Jose, CA
    Vehicle:
    13 PreRunner TRD Off Road
    I put the LKQ ProEFX towing mirrors on my 2013 TRD OR Access Cab and the turn signals worked just fine with the wiring that was in place. I did not have to run any additional wires.
     
    Norton likes this.
  12. Apr 27, 2014 at 3:37 PM
    #12
    MC68440

    MC68440 [OP] Member

    Joined:
    Apr 22, 2014
    Member:
    #128235
    Messages:
    21
    Gender:
    Male
    Los Angeles CA
    Vehicle:
    2013, 4x4 Access, TRD Dark Blue
    No Mods, more of add-ons.
    Thanks for the suggestions and help! ;)
     
  13. Apr 27, 2014 at 3:43 PM
    #13
    MC68440

    MC68440 [OP] Member

    Joined:
    Apr 22, 2014
    Member:
    #128235
    Messages:
    21
    Gender:
    Male
    Los Angeles CA
    Vehicle:
    2013, 4x4 Access, TRD Dark Blue
    No Mods, more of add-ons.
    Is it a PreRunner? :confused: Maybe they have different wiring than the 4x4's.
     
  14. Apr 27, 2014 at 4:03 PM
    #14
    Bunk454

    Bunk454 Well-Known Member

    Joined:
    Apr 11, 2013
    Member:
    #101906
    Messages:
    49
    Gender:
    Male
    Huntsville, AL
    Vehicle:
    '13 MGM DCSB TRD Off-Road
    I installed the exact same mirrors, but was NOt able to get the turn signals working. Same problem as the OP. The wiring is there (in the doors), but no voltage.

    I never traced the wires into the harness, but I suspect that different models trucks had different harnesses installed....which is curious to me, as I would have thought it would be cheaper to stick with a standard harness for all models.
     
    Norton likes this.
  15. Apr 28, 2014 at 9:53 AM
    #15
    MarkH

    MarkH Well-Known Member

    Joined:
    Aug 24, 2013
    Member:
    #111055
    Messages:
    158
    Gender:
    Male
    First Name:
    Mark
    San Jose, CA
    Vehicle:
    13 PreRunner TRD Off Road
    Yes, I have a PreRunner.
     
  16. May 18, 2014 at 7:31 AM
    #16
    double dee

    double dee Well-Known Member

    Joined:
    Mar 15, 2011
    Member:
    #53104
    Messages:
    968
    Gender:
    Male
    Phoenix
    Vehicle:
    2016 Tacoma 4x4
    I'm trying to figure out getting my turn signals to work as well. After reading other threads I am trying to make sure I understand this. I have a 2014 off road and have the correct wires in the door but not elsewhere. I need an add a fuse from the turn signal under the dash to the pink + wire in the door panel. then ground the white - wire in the door?
     
    Last edited: May 18, 2014
  17. May 19, 2014 at 10:18 AM
    #17
    MC68440

    MC68440 [OP] Member

    Joined:
    Apr 22, 2014
    Member:
    #128235
    Messages:
    21
    Gender:
    Male
    Los Angeles CA
    Vehicle:
    2013, 4x4 Access, TRD Dark Blue
    No Mods, more of add-ons.
    Well, I never followed through with my wiring but I did find the wiring diagrams for my 2013 - I think it should be the same idea with the 2014's.

    Looking at the diagrams, it seems like the "Flash Relay" is your best shot at getting the signals. It has both the left and right signals as well as hazard and best of all, it is fused. On trucks that have the turn indicator mirrors, those mirrors are connected there also. Specifically, the Right Hand Mirror connects to pin 18 of the Relay, and the Left Hand goes to pin 9. Looking at the diagram you can also use 7 and 5 or even 11 and 4 if you don't have the "Shorting Pins" installed.

    Again, I have not wired mine at this time but when I do, this is the route I'll take. I don't like the steering column idea because I want both mirrors to flash when (if) the hazards are on. The other side of the LED lamps go to ground. I have attached the parts of the electrical diagram I was referring to.

    I would not trust the wire colors as I have heard that they can change over the model years. Just find the relay (listen for where the click click click is coming from :p) then check for the right voltage at the right time and place, tie in that spot.

    Also, since you have a 2014, I'm pretty sure it is still covered under Toyo's warranty - I have no idea how this would effect the warranty but disclaimer disclaimer etc...


    Let us know how it turns out!

    3.jpg
    2.jpg
    1.jpg
     
    Last edited: May 19, 2014
  18. May 19, 2014 at 10:28 AM
    #18
    eliasj7

    eliasj7 Well-Known Member

    Joined:
    Jul 3, 2013
    Member:
    #107578
    Messages:
    52
    Gender:
    Male
    First Name:
    Elias
    Beaverton, OR
    Vehicle:
    2013 Tacoma TRD Offroad
    5100's w/ OME 885X, LR UCA's, OME Dakar Leaf Springs w/ OME Nitrochargers. Grillcraft MX Grill w/ white grill trim. AFE Intake. Redline Tuning Hood struts. ADD W1 Oil Catch Can. TRD Cat Back Exhaust.
  19. May 19, 2014 at 4:47 PM
    #19
    voz

    voz Nothing Witty To Say

    Joined:
    Apr 28, 2014
    Member:
    #128687
    Messages:
    5,454
    Gender:
    Male
    First Name:
    VOZ
    VOZLAND
    Vehicle:
    The Clean One
    In Progress, Progressively
    subd
     
  20. May 27, 2014 at 8:03 PM
    #20
    double dee

    double dee Well-Known Member

    Joined:
    Mar 15, 2011
    Member:
    #53104
    Messages:
    968
    Gender:
    Male
    Phoenix
    Vehicle:
    2016 Tacoma 4x4
    I wish someone would do a write up with pictures so I can get these things working :(
     

Products Discussed in

To Top