1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

air bag light on

Discussion in '2nd Gen. Tacomas (2005-2015)' started by toymachine, Sep 14, 2009.

  1. Sep 14, 2009 at 3:16 PM
    #1
    toymachine

    toymachine [OP] .

    Joined:
    Jun 8, 2008
    Member:
    #7178
    Messages:
    175
    after i installed my new headunit on my 08 DC i noticed an air bag light on . how would i turn it off?
     
  2. Sep 14, 2009 at 3:20 PM
    #2
    UpstateTacoma

    UpstateTacoma I'd rather be diving than working..

    Joined:
    Jun 13, 2009
    Member:
    #18385
    Messages:
    276
    Gender:
    Male
    Greenville SC
    Vehicle:
    2010 PreRunner!!!
    All Stock, future mods will be audio only!!
    Gotta take it to the dealership and have them reset the airbag code. I know with nissan trucks and cars you cant reset it anyways. you have to bring it to the dealership to have them reset it. if your a loyal customer at a dealership they may waive the diag fee, but ususally they dont..
     
  3. Sep 14, 2009 at 3:24 PM
    #3
    toymachine

    toymachine [OP] .

    Joined:
    Jun 8, 2008
    Member:
    #7178
    Messages:
    175
    i think im a loyal customer there hope they waive it. Thanks for the reply!
     
  4. Sep 14, 2009 at 3:25 PM
    #4
    UpstateTacoma

    UpstateTacoma I'd rather be diving than working..

    Joined:
    Jun 13, 2009
    Member:
    #18385
    Messages:
    276
    Gender:
    Male
    Greenville SC
    Vehicle:
    2010 PreRunner!!!
    All Stock, future mods will be audio only!!
    No problem.. Next time you do a headunit mod or anything that you have to take the dash out, if you disconnect the airbag (ususally yellow in color) harness, be sure you re connect it before you turn on the switch. (also disconnect the battery)
     
  5. Sep 14, 2009 at 3:28 PM
    #5
    Brunes

    Brunes abides.

    Joined:
    May 31, 2008
    Member:
    #7011
    Messages:
    17,641
    Gender:
    Male
    First Name:
    Rotorhead
    DC or New Jersey - Depends on the day....
    Vehicle:
    08 Red/Graphite and Satin Black
    Inside: Tint, Wet Okole 1/2 Piped Red/Black Covers, Black Weathertech Digital Fit Mats, URD Short Throw w/ TWM Weighted Knob, USA Spec iPod adapter. Outside: 4300K Retro w/ Angel Eyes and Red Shrouds, 5000K Blazer Fog Light Retrofit, Debadge, Bed Locking Handle, Satin Black Rims Performance: TRD/Steigmeier Blower w/ 2.7 Pulley. 668 Injectors and 320 LPH AEM Fuel pump. URD UCON and 7th Injector. DTLT Headers, URD Y-Pipe, Wicked Flow Muffler. Suspension: Both: OME Shocks Front: 886X's and TC UCAs Rear: Dakars Armor: Relentless Front Bumper Relentless High Clearance Rear w/ Tire/Rotopax Swing Out Relentless Front, Mid, and TCase skids BAMF Diff Skid Recovery and Spares: Fullsize Spare Tire 2x2 gal Rotopax 1x1 gal Rotopax 1x1 gal Water Rotopax Warn 9.5XP-S Winch Hi-Lift Extreme 60" Ironman Off-Road Recovery Kit
    Double check everything you did while installing the headunit. My guess is something is grounded incorrectly or you unplugged something and didn't clip it back together??

    Go back over your work before you take it to the dealer...but my guess is you are on the hook for getting them to look at it...and since it's something related to putting the radio in...I wouldn't hope for much of a deal from the service guys...
     
  6. Oct 22, 2009 at 5:27 PM
    #6
    RDAY

    RDAY Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    mine did the same thing the airbag will still work and everything if i were to be in accident right?
     
  7. Nov 13, 2009 at 9:04 PM
    #7
    car15

    car15 Well-Known Member

    Joined:
    Jul 31, 2009
    Member:
    #20435
    Messages:
    80
    Gender:
    Male
    AZ
    Vehicle:
    09 X-Runner
    So what is the verdict? I just installed an Eclipse AVN726E nav unit and now the airbag light is on. Help!
     
  8. Nov 13, 2009 at 10:44 PM
    #8
    rossk35

    rossk35 Do Work Son!

    Joined:
    Mar 26, 2009
    Member:
    #15197
    Messages:
    945
    Gender:
    Male
    hawaii
    Vehicle:
    07 TRD Sport Supercharged
    TRD S/C/TRD Intake/TRD Boost Gauge/DT Headers/OEM TL/ZKW retro/Pioneer DVD w/Ipod/Magnaflow/20% Tint/BHLM/JL 10" sub, JL VR components, JL 450/4 amp/Helwig Sway bar/Viper 791/ 18" limited 4runner rims
    does the clock or hazard button work?
     
  9. Nov 13, 2009 at 11:52 PM
    #9
    car15

    car15 Well-Known Member

    Joined:
    Jul 31, 2009
    Member:
    #20435
    Messages:
    80
    Gender:
    Male
    AZ
    Vehicle:
    09 X-Runner

    I have not been able to install it as of yet due to fit issues with the Metra dash kit.

    Why?
     
  10. Nov 14, 2009 at 12:03 AM
    #10
    TacomaHarry

    TacomaHarry Well-Known Member

    Joined:
    Jul 25, 2007
    Member:
    #2203
    Messages:
    151
    Gender:
    Male
    I just took mine in for the same thing. Air bag light on the dash was on.

    I tried to pull the battery terminal to reset it. Still on.

    Took it to the dealer and they replaced a connector behind the steering wheel.
    And it was covered under the 5 year 60,000 mile power train warranty.

    All's fine now.
     
  11. Nov 14, 2009 at 7:28 AM
    #11
    dktaco

    dktaco Yes MAObama is a joke!

    Joined:
    Nov 9, 2009
    Member:
    #25643
    Messages:
    286
    Gender:
    Male
    First Name:
    Josh
    So. Cal (D-town aka Downey)
    Vehicle:
    05' Pre-Runner SR5 6-spd Modded
    5100's set @ 2.5", Wheeler's AAL, Toyota factory trailer hitch w/ a Reese 3.5" drop ball, Gaylord's Tonneau cover, BLHM w/ 35w 6000k HID's, Lumincs yellow fogs, Sylvania 886 bulbs in taillights for reverse lights, Debadged, Dee-Zee nerf bars, Shorty black antenna, 3M rubberized billet grille & surround, Toyo Open Country AT's 31's, K&N intake, 40 series Flowmaster, Redline Racing Synthetic fluid all the way around, Wet Okole set covers, dash mat, Sirius Starmate 5 hardwired, Cobra radar detector hardwired, paint always taken care of the finest products from Autogeek.net and a Porter Cable dual action polisher.
    No it will not work. Take your vehicle to the dealer immediately. Mine came on and I got it reset.
     
  12. Nov 14, 2009 at 7:34 AM
    #12
    Asgard

    Asgard Well-Known Member

    Joined:
    Apr 19, 2008
    Member:
    #6078
    Messages:
    1,093
    Gender:
    Male
    First Name:
    Chris
    Vehicle:
    06 PreRunner DC SR5 w/LSD
    X2
    Did mine a couple weeks ago.
     
  13. Nov 14, 2009 at 10:27 AM
    #13
    Jimirich

    Jimirich Well-Known Member

    Joined:
    Mar 1, 2009
    Member:
    #14195
    Messages:
    238
    Gender:
    Male
    Hawaii
    Vehicle:
    08 4x4 Dbl cab shorty O.R. pkg
    DTRL, Debadged, Donkey tethered in the bed that rips 142 db farts so I can piss off the neighbors and rattle the windows on my house when I'm parked in front.
    If you do not have the hazard button console hooked up, the airbag light will be on. hook it up without installing it and see if the light goes out.
     
  14. Nov 14, 2009 at 10:35 AM
    #14
    car15

    car15 Well-Known Member

    Joined:
    Jul 31, 2009
    Member:
    #20435
    Messages:
    80
    Gender:
    Male
    AZ
    Vehicle:
    09 X-Runner
    Stupid me! Yes, I hooked up the console and the light is gone. Thanks!!

    Now I need to somehow adjust the Metra dash face. The dash face interferes with the AVN726E's screen movement.
     
To Top