1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Anybody actually had this issue?

Discussion in 'Suspension' started by deerman, Apr 28, 2014.

  1. Apr 28, 2014 at 3:02 PM

    deerman [OP] Deer Huntin Fool

    Feb 2, 2014
    First Name:
    Raleigh, NC
    2014 DCSB Super White TRD Offroad
    I am leaning towards getting an OME kit put on my 2014 DCSB here in the next couple weeks. And obviously, I'd like to keep the warranty if possible. My local dealer said that they would have to be able to prove that it was the lift that caused the issue in order for the warranty to be void. He said if he were talking to me outside of that uniform, he'd say "they've been lifting these trucks for 20 years. They've got it figured out". Told me that he'd do it if he were me without worry.

    I have seen other threads on related topics on what the dealer can and can't do (and Magnuson-Moss Act), but my question is...has anybody actually had an issue within 3 years that was an issue that is related to your lift? It seems like there is a lot of could-be scenarios on here, but I haven't seen anyone that actually had issues with the OME lift within 3 yrs/36k miles.
To Top