1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Anybody running Billys with moto metal 951

Discussion in '2nd Gen. Tacomas (2005-2015)' started by simmersm, Apr 29, 2010.

  1. Apr 29, 2010 at 9:34 AM
    #1
    simmersm

    simmersm [OP] Active Member

    Joined:
    Apr 21, 2010
    Member:
    #35707
    Messages:
    37
    Gender:
    Male
    Alexandria VA
    Vehicle:
    10 Black DBL Cab 4wd
    Anybody running Billys with moto metal 951 in a 16x8 with 285/75? Any rubbing issues on the UCA?

    thanks
     
  2. Apr 29, 2010 at 9:38 AM
    #2
    wiscdave

    wiscdave Lets Do It!

    Joined:
    Mar 20, 2008
    Member:
    #5392
    Messages:
    2,543
    Gender:
    Male
    Northern Wisconsin
    Vehicle:
    Tundra Rock Warrior
    Past ride - 3" OME 885s&Shocks/ TSB 1.5AAL/ AX184 Rims 285 Firestone destination ATs/ 2 Shallow mount P310s in Supercrew Box - Punch 601s, Beefed up Hunter Brush guard, Tint, Fog light mod, AFE Drop in, AC and Fog light mods, scangauge
    4.5 back spacing and your fine
     
  3. Apr 29, 2010 at 9:39 AM
    #3
    simmersm

    simmersm [OP] Active Member

    Joined:
    Apr 21, 2010
    Member:
    #35707
    Messages:
    37
    Gender:
    Male
    Alexandria VA
    Vehicle:
    10 Black DBL Cab 4wd
    thats what I was figuring. thanks for the reply.. now if i can just find a pic of one done :)
     
To Top