1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Anyone have rust issues with under the windshield?

Discussion in '1st Gen. Tacomas (1995-2004)' started by bobwilson1977, Jan 22, 2009.

  1. Jan 22, 2009 at 1:25 PM

    bobwilson1977 [OP] Well-Known Member

    Jan 7, 2009
    96 Tacoma 2WD ( pizza delivery model)
    none except for crappy hub caps and floor mats.
    Probably 11 Years ago I had my windshield replaced after it got nailed with a rock. Everything was fine until I noticed there was some rust bubbling up from under the weather stripping. I sort of ignored it for a few years until it really started to spread to outside the weather stripping and onto the outer edges of the window frame. Last year I wound up peeling back all the weather stripping, sanding it down, priming the area, painting it, and re-sealing it. It was rusted almost all the way through in a few spots and I filled these in. After that I thought I was good to go.

    Well, now that its the rainy season again, I've noticed that once more, there's a little bit of rust stain showing up under the paint of the repaired area. I'm guessing that some of it is underneath the replaced window. My suspicion is that the guys who installed the new glass must've scratched the paint putting it in and over the years it gradually rusted.

    I have no idea how to get rid of the rust short of removing the glass, which I can't because the replacement itself now has a few cracks, which means I'd have to replace the windshield. I have no clue how to install one so I guess I'd have to do the rust repair, then call someone to install new glass. What a pain in the ass!

    Course the other idea is that the truck is getting old and perhaps by the time the rust becomes a serious issue, I'll be gettin something newer anyway.

    Weird problem. Anyone else had this issue or have a good idea about what to do to solve it?
  2. Jan 23, 2009 at 6:39 AM

    EnolaGaia Well-Known Member

    Sep 9, 2006
    Midwest USA
    '01 & '04 S-Runners
    01 SR: Double Cab conversion, S/C, lowered.
    This sort of thing can happen with any vehicle, and it isn't a commonly-reported problem on pre-2005 Tacomas.

    It might be that the current (replacement) windshield, etc., is somehow trapping water around the frame area and promoting rust formation. If you did an adequate job on the rust repairs 'back when', it's kinda odd you'd be seeing the same problem in the same place.

    When you did the repairs, did you replace the weatherstripping, or did you reuse the old one? If you reused the old one it might have resulted in distortion or nicking that's helping water (and / or etc.) get to the metal around the windshield.
To Top