1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Are my leafs done??

Discussion in '1st Gen. Tacomas' started by Hektor, Jun 28, 2012.

  1. Jun 28, 2012 at 6:32 PM
    #1
    Hektor

    Hektor [OP] Well-Known Member

    Joined:
    Jan 7, 2010
    Member:
    #28955
    Messages:
    972
    Gender:
    Male
    Texas
    Vehicle:
    03 Tacoma DC TRD v6
    Here are some pics. [​IMG][​IMG]

    65k on my 2003.
     
  2. Jun 28, 2012 at 6:33 PM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Thor

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    103,833
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Look good to me
     
  3. Jun 28, 2012 at 6:36 PM
    #3
    medic2230

    medic2230 Ditch Doctor

    Joined:
    Oct 13, 2008
    Member:
    #9942
    Messages:
    10,254
    Gender:
    Male
    First Name:
    Murph
    Columbus, Ga
    Vehicle:
    2011 Taco 4x4 DCLB
    20% Tint, OME 3"complete lift with Dakar's, Light Racing UCA's, 285/75/16 Nitto Terra Grapplers, 10 HP TW sticker, Ultraguage, B.A.M.F. Rock Sliders, MedicFab Bed Rack, Relentless front bumper
    Yup looks good. They are still smiling. Unless you want us to talk you into a lift kit. Then we could re-evaluate the situation. :D
     
  4. Jun 28, 2012 at 6:36 PM
    #4
    Hektor

    Hektor [OP] Well-Known Member

    Joined:
    Jan 7, 2010
    Member:
    #28955
    Messages:
    972
    Gender:
    Male
    Texas
    Vehicle:
    03 Tacoma DC TRD v6
    Im just asking cause my rear squeaks every time I go thru bumpy roads.
     
  5. Jun 28, 2012 at 6:38 PM
    #5
    medic2230

    medic2230 Ditch Doctor

    Joined:
    Oct 13, 2008
    Member:
    #9942
    Messages:
    10,254
    Gender:
    Male
    First Name:
    Murph
    Columbus, Ga
    Vehicle:
    2011 Taco 4x4 DCLB
    20% Tint, OME 3"complete lift with Dakar's, Light Racing UCA's, 285/75/16 Nitto Terra Grapplers, 10 HP TW sticker, Ultraguage, B.A.M.F. Rock Sliders, MedicFab Bed Rack, Relentless front bumper
    My 1st gen ones would squeak when I was mall crawling over the speed bumps. :anonymous:
     
  6. Jun 28, 2012 at 6:38 PM
    #6
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Thor

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    103,833
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Dirt in the springs. use a high pressure washer and spray the ever loving shit out of them. If that doesnt work, brake fluid ( DO NOT GET IT ON PAINT!) has worked for me in the past. If those dont work, break them lose, clean them out, and re assemble.
     
  7. Jun 28, 2012 at 6:38 PM
    #7
    TACOMABOSS

    TACOMABOSS Well-Known Member

    Joined:
    Jul 7, 2011
    Member:
    #59499
    Messages:
    4,311
    Gender:
    Male
    Vehicle:
    96 SR5 4x4
    Bilstein 5100s, Toytec AAL, Deck plate mod, Hella 500ff's, Sportsman Camo seat covers, Total Chaos 1" diff drop, JVC stereo, Painted bumpers and grille, Custom grille insert, HID projectors, Black spray paint
    They dont look too bad
     
  8. Jun 28, 2012 at 6:39 PM
    #8
    TACOMABOSS

    TACOMABOSS Well-Known Member

    Joined:
    Jul 7, 2011
    Member:
    #59499
    Messages:
    4,311
    Gender:
    Male
    Vehicle:
    96 SR5 4x4
    Bilstein 5100s, Toytec AAL, Deck plate mod, Hella 500ff's, Sportsman Camo seat covers, Total Chaos 1" diff drop, JVC stereo, Painted bumpers and grille, Custom grille insert, HID projectors, Black spray paint
    X2
     
  9. Jun 28, 2012 at 6:40 PM
    #9
    Hektor

    Hektor [OP] Well-Known Member

    Joined:
    Jan 7, 2010
    Member:
    #28955
    Messages:
    972
    Gender:
    Male
    Texas
    Vehicle:
    03 Tacoma DC TRD v6
    Would do!! Thanks for all the fast responses. I guess I be saving some cash since I dont have to replace them yet.
     
  10. Jun 28, 2012 at 6:45 PM
    #10
    BuckWells

    BuckWells Well-Known Member

    Joined:
    Feb 21, 2011
    Member:
    #51588
    Messages:
    508
    Gender:
    Male
    First Name:
    Aaron
    Wichita, Kansas
    Vehicle:
    06 TRD Offroad
    painted badges, sockmonkey decals, CHLM, bed light mod, 20% tint, color match grille
    those look fine. you should see mine if you're worried about yours.
     
  11. Jun 28, 2012 at 6:55 PM
    #11
    Madjik_Man

    Madjik_Man The Rembrandt of Rattle Can

    Joined:
    Dec 2, 2009
    Member:
    #26893
    Messages:
    10,267
    Gender:
    Male
    Boulder, CO
    Vehicle:
    1998 Ext Cab TRD 5MT sunfire red pearl
    About 25 pounds of spray paint and vinyl dye
    Sheeeeeeeet... mine looked like that

    8 years ago
     
  12. Jun 28, 2012 at 6:55 PM
    #12
    TIPICOTACO

    TIPICOTACO Well-Known Member

    Joined:
    Nov 22, 2010
    Member:
    #46556
    Messages:
    1,982
    Gender:
    Male
    First Name:
    Tyler
    nw nj
    Vehicle:
    '01 DC 4X4 TRD "RAD BARON"
    Some lift, some armor, some scratches.. check out the build!
    na they look ok, mayb an AAL if you need a little more out of them

    for reference OP, this is what shot leaves look like :eek::eek:

    [​IMG]
     
  13. Jun 28, 2012 at 7:09 PM
    #13
    Madjik_Man

    Madjik_Man The Rembrandt of Rattle Can

    Joined:
    Dec 2, 2009
    Member:
    #26893
    Messages:
    10,267
    Gender:
    Male
    Boulder, CO
    Vehicle:
    1998 Ext Cab TRD 5MT sunfire red pearl
    About 25 pounds of spray paint and vinyl dye
    That's what mine look like
     
  14. Jun 28, 2012 at 7:32 PM
    #14
    Robertgeejr1

    Robertgeejr1 Well-Known Member

    Joined:
    Dec 21, 2011
    Member:
    #69167
    Messages:
    779
    Gender:
    Male
    First Name:
    Robert
    Aorora, Ill, yeah!
    Vehicle:
    1996 Toyota Tacoma SR5 4x4
    I have done all the hi-pro mods for a life time, since I got this truck at a great price, I will be happy with showroom new.
    Mine too! except one leaf on the drivers side is split....
     
  15. Jun 28, 2012 at 7:40 PM
    #15
    Hektor

    Hektor [OP] Well-Known Member

    Joined:
    Jan 7, 2010
    Member:
    #28955
    Messages:
    972
    Gender:
    Male
    Texas
    Vehicle:
    03 Tacoma DC TRD v6
    Wow I know what they look like!! I boy do any off road driving nor put heavy stuff on the bed. So I dnt think I need a aal.
     
  16. Jun 28, 2012 at 7:50 PM
    #16
    ffirg

    ffirg Well-Known Member

    Joined:
    Jun 9, 2011
    Member:
    #57975
    Messages:
    4,363
    Gender:
    Male
    First Name:
    mike
    Anchorage, Alaska
    Vehicle:
    2002 Tacoma SR5 TRD 4X4
    Deckplate mod, grey wire mod, Moromoto Mini H1 projectors, 20'' Blitzpro LED bar, two 6'' Blitzpro LED bars, ultra gauge, rhino lined bed, LED dome light in camper shell, and more to come...
    They look fine. I wish mine were that happy looking :mad:
     
  17. Jun 28, 2012 at 8:10 PM
    #17
    4WD

    4WD cRaZy oLdmAn

    Joined:
    Jul 2, 2009
    Member:
    #19185
    Messages:
    22,409
    Gender:
    Male
    First Name:
    Doug
    Gardnerville, Nevada
    Vehicle:
    No Truck
    Grey wire MOD, deck plate, diff breather MOD, 2nd gen. OME 883# on Tundra 5100's, OMD custom 3" leafsprings, rear shock relocation, Ivan Stewart TRD rims w/285/75/16's, '02 bumper MOD, Famous Fabrications sliders , LED interior/exterior lights, bed bar, Custom tube bumper, Old school KC day lighters,Red Ring 8" HID flood, Kenwood vhf 2M.. umm some other shit I'm forgetting right now
    If you dont offroad hard or carry heavy loads they got some life left, when they go to negative ARC, come talk to me.... as far as the squeak could be dirt in between leafs, or might be spring bushings either at the shakle end (rear) or the hanger end (front) don't put any type of heavy lubricant/grease or anything like that on your springs, All it does is attract dirt,etc;....
     
  18. Jun 28, 2012 at 8:20 PM
    #18
    Hektor

    Hektor [OP] Well-Known Member

    Joined:
    Jan 7, 2010
    Member:
    #28955
    Messages:
    972
    Gender:
    Male
    Texas
    Vehicle:
    03 Tacoma DC TRD v6
    So if the pressure washer dnt fix it I need to replace spring bushings???
     
  19. Jun 28, 2012 at 9:06 PM
    #19
    4WD

    4WD cRaZy oLdmAn

    Joined:
    Jul 2, 2009
    Member:
    #19185
    Messages:
    22,409
    Gender:
    Male
    First Name:
    Doug
    Gardnerville, Nevada
    Vehicle:
    No Truck
    Grey wire MOD, deck plate, diff breather MOD, 2nd gen. OME 883# on Tundra 5100's, OMD custom 3" leafsprings, rear shock relocation, Ivan Stewart TRD rims w/285/75/16's, '02 bumper MOD, Famous Fabrications sliders , LED interior/exterior lights, bed bar, Custom tube bumper, Old school KC day lighters,Red Ring 8" HID flood, Kenwood vhf 2M.. umm some other shit I'm forgetting right now

    If it is your bushings its probably dirt/or too dry between the shakle pins (where the springs slide on to) & the center sleeve in the bushing...

    Here its ok to use a little lithium grease or other non petroleum based heavy lube .. (petro based lubes will rot the rubber bushings over time..
     
  20. Jun 28, 2012 at 9:17 PM
    #20
    Hektor

    Hektor [OP] Well-Known Member

    Joined:
    Jan 7, 2010
    Member:
    #28955
    Messages:
    972
    Gender:
    Male
    Texas
    Vehicle:
    03 Tacoma DC TRD v6
    Cool thanks man.
     
To Top