1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

auto trans indicator stuck

Discussion in '1st Gen. Tacomas (1995-2004)' started by rafael, May 27, 2012.

  1. May 27, 2012 at 8:13 AM
    #1
    rafael

    rafael [OP] Member

    Joined:
    May 26, 2012
    Member:
    #79530
    Messages:
    8
    Gender:
    Male
    First Name:
    raf
    puerto rico
    Vehicle:
    SR5
    only displays ' P ' ?
     
  2. May 27, 2012 at 8:15 AM
    #2
    whippersnapper02

    whippersnapper02 Well-Known Member

    Joined:
    Dec 20, 2009
    Member:
    #27905
    Messages:
    35,214
    Gender:
    Male
    First Name:
    Christian
    Yorba Linda, CA
    Vehicle:
    10 MGM TRD OR 4wd Auto DCSB
    Banks Monster Exhaust, Pop n Lock tailgate lock, Hook-Ups tie down brackets, USA Spec Ipod adaptor, WO seat covers, color matched grill with Grillcraft insert, Tuffy locking bed box
    Probably a bad or loose shift position sensor. I think it is on the side of the trans.
     
  3. May 27, 2012 at 11:54 AM
    #3
    ffirg

    ffirg Well-Known Member

    Joined:
    Jun 9, 2011
    Member:
    #57975
    Messages:
    4,415
    Gender:
    Male
    First Name:
    mike
    Anchorage, Alaska
    Vehicle:
    2002 Tacoma SR5 TRD 4X4
    Deckplate mod, grey wire mod, Moromoto Mini H1 projectors, 20'' Blitzpro LED bar, two 6'' Blitzpro LED bars, ultra gauge, rhino lined bed, LED dome light in camper shell, and more to come...
    Do you mean the shifter won't shift out of park?
     
  4. May 28, 2012 at 9:44 AM
    #4
    rafael

    rafael [OP] Member

    Joined:
    May 26, 2012
    Member:
    #79530
    Messages:
    8
    Gender:
    Male
    First Name:
    raf
    puerto rico
    Vehicle:
    SR5
    Do you mean the shifter won't shift out of park?

    no - it shifts fine ;
     
  5. May 28, 2012 at 9:48 AM
    #5
    rafael

    rafael [OP] Member

    Joined:
    May 26, 2012
    Member:
    #79530
    Messages:
    8
    Gender:
    Male
    First Name:
    raf
    puerto rico
    Vehicle:
    SR5
    only displays ' P ' ?

    but shifts , ok .
     
  6. May 29, 2012 at 4:48 PM
    #6
    hossmaster

    hossmaster Well-Known Member

    Joined:
    Feb 22, 2012
    Member:
    #73399
    Messages:
    401
    Gender:
    Male
    League City, Tx
    Was a PreRunner, now it isn't
    It is possible that the indicator is broken in the shift mechanism. Take the cover off and have a peek and see if it's something that is easily fixed. I have a spare one, brown, that I might sell.

    [​IMG]
     
  7. May 31, 2012 at 8:12 AM
    #7
    rafael

    rafael [OP] Member

    Joined:
    May 26, 2012
    Member:
    #79530
    Messages:
    8
    Gender:
    Male
    First Name:
    raf
    puerto rico
    Vehicle:
    SR5
    a switch , outside the transmission itself ?

    may be , where the disconnect occurred ;

    thanks for sharing .
     
  8. May 31, 2012 at 8:18 AM
    #8
    rafael

    rafael [OP] Member

    Joined:
    May 26, 2012
    Member:
    #79530
    Messages:
    8
    Gender:
    Male
    First Name:
    raf
    puerto rico
    Vehicle:
    SR5
    thanks for the heads up , dude . . . you are seriously smart .
     
  9. May 31, 2012 at 8:24 AM
    #9
    rafael

    rafael [OP] Member

    Joined:
    May 26, 2012
    Member:
    #79530
    Messages:
    8
    Gender:
    Male
    First Name:
    raf
    puerto rico
    Vehicle:
    SR5
    ( thinks it is on the side of the trans. )

    must i drop trans , to get at it ?
     
  10. May 31, 2012 at 8:28 AM
    #10
    98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,164
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
    No, and if it were malfunctioning it would throw a code (you check engine light would be on). Do what Hossmaster suggested.
     
  11. May 31, 2012 at 3:57 PM
    #11
    hossmaster

    hossmaster Well-Known Member

    Joined:
    Feb 22, 2012
    Member:
    #73399
    Messages:
    401
    Gender:
    Male
    League City, Tx
    Was a PreRunner, now it isn't

    the physical link from the shifter to the transmission is on the side of the trans, if there was a problem with that it would be apparent.
     
  12. Jun 1, 2012 at 10:54 AM
    #12
    rafael

    rafael [OP] Member

    Joined:
    May 26, 2012
    Member:
    #79530
    Messages:
    8
    Gender:
    Male
    First Name:
    raf
    puerto rico
    Vehicle:
    SR5
    ( on passenger side ):| only a switch connector - at the top ;

    that cable joins another , that connects to Ox sensor but driver

    side only , has shift linkage ; where can i get auto trans diagram ?
     
To Top