1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Aux button works SOMETIMES / malfunction

Discussion in 'Audio & Video' started by DreDog, Nov 3, 2011.

  1. Nov 3, 2011 at 1:16 AM
    #1
    DreDog

    DreDog [OP] Well-Known Member

    Joined:
    Aug 18, 2011
    Member:
    #61929
    Messages:
    522
    Gender:
    Male
    First Name:
    Andrew
    Whittier, CA (90601)
    I have a 2009 prerunner and when i push my aux button on my stock head unit, so I can listen to my iPod, it goes to aux mode..but will sometimes go back to the regular radio. Ad I'll have to push the button like 10 times to get it to finally go back to my iPod. Or sometimes I have to unplug my aux cord and plug it back in to the jack and then push the button on my dash like 5 more times for it to go back to aux mode for my iPod.

    It is the most fucking annoying thing on earth. Does this happen to any of you guys? What can I do about it?
     
  2. Nov 3, 2011 at 2:54 PM
    #2
    DreDog

    DreDog [OP] Well-Known Member

    Joined:
    Aug 18, 2011
    Member:
    #61929
    Messages:
    522
    Gender:
    Male
    First Name:
    Andrew
    Whittier, CA (90601)
    Bump
     
  3. Nov 14, 2011 at 11:19 AM
    #3
    DreDog

    DreDog [OP] Well-Known Member

    Joined:
    Aug 18, 2011
    Member:
    #61929
    Messages:
    522
    Gender:
    Male
    First Name:
    Andrew
    Whittier, CA (90601)
  4. Nov 14, 2011 at 11:22 AM
    #4
    whippersnapper02

    whippersnapper02 Well-Known Member

    Joined:
    Dec 20, 2009
    Member:
    #27905
    Messages:
    35,214
    Gender:
    Male
    First Name:
    Christian
    Yorba Linda, CA
    Vehicle:
    10 MGM TRD OR 4wd Auto DCSB
    Banks Monster Exhaust, Pop n Lock tailgate lock, Hook-Ups tie down brackets, USA Spec Ipod adaptor, WO seat covers, color matched grill with Grillcraft insert, Tuffy locking bed box
    The 09 radios are junk. People have reported many issues with them.
     
  5. Nov 14, 2011 at 11:31 AM
    #5
    DreDog

    DreDog [OP] Well-Known Member

    Joined:
    Aug 18, 2011
    Member:
    #61929
    Messages:
    522
    Gender:
    Male
    First Name:
    Andrew
    Whittier, CA (90601)
    Well I was in a 2011 taco the other day and I noticed that now they have a USB port.

    Could I play my iPod through the USB?

    Or what should I do to fix that problem? I was looking at te USA spec 15 but do t wanna spend 100 for a stupid aux jack problem
     
  6. Nov 14, 2011 at 11:43 AM
    #6
    whippersnapper02

    whippersnapper02 Well-Known Member

    Joined:
    Dec 20, 2009
    Member:
    #27905
    Messages:
    35,214
    Gender:
    Male
    First Name:
    Christian
    Yorba Linda, CA
    Vehicle:
    10 MGM TRD OR 4wd Auto DCSB
    Banks Monster Exhaust, Pop n Lock tailgate lock, Hook-Ups tie down brackets, USA Spec Ipod adaptor, WO seat covers, color matched grill with Grillcraft insert, Tuffy locking bed box
    2012.:D

    They changed the stereo a bit for 2012 to incorporate the USB input and other features. I'm not sure if it would work on the older trucks.

    Have you looked into an ipod interface like Grom or USA Spec? It would be cheaper than buying a newer stock unit. I have the USA Spec unit and I love it. I got is for $120 shipped from ebay. Another option is a new headunit unless you want to stick with the stock one.
     
  7. Nov 14, 2011 at 11:57 AM
    #7
    DreDog

    DreDog [OP] Well-Known Member

    Joined:
    Aug 18, 2011
    Member:
    #61929
    Messages:
    522
    Gender:
    Male
    First Name:
    Andrew
    Whittier, CA (90601)
    I Don't have any plans on getting a new head unit. Or a different stock one.

    I have looked at a few different grom and USA spec models. I don't need to charge or control anything from my radio or steering wheel but I was just hoping that there was some way I could directly connect my iPhone to the radio with a cable just so that I could bypass using the aux jack

    Kind of like a caveman solution
     
  8. Nov 14, 2011 at 12:00 PM
    #8
    whippersnapper02

    whippersnapper02 Well-Known Member

    Joined:
    Dec 20, 2009
    Member:
    #27905
    Messages:
    35,214
    Gender:
    Male
    First Name:
    Christian
    Yorba Linda, CA
    Vehicle:
    10 MGM TRD OR 4wd Auto DCSB
    Banks Monster Exhaust, Pop n Lock tailgate lock, Hook-Ups tie down brackets, USA Spec Ipod adaptor, WO seat covers, color matched grill with Grillcraft insert, Tuffy locking bed box
  9. Nov 14, 2011 at 12:05 PM
    #9
    DreDog

    DreDog [OP] Well-Known Member

    Joined:
    Aug 18, 2011
    Member:
    #61929
    Messages:
    522
    Gender:
    Male
    First Name:
    Andrew
    Whittier, CA (90601)
    Yeah I saw the grom thing. Do you have the link to the DIY?
     
  10. Nov 14, 2011 at 12:10 PM
    #10
    whippersnapper02

    whippersnapper02 Well-Known Member

    Joined:
    Dec 20, 2009
    Member:
    #27905
    Messages:
    35,214
    Gender:
    Male
    First Name:
    Christian
    Yorba Linda, CA
    Vehicle:
    10 MGM TRD OR 4wd Auto DCSB
    Banks Monster Exhaust, Pop n Lock tailgate lock, Hook-Ups tie down brackets, USA Spec Ipod adaptor, WO seat covers, color matched grill with Grillcraft insert, Tuffy locking bed box
  11. Nov 14, 2011 at 12:14 PM
    #11
    Tacomanator

    Tacomanator Boiling denim and bangin whores

    Joined:
    Jul 25, 2010
    Member:
    #40746
    Messages:
    4,589
    Gender:
    Male
    First Name:
    Clam Slammer
    Here
    King 2.5" extended travel coilovers with compression adjusters, Camburg UCA's, King 2.5" rear shocks, Volant cold air intake with ram air scoop.
    Isn't your truck still under warranty? Take it to the dealer before you start ripping shit apart.
     
  12. Nov 14, 2011 at 12:14 PM
    #12
    MMazz365

    MMazz365 Well-Known Member

    Joined:
    Nov 7, 2009
    Member:
    #25564
    Messages:
    649
    Gender:
    Male
    First Name:
    Michael
    NY
    Vehicle:
    TRD Off Road
    -flowmaster dual side exit exhaust -3 inch lift -cb radio -scanner -DTRL's -Fogs Anytime -Truxedo Soft Tonnahu Cover -eyelids -grillcraft upper and lower -fogs behind the grill
    I have a similar problem, and it aggrivates me so much. I cant even use mine. Next time it's in the dealer im gonna have them replace it
     
  13. Nov 14, 2011 at 12:28 PM
    #13
    DreDog

    DreDog [OP] Well-Known Member

    Joined:
    Aug 18, 2011
    Member:
    #61929
    Messages:
    522
    Gender:
    Male
    First Name:
    Andrew
    Whittier, CA (90601)
    No way. The dealer is a bunch of idiots. I USED to have my cb plugged into my my cig lighter. Then one day it went out so I took it to the dealer. And they wired the cig to something else and after that, when I would plug the cb in, it kept blowing the cb's fuse.

    So now I have my cb wired to the battery.

    The dealer has no idea what there doing. That's why I do my own stuff now, plus you have to wait for like 4 hours for them to do it, and try jut make it worse
     
  14. Nov 14, 2011 at 12:30 PM
    #14
    DreDog

    DreDog [OP] Well-Known Member

    Joined:
    Aug 18, 2011
    Member:
    #61929
    Messages:
    522
    Gender:
    Male
    First Name:
    Andrew
    Whittier, CA (90601)
    Whipper snapper I saw that DIY but was nervous to try it. But now I guess I have no choice but to do it
     
  15. Nov 17, 2011 at 2:58 PM
    #15
    Aw9d

    Aw9d That one guy

    Joined:
    Nov 7, 2011
    Member:
    #66635
    Messages:
    12,337
    Gender:
    Male
    Are you sure you weren't looking at the 2012? I have a 2011 Taco with the white gauges, unless I"m missing it I don't have a usb port. I have a 3.5mm headphone jack.
     
  16. Feb 1, 2012 at 6:53 PM
    #16
    PhishPhryer

    PhishPhryer Well-Known Member

    Joined:
    Nov 24, 2011
    Member:
    #67608
    Messages:
    89
    Gender:
    Male
    First Name:
    John
    Lewisberry
    Vehicle:
    '09 Tacoma SR5
    I had the same problem. I took it to the stealership and they told me the aux jack was faulty and it would be $200 to replace. Anyone ever try to replace one on their own.
     
  17. Feb 26, 2012 at 9:38 AM
    #17
    mk7

    mk7 Active Member

    Joined:
    Sep 7, 2011
    Member:
    #63102
    Messages:
    44
    Gender:
    Male
    First Name:
    Michael
    Austin, TX
    Vehicle:
    '11 4x4 TRD Off Road
    DreDog,
    Did you get this fixed? I believe the AUX input jack has a sense switch that is used to detect when a cable is plugged in. You could connect the jack sense signal to the active state so your Headunit thinks that that a cable is always plugged in. I don't have a any details on how do this, I would have to take mine apart. There should be three wires for audio and an addional wire for the jack sense. You need a multimeter to check the wiring. The left audio channel is connected to the tip of the cable, the right audio channel is connected to the ring of the cable, and ground is connected to the sleeve. The jack sense will be switched by the connector when a cable is plugged in.
     
  18. Feb 26, 2012 at 10:25 AM
    #18
    Rmesa1

    Rmesa1 Well-Known Member

    Joined:
    Feb 9, 2012
    Member:
    #72515
    Messages:
    111
    Gender:
    Male
    Try a new cable if that doesn't work you probably need a new aux jack. They are easy to install the plug is right on the back.
     
  19. Feb 26, 2012 at 3:10 PM
    #19
    gopedguy101

    gopedguy101 Well-Known Member

    Joined:
    Oct 31, 2011
    Member:
    #66216
    Messages:
    131
    Gender:
    Male
    Cupertino, CA
    Vehicle:
    2005 V6 6 speed 4x4 TRD
  20. May 5, 2012 at 4:40 AM
    #20
    bishtacova

    bishtacova Don't buy a Ford

    Joined:
    Oct 13, 2009
    Member:
    #24239
    Messages:
    234
    Gender:
    Male
    Vehicle:
    2009 DC PreRunner V6
    4 leaf TSB, reflash ECM, Eurostyle antenna, thule roof rack, bed extender
    Same issue here in my 09 prerunner. The unit was replaced a while back. I have one month left on warranty as my aux jack is loose.
     
To Top