1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Axxess ASWC

Discussion in 'Audio & Video' started by PVT Pablo, Mar 11, 2013.

  1. Mar 11, 2013 at 3:51 PM
    #1
    PVT Pablo

    PVT Pablo [OP] Ultra Junior Member

    Joined:
    Jun 23, 2011
    Member:
    #58751
    Messages:
    708
    Gender:
    Male
    First Name:
    Paul
    Puerto Rico
    Vehicle:
    2011 TRD Off Road
    ICON 2.5" EXT Coil Overs SPC UCA's ICON 2.0" rear shocks Skyjacker 2.0" rear leaf springs 285/70/17 Duratracs mounted on 17" V-Tec Offroads Satoshi with BAMF Light Bar and 2 Hella 700FF's 2 1/2" Magnaflow after axle dump EBC USR Slotted Rotors/EBC 7000 Pads Wheeler's Superbumps RokBlokz Mud Flaps Stinger Sound Deadening
    Hello TW,

    So I ordered the Pioneer AVH-X5500BHS for my 2011 O/R w/ JBL. With it, I ordered the Axxess ASWC to keep my steering wheel buttons. I haven't gotten the stuff yet, but I fear that I may have gotten the wrong steering wheel adapter as a couple have websites have mentioned incompatability, stating instead that I need the ASWC-1.

    Anyone have any further information or experience? Trying to figure out if I should order the ASWC-1 now so I don't have to wait any longer after I figure out the ASWC doesn't work.

    Thanks!
     
  2. Mar 14, 2013 at 10:26 PM
    #2
    TreeFortRichard

    TreeFortRichard New Tacoma 0wner!!!

    Joined:
    Jan 18, 2013
    Member:
    #95515
    Messages:
    277
    Gender:
    Male
    Massachusetts (Central)
    Vehicle:
    '10 Access 4x4 SR5 Manual
  3. Mar 16, 2013 at 8:52 PM
    #3
    2012SilverSport

    2012SilverSport Well-Known Member

    Joined:
    Apr 16, 2012
    Member:
    #77067
    Messages:
    597
    Gender:
    Male
    Guam
    Vehicle:
    2012 Silver TRD Sport Double Cab
    CS Jumpers LED's throughout the cab and marker/DTRL's weather techs/seat covers. Head unit Pioneer AVHX5500BHS, Speakers, Front, Polk Audio DXi 6500 component, rear Polk Audio DXi 650s Subwoofer Sound Ordinance B-8PS, Amplifier Alpine KTP 445U. Front ICON extended travel 2.5 remote resi, Camburg UCA's. Rear ICON 2.0 remote res rear. Wheelers 3 leaf HD progressive AAL,
    I ordered the ASWC-1. Some of the issues are more with the pioneer than with the Toyota. There are mixed reviews where some worked and some didnt. so you have a 50 50 shot. I also believe that some of the issues have been operator error. If not done correctly you will have some functions, like volume but not phone functions etc. just make sure that you do the install procedures IAW the directions and you should be fine. I read some reviews where people were having difficulty so I went with the ASWC-1 just to be on the safe side.
     
  4. Mar 16, 2013 at 9:00 PM
    #4
    JW87

    JW87 Well-Known Member

    Joined:
    Jan 20, 2013
    Member:
    #95610
    Messages:
    72
    Gender:
    Male
    First Name:
    JW
    Richmond,VA
    Vehicle:
    TRD Sport 4x4
    Tonneu cover, bed rug, all weather mats, antennax 13", and sil protectors.
    I installed the aswc couple weeks ago no problem. I spent the extra $15 to get the plug and play adapter to eliminate splicing.
     
  5. Mar 17, 2013 at 10:39 AM
    #5
    2012SilverSport

    2012SilverSport Well-Known Member

    Joined:
    Apr 16, 2012
    Member:
    #77067
    Messages:
    597
    Gender:
    Male
    Guam
    Vehicle:
    2012 Silver TRD Sport Double Cab
    CS Jumpers LED's throughout the cab and marker/DTRL's weather techs/seat covers. Head unit Pioneer AVHX5500BHS, Speakers, Front, Polk Audio DXi 6500 component, rear Polk Audio DXi 650s Subwoofer Sound Ordinance B-8PS, Amplifier Alpine KTP 445U. Front ICON extended travel 2.5 remote resi, Camburg UCA's. Rear ICON 2.0 remote res rear. Wheelers 3 leaf HD progressive AAL,
    What deck did you install? I read mostly an incompatability with Pioneer decks originally. There is a reasone they updated it and from what I understand it was difficulty in recognizing blue tooth function for some decks. In the aswc it requires you to depress the hang up or pick up button once installed and deck/vehicle is recognized. Mine did not control the phone functions until I did that procedure. PVT Pablo, I hope that it works out for you. Read the small print...LOL...that is where I found the side note on the phone functions.
     
  6. Mar 26, 2013 at 12:14 PM
    #6
    PVT Pablo

    PVT Pablo [OP] Ultra Junior Member

    Joined:
    Jun 23, 2011
    Member:
    #58751
    Messages:
    708
    Gender:
    Male
    First Name:
    Paul
    Puerto Rico
    Vehicle:
    2011 TRD Off Road
    ICON 2.5" EXT Coil Overs SPC UCA's ICON 2.0" rear shocks Skyjacker 2.0" rear leaf springs 285/70/17 Duratracs mounted on 17" V-Tec Offroads Satoshi with BAMF Light Bar and 2 Hella 700FF's 2 1/2" Magnaflow after axle dump EBC USR Slotted Rotors/EBC 7000 Pads Wheeler's Superbumps RokBlokz Mud Flaps Stinger Sound Deadening
    So I got it all hooked up, everything is good to go except the bluetooth buttons. The hangup/pickup buttons don't work, and the voice button just turns the volume down. All the other buttons work flawlessly.

    It is strange however, my DVD fuction wont seem to work, I may have hooked up the E-Brake wire incorrectly, because other fuctions that need to have the e-brake connected, still work.

    (by the way silversport, I like the "IAW" you used there ;))
     
  7. Apr 10, 2013 at 1:43 PM
    #7
    6spd

    6spd Well-Known Member

    Joined:
    Feb 4, 2012
    Member:
    #72162
    Messages:
    851
    Gender:
    Male
    san diego
    Vehicle:
    2012 4x4
    (Pardon this post, thinking out loud, but also trying to compile all the info in this one post for future reference)

    damnit, shoulda done a search before I purchased the as2c-1. I'm also squealing my tires trying to get it to work with the pioneer 80prs.

    in the application chart, it designates two wires that need to get connected,

    1. violet/white
    2. yellow black

    do are these wires supposed to connect to a harness that is outisde of the radio wiring harness? all I have hooked up is power, ground, and the 3.5mm plug

    edit: actually, just noticed that the actual harness for the aswc-1 doesnt have those colors, so may be referencing the harness in the vehicle.
    edit 2: there are those colors in a harness in the vehicle.

    questions for those that have either the aswc or aswc-1 working, which wires are you guys using to get this to work?

    edit 3(found from another thread):

    another find:

    http://tacotunes.com/car-audio-vide...yota-tacoma-steering-wheel-control-manual.pdf
     
    Last edited: Apr 10, 2013
  8. Apr 15, 2013 at 5:40 PM
    #8
    6spd

    6spd Well-Known Member

    Joined:
    Feb 4, 2012
    Member:
    #72162
    Messages:
    851
    Gender:
    Male
    san diego
    Vehicle:
    2012 4x4
    so I finally got this steering wheel adapter/control to work. I have it paired up with a pioneer 80prs and it had auto detected it right away. volume control works, and the search works(next track AND fast forward or reverse search during playback. no next folder advance or revert, since that is a pioneer thing [for thumb drives or ipods<--havent tested the ipod]).

    for correct installation you will need this:
    http://axxessinterfaces.com/index.php?main_page=product_info&products_id=197

    and this to replace the harness that came with the module noted above:
    http://axxessinterfaces.com/index.php?main_page=product_info&cPath=11&products_id=109

    had I known this prior to installing the pioneer, it would have been nice. but I rest easy so far, that everything works as intended.

    if you can install a stereo, you can definitely install this steering wheel control harness. just do it at the same time, so you only install it once. :)
     
  9. Apr 16, 2013 at 10:41 PM
    #9
    Balot64

    Balot64 Well-Known Member

    Joined:
    Oct 24, 2011
    Member:
    #65740
    Messages:
    113
    Gender:
    Male
    Jax to San Diego, now Jax again
    Vehicle:
    2012 Tacoma Offroad 4x4
    FX-R HID retrofit, G2 Bak cover, N-fab step wanna be, Pop & Lock, Weathertech digifit floor mat, LED interior, OME front and rear shocks, OME 884, LR UCA, Wheeler 3 leaf pack. FJ black trail rims with 265/75/16 Michelin LTX MS2
    I have 2012 offroad and thinking of getting Pioneer 80 PRS also. So all the function of the steering wheel control works? Because I want all my steering wheel control works. Thanks.
     
  10. Apr 17, 2013 at 11:45 AM
    #10
    6spd

    6spd Well-Known Member

    Joined:
    Feb 4, 2012
    Member:
    #72162
    Messages:
    851
    Gender:
    Male
    san diego
    Vehicle:
    2012 4x4
    everything works minus the phone call buttons on the steering wheel as you would have to configure that through the stereo with your phone.
     
  11. May 2, 2013 at 5:49 PM
    #11
    jparf

    jparf blissfully biased

    Joined:
    Mar 31, 2013
    Member:
    #100976
    Messages:
    324
    Gender:
    Male
    First Name:
    Jason
    Mechanicsburg, PA
    Vehicle:
    15 Silver Highlander Limited
    Hopefully someone can answer. I'm going to install my X5500BHS this weekend. I didn't buy the factory adapter for the ASWC-1 and I it wouldn't be here this weekend if I ordered it. What exactly does this thing plug into? I bought the factory wiring harness for the Pioneer. Does it tap into that? Or is there a third harness behind the stock head unit it tapes into? This is a 2013 non entune. The website instructions say about plugging into pin 21 and 22 but I have no idea what pins those are.

    Any help or advice is appreciated.
     
  12. May 2, 2013 at 5:59 PM
    #12
    6spd

    6spd Well-Known Member

    Joined:
    Feb 4, 2012
    Member:
    #72162
    Messages:
    851
    Gender:
    Male
    san diego
    Vehicle:
    2012 4x4
    let's see if I can explain this easily. you would need two things to make the axxess to work properly(minus the bluetooth function, that is toatlly independent of the wiring from an aftermarket stereo)

    you would need the two items listed in post#8. the actual axxess controller, and the other wiring harness, purchased separately. the wiring harness that came with the controller is no good for us tacoma owners. the other harness replaces that.

    then you would need an aftermarket wiring harness to mate your aftermarket stereo to our factory wiring, making installation super easy.

    and last but not least, you would need a dash kit, metra, or I forget the other brand.

    once everything is in front of you, and you read this thread, installation should be easy peasy. if not, report back. you shouldn't have to cut any wires from the factory harness if you have the everything that I had listed. does your head unit support steering wheel controls(how new is it? if really new then probably so)?
     
  13. May 2, 2013 at 6:52 PM
    #13
    jparf

    jparf blissfully biased

    Joined:
    Mar 31, 2013
    Member:
    #100976
    Messages:
    324
    Gender:
    Male
    First Name:
    Jason
    Mechanicsburg, PA
    Vehicle:
    15 Silver Highlander Limited
    There has to be a way to get it to work without that adapter. Its the same head unit the OP has so it works. I just don't understand what wires it needs to plug into.
     
  14. May 2, 2013 at 7:50 PM
    #14
    6spd

    6spd Well-Known Member

    Joined:
    Feb 4, 2012
    Member:
    #72162
    Messages:
    851
    Gender:
    Male
    san diego
    Vehicle:
    2012 4x4
    buy the parts first. if you think you dont need them, you can at least return them. but if you try the install, and are missing some things, well, you wont know it and you'll be spinning your tires
     
  15. May 3, 2013 at 12:39 PM
    #15
    C Wills

    C Wills Well-Known Member

    Joined:
    Oct 18, 2011
    Member:
    #65441
    Messages:
    209
    Gender:
    Male
    First Name:
    Cearyx aka C Gutta
    Englewood,nj
    Vehicle:
    DCSB
    20% tint, extang trifecta tonneau cover.
    Why wouldn't it work?
     
  16. May 3, 2013 at 6:37 PM
    #16
    tstout23

    tstout23 Well-Known Member

    Joined:
    Sep 30, 2010
    Member:
    #44034
    Messages:
    70
    Gender:
    Male
    Vehicle:
    2013 access cab sr5 4x4
    the metra turbowire harness made to work with the aswc-1 doesnt work with the 2013 model trucks. the plugs are different. i purchased the harness thinking it would work and it doesnt. so what are we 2013 folks supposed to do?
     
  17. May 4, 2013 at 5:00 AM
    #17
    jparf

    jparf blissfully biased

    Joined:
    Mar 31, 2013
    Member:
    #100976
    Messages:
    324
    Gender:
    Male
    First Name:
    Jason
    Mechanicsburg, PA
    Vehicle:
    15 Silver Highlander Limited
    I emailed with metro and they have me the wire colors.

    Pin 21 violet/white
    Pin 22 yellow/black
    Pin 23 white/red



    I'm going to try it this afternoon. Will report back.

     
  18. May 4, 2013 at 9:00 AM
    #18
    tstout23

    tstout23 Well-Known Member

    Joined:
    Sep 30, 2010
    Member:
    #44034
    Messages:
    70
    Gender:
    Male
    Vehicle:
    2013 access cab sr5 4x4
    so i have to cut the factory plug from my truck. i dont really like that idea... because then it kinda becomes per-ma-nent </jase robertson voice>
     
  19. May 4, 2013 at 4:57 PM
    #19
    tstout23

    tstout23 Well-Known Member

    Joined:
    Sep 30, 2010
    Member:
    #44034
    Messages:
    70
    Gender:
    Male
    Vehicle:
    2013 access cab sr5 4x4
    UPDATE - for 2013 models the turbowire harness that metra sells to make this plug and play doesnt work. 2013 models have 28 pin plug and 2011-before have 20 pin plugs. i do not know if 2012 uses 28 pin plug or 20 pin plug. i used tap splices i bought at lowes in the electrical department to tap into 3 wires on the factory toyota steering wheel control plug, pins 21,22,and 23.

    here is how i installed aswc-1 and it auto detected and worked perfectly on a pioneer avic x940bt.

    aswc-1 red wire to red wire on metra radio harness
    aswc-1 black wire to black wire on metra radio harness
    aswc-1 green/orange wire to purple/white wire on the toyota steering wheel control factory plug
    aswc-1 black/green wire to yellow/black wire on toyota steering wheel control factory plug
    white/red wire to black wire on metra radio harness
     
  20. May 5, 2013 at 5:37 AM
    #20
    jparf

    jparf blissfully biased

    Joined:
    Mar 31, 2013
    Member:
    #100976
    Messages:
    324
    Gender:
    Male
    First Name:
    Jason
    Mechanicsburg, PA
    Vehicle:
    15 Silver Highlander Limited
    This is exactly what I did yesterday.


    At first my Bluetooth buttons were changing the source so with the help of another forum member I did the following: after the box has been configured and is working stop the truck and take out the keys. Restart the truck. With a paper clip hold the reset button in the aswc box for 5 seconds and no more than 10. After you release it will go through a bunch of lights and finally the red led will stay on. Now hold down the pick up or hang up button for about 3 seconds and the led will turn off. The Bluetooth buttons will now be paired. They only work when someone calls you unlike the tacoma which will bring up the phone menu if you press them. I always made calls from the phone so this never bothered me.




    I ordered the adapter but it looks like I won't be using it.


    Also I installed the Pioneer avh-x5500bhs. Great unit so far.
     
To Top