1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Bad Brake Problem (Not in my Tacoma)

Discussion in 'Technical Chat' started by I Liquid I, Mar 2, 2010.

  1. Mar 2, 2010 at 10:39 PM
    #1
    I Liquid I

    I Liquid I [OP] Well-Known Member

    Joined:
    Feb 11, 2010
    Member:
    #31207
    Messages:
    764
    Gender:
    Male
    Puerto Rico
    Vehicle:
    06 BSP Double Cab Long Bed
    Too many mods to list
    Im having a huge break problem in a Jeep Liberty 02 I own. Ive been going crazy going to a couple different mechanics, but all to no success. Id like to ask anyone here with experience in brake systems for their advice or their opinion on what it could be.

    The problem is that when the car is cold or just hasn't been run for about 10 minutes, when you press the brake pedal, it stops retardedly fast. Its a very sudden stop, like if you where pushing your pedal to the end, but in reality you just touched the pedal. It only seems to do this while the brakes are cold.

    The car has new pads (ceramic), the discs have been cut so they should be even and in good shape. Im going to get the mechanic to do a brake fluid flush and hope that fixes it, but it doesnt sound like it will.

    Up to now, at least half a dozen mechanics have seen the car and they all say the car is braking fine... at which I reply everytime with, ARE YOU CRAZY!!! Anyhow, its getting annoying to leave the car overnight so that the mechanics can starts the vehicle cold and look at the problem. Up to now, no mechanic has been able to find the problem, but im thinking its just because all the mechanics that have seen the car,... suck... Its a shame that my trusty mechanic doesnt work on american cars and he doesnt want to touch the Liberty... else it would probably be fixed by now.

    Thx in advance for any help with this dangerous problem im having.

    Edit: Just in case, I have gone to many Jeep Liberty forums, but nothing.
     
  2. Mar 5, 2010 at 6:06 PM
    #2
    I Liquid I

    I Liquid I [OP] Well-Known Member

    Joined:
    Feb 11, 2010
    Member:
    #31207
    Messages:
    764
    Gender:
    Male
    Puerto Rico
    Vehicle:
    06 BSP Double Cab Long Bed
    Too many mods to list
    Dam... No ideas?

    Think that car is cursed...

    Oh well, guess I can just crash into it with my Taco. Might be fun...
     
To Top