1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

bad throttle respone and bogging down

Discussion in '1st Gen. Tacomas (1995-2004)' started by 98yota, Jun 20, 2008.

  1. Jun 20, 2008 at 2:36 PM

    98yota [OP] Mean Green Machine

    Dec 5, 2007
    Marion, VA
    4WD Timberland Mica taco
    CAI, gutted cat, bed cover.
    hey guys, i have a 2.7 98 yota. i bought a option racing CAI last year and my brace broke that holds the filter up. i try to fix it to stay in the air but it just wants to fall back down. when i go to start it up, you can hear a "tap tap tap" and that where the bottom of it is smackin against the body and im afraid itll damage my MAF sensor. i can fix this somehow by making one, but it seems like its makin my truck have awful throttle response. also i gutted the converter about 6 months ago, not once did the CEL come on but it does seem like when you hit the throttle it seems like it takes about 1/4 sec later for it to kick in. and if you keep a steady pedal on the throttle in the low RPM range, it feels like itll go for a bit then it feels like it hesitates for a second, you can only tell when you drive it. i just need help, idk what to do but im buyin a high flow cat and a K&N CAI to fix both of these permanently. but if this doesnt work, what else can you think of? any help is appreciated.
To Top