1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

broke plug off block by oil filter

Discussion in 'Technical Chat' started by vickness, Mar 17, 2011.

  1. Mar 17, 2011 at 1:02 AM
    #1
    vickness

    vickness [OP] New Member

    Joined:
    Mar 17, 2011
    Member:
    #53176
    Messages:
    3
    Gender:
    Male
    I was changing my oil today on my 04 tacoma and my oil filter was hard as hell to get to and it was too tight to loosen by hand. I used an oil filter wrench to loosen but when broke free the handle snaped a plug on the block to the left of the filter. What is the plug?
     
  2. Mar 17, 2011 at 1:15 AM
    #2
    vickness

    vickness [OP] New Member

    Joined:
    Mar 17, 2011
    Member:
    #53176
    Messages:
    3
    Gender:
    Male
    Was changing my oil today and when I replaced the oil filter I somehow snapped the plug off block to the upper left of filter what is this plug
     
  3. Mar 17, 2011 at 1:16 AM
    #3
    vickness

    vickness [OP] New Member

    Joined:
    Mar 17, 2011
    Member:
    #53176
    Messages:
    3
    Gender:
    Male
    On 04 tacoma 6 cyl
     
  4. Mar 17, 2011 at 2:15 AM
    #4
    MountainEarth

    MountainEarth Well-Known Member

    Joined:
    Feb 1, 2010
    Member:
    #30519
    Messages:
    2,487
    Gender:
    Male
    First Name:
    Bryan
    CO
    Vehicle:
    2010 TRD OR Access
    Leer 100XR Shell, BedRug mat - comfy sleeping, GT Covers microfiber seat covers, BFG All Terrains 265/70r16, Dashmat, Antennax 13" shorty antenna, Weathertech liners, Ultra Gauge, Avid Light Bar, PIAA 520 ATPs, one old dog
  5. Mar 17, 2011 at 7:43 AM
    #5
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,156
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Can you post a pic?
     
  6. Mar 20, 2011 at 4:49 PM
    #6
    2000GTacoma

    2000GTacoma Well-Known Member

    Joined:
    Jan 29, 2011
    Member:
    #50183
    Messages:
    2,188
    Gender:
    Male
    Snow Hill NC
    Vehicle:
    00 Tacoma Ext. 3.4L SR5
    if its a 3.4 v6 sounds like the oil pressure sensor just replaced mine. it was leaking oil badly. $20 and replaced in 15 mins or so on a lift
     
To Top