1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Broken Windshield Wiper

Discussion in '2nd Gen. Tacomas' started by toyotacoma, Nov 16, 2009.

  1. Nov 16, 2009 at 9:25 PM
    #1
    toyotacoma

    toyotacoma [OP] Member

    Joined:
    Feb 9, 2009
    Member:
    #13459
    Messages:
    232
    Gender:
    Male
    Fort Collins
    Vehicle:
    07 Prerunner SR5
    Kenwood Excelon X-592 Custom TRD Badges
    I guess it got frozen to my windshield and when I tried to used it, it flew off the left side off of my windshield...anyway I can fix it?
    -I put it back in place, but it doesn't move with I use the wiper...
     
  2. Nov 17, 2009 at 9:32 AM
    #2
    toyotacoma

    toyotacoma [OP] Member

    Joined:
    Feb 9, 2009
    Member:
    #13459
    Messages:
    232
    Gender:
    Male
    Fort Collins
    Vehicle:
    07 Prerunner SR5
    Kenwood Excelon X-592 Custom TRD Badges

    It's not the actual wiper that is broken. It's the electric motor/gears...
    It wouldn't be that much of a problem if it wasn't on the driver's side.
     
  3. Nov 17, 2009 at 9:47 AM
    #3
    pataco

    pataco Well-Known Member

    Joined:
    Jan 1, 2009
    Member:
    #12092
    Messages:
    2,071
    Gender:
    Male
    Down by the lake
    Vehicle:
    05 4x4 trd dc white
    FOX 2.0 RESIS,LRUCAS,BILLY 5100S ON THE REAR.MAGNAFLOW 11264,COLOR MATCHED GRILL,YELLOW FOG MOD.OVER HEAD DVD,FEDERAL COURAGIA M/T
    sounds like new wiper motor is needed.
     
To Top