1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Car solutions reverse anytime + front camera install

Discussion in 'Audio & Video' started by abidar, Apr 15, 2019.

  1. Apr 15, 2019 at 11:03 AM
    #1
    abidar

    abidar [OP] Well-Known Member

    Joined:
    Mar 20, 2019
    Member:
    #287249
    Messages:
    54
    Gender:
    Male
    Vehicle:
    2016 TRD Sport DCLB 4x4
    This is a super simple mod that will add a front camera + reverse anytime viewing using the stock steering wheel controls (double tap mode button for use and use the left steering wheel's up/down control to switch cameras).

    Parts:
    Car solutions kit:
    https://www.amazon.com/dp/B07DKH6J4W/ref=cm_sw_em_r_mt_dp_U_21lTCb5BBYG43

    Natika backup camera:
    https://www.amazon.com/dp/B07H852D49/ref=cm_sw_em_r_mt_dp_U_D4lTCbPNBBA86

    Remove negative battery cable and boot it (for any electrical work).

    First I installed the front camera. In hindsight, I might do this last and check out view points while mounting the camera with zipties. Meh. It worked out. I drilled a hole in my pro grille, used the two sided 3m adhesive mount (included with camera), and tightened the lock nut down. Then, route the wire over towards the driver's side of the truck where the wires can pass through the firewall grommet. Eventually, you're going to want to pass these into the cab with a screwdriver or coat hanger. I won't describe that here, removing the trim has been explained in plenty of other threads.

    2j3mcep_50daad558a7c4177c75e0f9263188c202a5f216c.jpg


    On the inside of the truck, start taking apart the interior trim around the head unit. Grab the area I have highlighted like a climbing jug and gently pull.

    k1dgfd_3e4f512ea16305868df4e4408e44715ff34f889e.jpg


    This trim piece will separate from the head unit. The head unit is held in by 4x10 mm bolts. Remove these and pull the head unit forward. It should slide right out. If you have an auto, it'll sit conveniently on the shift knob.

    166x7ro_509c4ddddee8139f185d8f405abac8b698388251.jpg


    Pull the car solutions kit out of the box if you haven't already. You're basically going to match the connectors - it's pretty intuitive with labels that say "to monitor," "6V," and "12V," etc. I did not use the 6V connectors.

    2dj6kqx_09f95e3de5ac9f6b704c9e1d5bd03ee230e1dbc5.jpg


    These 3 connectors are going to be removed and replaced with the kit's connectors (this is literally the most difficult part to figure out about this install).

    155056h_f5483ac26c7c3e6ec5ae93e96cd93c46f4aa8fef.jpg


    12V wires crimped to appropriate black and red wires from the Natika camera. Yellow A/V cable connected.

    245wtgw_35a57c0aa1083ec529d9f7ae2289ec5748516bda.jpg


    Reconnect your negative battery cable and test your front/rear cams (again, using double tap of mode button and up/down).

    Front:
    kdmrdk_64f2019d38a13a305ed52a7a917ed9d3b13f8a15.jpg

    Rear:
    6eou2p_9e94bc8fa6a6fde04b713b093c35933d41b293e9.jpg


    If everything works out, tidy up the wiring harnesses, slide the head unit back in, retorque 10mm bolts, and replace the head unit trim piece.

    Enjoy.




    Disconnect negative battery cable for any of the following:

    You're going to want to mirror the camera's image if it's mounted on the front (clip white Natika wire). If you want the guide line to disappear, cut the green Natika wire.

    Natika instructions:
    2m5jtah_c21e5f17722cc4995b1f402a62680448ef46daf4.jpg


    Let me know if you have any questions. Very simple mod with great functionality and SOOOO much easier to park.
     
  2. Apr 15, 2019 at 11:06 AM
    #2
    Cav_BluTRD

    Cav_BluTRD TW Constituent

    Joined:
    Jan 30, 2019
    Member:
    #281288
    Messages:
    2,056
    Lake Sherwood, MO
    Vehicle:
    2019 Calvary Blue OR
    OVTune, RCI stuff, BD lights, UpTopOverland roof rack, Mobtown Stuff, Softopper, other stuff. Money pit.
    Good write up OP
    I have this done and it’s a nice addition.
     
    abidar [OP] likes this.
  3. Apr 15, 2019 at 12:33 PM
    #3
    Ziggyman

    Ziggyman Well-Known Member

    Joined:
    Nov 19, 2018
    Member:
    #273155
    Messages:
    119
    Gender:
    Male
    Vehicle:
    2018 TRD OR DBL 4x4
    Did this same thing Saturday. Good write up.
     
    abidar [OP] likes this.
  4. Apr 15, 2019 at 1:09 PM
    #4
    porterx

    porterx Well-Known Member

    Joined:
    Dec 3, 2018
    Member:
    #274643
    Messages:
    208
    Gender:
    Male
    I installed this a couple of weeks ago. It works great.

    I noticed that you are using the smaller connector that is between the 24 and 28 pin connectors. When I installed mine, there wasn't a connector plugged into that but there was one plugged into the small connector below it (right next to the blue connector in your picture). That's the one I used so i don't have anything plugged into the upper small connector.

    Yours works. Mine works. I guess it doesn't matter which one is used. When you started, which plug was the connector plugged into on your radio?
     
  5. Apr 15, 2019 at 1:30 PM
    #5
    abidar

    abidar [OP] Well-Known Member

    Joined:
    Mar 20, 2019
    Member:
    #287249
    Messages:
    54
    Gender:
    Male
    Vehicle:
    2016 TRD Sport DCLB 4x4

    Do all of your controls work (auto and manual)? Listed in the instructions:
    https://car-solutions.com/nfs/product/875000/file/rfcc_camera_control_system_manual_en.pdf


    EDIT**
    It also might be for the reverse camera - we don't need it because we've got the stock rear camera setup?
     
    porterx likes this.
  6. Apr 15, 2019 at 1:50 PM
    #6
    porterx

    porterx Well-Known Member

    Joined:
    Dec 3, 2018
    Member:
    #274643
    Messages:
    208
    Gender:
    Male
    I think they do. Well, I'm sure the front camera turns off way before I reach 20kph. I don't think the camera stays displayed for 30 seconds although I've not timed it. And it takes more than 1 second for the beep that forces the display to stay displayed until it is cancelled. More like 5 seconds.
     
  7. Apr 15, 2019 at 7:37 PM
    #7
    3rdturd

    3rdturd Well-Known Member

    Joined:
    Feb 23, 2012
    Member:
    #73481
    Messages:
    850
    Gender:
    Male
    Colorado
    Vehicle:
    2016 DCSB TRDOR
    Duct Tape
    How long will the camera be displayed
     
  8. Apr 15, 2019 at 7:42 PM
    #8
    Cav_BluTRD

    Cav_BluTRD TW Constituent

    Joined:
    Jan 30, 2019
    Member:
    #281288
    Messages:
    2,056
    Lake Sherwood, MO
    Vehicle:
    2019 Calvary Blue OR
    OVTune, RCI stuff, BD lights, UpTopOverland roof rack, Mobtown Stuff, Softopper, other stuff. Money pit.
    30 seconds in the front when removed from reverse. Or you can press the mode button twice to toggle on camera. Then press the driver side up button on the steering wheel til an audible beep is heard, then it will stay in camera mode until you move the shifter out of gear or press the mode button again. @3rdturd
     
    3rdturd, abidar [OP] and porterx like this.
  9. Apr 18, 2019 at 9:27 AM
    #9
    MacGyver18E

    MacGyver18E Member

    Joined:
    Apr 16, 2019
    Member:
    #290374
    Messages:
    11
    Gender:
    Male
    Vehicle:
    2019 Cement Tacoma TRD Off-Road
    Mine setup is due to arrive tomorrow via DHL - paid the $20 shipping - looking forward to being able to see how far my bumper is in front of me (and hoping it will help off road with logs/ditches); thanks for the detailed instructions abidar Love this feature in my wife's Explorer Platinum - the 360 would be really awesome; but too lazy to do all that work. . hahahahaha.
     
    abidar [OP] and porterx like this.
  10. Apr 18, 2019 at 10:55 AM
    #10
    abidar

    abidar [OP] Well-Known Member

    Joined:
    Mar 20, 2019
    Member:
    #287249
    Messages:
    54
    Gender:
    Male
    Vehicle:
    2016 TRD Sport DCLB 4x4
    I recently figured out (as part of this post) that if you hold the up button until it beeps, you keep the camera on, so I'm glad I wrote it up :thumbsup:.
     
    MacGyver18E likes this.
  11. Apr 19, 2019 at 7:09 PM
    #11
    Dammit Evie

    Dammit Evie This is Evie the Schnauzer

    Joined:
    Jun 4, 2018
    Member:
    #255466
    Messages:
    678
    Gender:
    Male
    First Name:
    Mike
    PNW -.-. .-.. .- ... ... .. ..-. .. . -..
    Vehicle:
    2018 Tacoma TRD Sport 4x4 DCSB A/T MGM
    2018 TRD 4x4 Sport DCSB V6 Auto Magnetic Grey Metalic Exterior Mods: TRD Pro SS catback exhaust | TRD Pro Grille | Redline Tuning hood QuickLIFT | OEM Tacoma bedmat | Black running boards | Derped chrome badges | Me-So Gashole | TRD Pro 17x8Alloy wheels Interior Mods: Black Clazzio Napa Leather seat covers |Aluminum stereo knobs Engine Mods: TRD Pro Intake Air Box Up Coming Mods: 265/70R17 Falken Wildpeak tires
    I installed the Natika front camera and the Car Solutions system, just like most of you have. Got everything wired up, rear camera works great, front camera nothing. So, I checked the power leads to the camera coming from the CS Controller and the +12V lead has no power (unit is running and able to switch front to back) but no front picture just a black screen. Has anyone else encountered this problem?

    Thanks in advance for your assistance.

    I can only surmise that the CS controller is defective.


     
  12. Apr 20, 2019 at 1:32 PM
    #12
    iampraneel

    iampraneel Well-Known Member

    Joined:
    Jan 6, 2019
    Member:
    #278405
    Messages:
    66
    Gender:
    Male
    When you shift from reverse to drive then start moving, does your front camera turn off? Mine does unless I creep very slowly but as soon as I press the gas it turns off.

    This is different than the description. Wondering if anyone else is experiencing the same.
     
    abidar [OP] and porterx like this.
  13. Apr 20, 2019 at 2:12 PM
    #13
    Cav_BluTRD

    Cav_BluTRD TW Constituent

    Joined:
    Jan 30, 2019
    Member:
    #281288
    Messages:
    2,056
    Lake Sherwood, MO
    Vehicle:
    2019 Calvary Blue OR
    OVTune, RCI stuff, BD lights, UpTopOverland roof rack, Mobtown Stuff, Softopper, other stuff. Money pit.
    I don’t have that problem. It stays on for 30 seconds then turns off.
     
    Dammit Evie likes this.
  14. Apr 20, 2019 at 2:21 PM
    #14
    Phoosa

    Phoosa Transient Goon

    Joined:
    Mar 8, 2015
    Member:
    #150436
    Messages:
    4,714
    Gender:
    Male
    First Name:
    Matt
    Vehicle:
    14 DCSB TRD OR
  15. Apr 20, 2019 at 3:30 PM
    #15
    iampraneel

    iampraneel Well-Known Member

    Joined:
    Jan 6, 2019
    Member:
    #278405
    Messages:
    66
    Gender:
    Male
    Do you have JBL head unit? Don’t know if that matters.
     
  16. Apr 20, 2019 at 6:51 PM
    #16
    Cav_BluTRD

    Cav_BluTRD TW Constituent

    Joined:
    Jan 30, 2019
    Member:
    #281288
    Messages:
    2,056
    Lake Sherwood, MO
    Vehicle:
    2019 Calvary Blue OR
    OVTune, RCI stuff, BD lights, UpTopOverland roof rack, Mobtown Stuff, Softopper, other stuff. Money pit.
    I have the JBL system, yes. Shouldn’t make a difference though.
     
    Dammit Evie likes this.
  17. Apr 20, 2019 at 8:04 PM
    #17
    abidar

    abidar [OP] Well-Known Member

    Joined:
    Mar 20, 2019
    Member:
    #287249
    Messages:
    54
    Gender:
    Male
    Vehicle:
    2016 TRD Sport DCLB 4x4
    Mine turns off unless I stay under 20 kph (whatever that is in freedom units). If I'm crawling, though, it'll stay on for 30 seconds.
     
  18. Apr 20, 2019 at 8:08 PM
    #18
    abidar

    abidar [OP] Well-Known Member

    Joined:
    Mar 20, 2019
    Member:
    #287249
    Messages:
    54
    Gender:
    Male
    Vehicle:
    2016 TRD Sport DCLB 4x4
    Sounds like bad controller if all of your wiring checks out. Have you traced it with a multimeter?
     
    Dammit Evie likes this.
  19. Apr 20, 2019 at 8:32 PM
    #19
    iampraneel

    iampraneel Well-Known Member

    Joined:
    Jan 6, 2019
    Member:
    #278405
    Messages:
    66
    Gender:
    Male
    I’ve noticed mine turns off as soon as I hit 2 mph crawl or giving it gas but this only happens when shifting from R to D. When I turn it on manually, I it stays on for 30 seconds regardless of speed.
     
    Black__cat and abidar [OP] like this.
  20. Apr 20, 2019 at 9:28 PM
    #20
    Dammit Evie

    Dammit Evie This is Evie the Schnauzer

    Joined:
    Jun 4, 2018
    Member:
    #255466
    Messages:
    678
    Gender:
    Male
    First Name:
    Mike
    PNW -.-. .-.. .- ... ... .. ..-. .. . -..
    Vehicle:
    2018 Tacoma TRD Sport 4x4 DCSB A/T MGM
    2018 TRD 4x4 Sport DCSB V6 Auto Magnetic Grey Metalic Exterior Mods: TRD Pro SS catback exhaust | TRD Pro Grille | Redline Tuning hood QuickLIFT | OEM Tacoma bedmat | Black running boards | Derped chrome badges | Me-So Gashole | TRD Pro 17x8Alloy wheels Interior Mods: Black Clazzio Napa Leather seat covers |Aluminum stereo knobs Engine Mods: TRD Pro Intake Air Box Up Coming Mods: 265/70R17 Falken Wildpeak tires
    The wiring checks out, the issue is the controller 12 volt feeds, no voltage. I also checked the 6 volt leads and they are OK but cannot use them.
    It's a bad controller.
    Thanks for your input.
     
To Top