1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

CB radio antenna ground

Discussion in 'Audio & Video' started by josh3972000, Apr 22, 2009.

  1. Apr 22, 2009 at 4:58 PM
    #1
    josh3972000

    josh3972000 [OP] Well-Known Member

    Joined:
    May 14, 2008
    Member:
    #6621
    Messages:
    86
    Gender:
    Male
    kentucky
    Vehicle:
    02 dbl cab TRD
    [​IMG]

    The antenna is a francis much like a firestik, why is it that with a ground wire ran to the frame the swr is off the chart, but when i remove the ground it meters at 2.0.
     
  2. Apr 22, 2009 at 5:11 PM
    #2
    sch0enne

    sch0enne Well-Known Member

    Joined:
    Sep 28, 2008
    Member:
    #9550
    Messages:
    367
    Gender:
    Male
    penticton British Columbia Canada
    Vehicle:
    03 Tacoma TRD
    bed lights, cobra 19 dx cb radio, flow pro muffler
    I did essentially the same antenna mount as you but i didnt use a ground wire and mine was tuned to within 5%. but yeah that seems kind of weird!
     
  3. Apr 22, 2009 at 5:17 PM
    #3
    jhodge83

    jhodge83 Any dog under 50# is a cat and cats are useless... Moderator

    Joined:
    Apr 27, 2007
    Member:
    #1432
    Messages:
    28,096
    Gender:
    Male
    First Name:
    Jamie
    Moncks Corner, SC
    Vehicle:
    09 Timberland Mica DC 4WD Sport
    wat?
    i'd say b/c the rails you are attached to have a path to the chasis ground through the bed. same thing happened w/ my antenna when i put it on my toolbox
     
To Top