1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

CEL ?/input

Discussion in '1st Gen. Tacomas (1995-2004)' started by Boosted TRD, May 7, 2015.

  1. May 7, 2015 at 10:54 PM
    #1
    Boosted TRD

    Boosted TRD [OP] your what hurts!?!?!?

    Joined:
    Dec 13, 2012
    Member:
    #93007
    Messages:
    742
    Gender:
    Male
    First Name:
    Zeb
    So Cal
    Vehicle:
    00 TRD SR5 4x4 5-spd supercharged, Cantilever L/T.
    TRD Supercharger, URD 7th injector, 2.2" S/C pulley, light weight crank pulley, CAI, CB exhaust, Camburg Mid-Travel front, LSK Cantilever L/T rear
    So a couple weeks ago after wheeling in hungry valley on the way home I got a CEL, checked the code & it was a P0171 (if I remember correctly) seemed to be running fine so cleared the code. Started noticing a hesitation at WOT but no CEL last weekend while wheeling in Mojave CEL came back, we checked it & same code, cleared it & came back on an hour later. So dropped off the truck, found a vacuum leak fixed it. CEL is still not back but still has the hesitation at WOT. Going to gap & install the new plugs from the 7th injector kit & put in a new fuel filter tomorrow. But im thinking its the airflow meter...you guys have any thoughts?Wanna get this taken care of before putting in the 7th injector kit & pulleys...
     
    Last edited: May 8, 2015
  2. May 8, 2015 at 11:14 AM
    #2
    mtucker

    mtucker Tacoma addict

    Joined:
    Aug 3, 2009
    Member:
    #20610
    Messages:
    300
    Gender:
    Male
    First Name:
    Matt
    Escondido, CA.
    Vehicle:
    03 Prerunner DC
    Replaced chrome badges with Sockmonkey black badges, painted billet grill black, K&N cold air intake, my corner light turn signal circuit, Speedfreek traction bars, RAAMaudio BXT/Ensolite, Stereo: Kenwood KIV-701 USB/Bluetooth deck, 10" Pioneer shallow sub behind the rear seat, Infinity 6822cf 6x8 front and rear doors, Fosgate P400-2 (sub), US Acoustics USX-4065 (four main speakers)
    Sounds very similar to what I was seeing (over about 75% throttle caused hesitation). I was getting P0171 (too lean). I replaced the MAF (air flow meter) since it was original and had 150K on it. Bam! She ran great again. You could try cleaning although a new one can be had on Amazon for $74. Denso 197-6020 Mass Air Flow Sensor.
     
  3. May 8, 2015 at 11:20 AM
    #3
    Boosted TRD

    Boosted TRD [OP] your what hurts!?!?!?

    Joined:
    Dec 13, 2012
    Member:
    #93007
    Messages:
    742
    Gender:
    Male
    First Name:
    Zeb
    So Cal
    Vehicle:
    00 TRD SR5 4x4 5-spd supercharged, Cantilever L/T.
    TRD Supercharger, URD 7th injector, 2.2" S/C pulley, light weight crank pulley, CAI, CB exhaust, Camburg Mid-Travel front, LSK Cantilever L/T rear
    That's what I was thinking, thanks!
     
  4. May 8, 2015 at 8:30 PM
    #4
    NightProwler

    NightProwler Well-Known Member

    Joined:
    Nov 12, 2013
    Member:
    #116470
    Messages:
    3,364
    Gender:
    Male
    First Name:
    Harlan
    Maricopa, Az
    Vehicle:
    '01 Prerunner, '03 cbr600rr, '09 R1
    Man I really wanna try replacing mine as well since I had a cel of the same, but ima be pissed if it doesn't work. Wish there was a way to tell......
     
  5. May 8, 2015 at 11:18 PM
    #5
    Boosted TRD

    Boosted TRD [OP] your what hurts!?!?!?

    Joined:
    Dec 13, 2012
    Member:
    #93007
    Messages:
    742
    Gender:
    Male
    First Name:
    Zeb
    So Cal
    Vehicle:
    00 TRD SR5 4x4 5-spd supercharged, Cantilever L/T.
    TRD Supercharger, URD 7th injector, 2.2" S/C pulley, light weight crank pulley, CAI, CB exhaust, Camburg Mid-Travel front, LSK Cantilever L/T rear
    Yours hesitating under 75%-WOT throttle? Or was it just a CEL for a min after your new exhaust?
     
  6. May 8, 2015 at 11:42 PM
    #6
    NightProwler

    NightProwler Well-Known Member

    Joined:
    Nov 12, 2013
    Member:
    #116470
    Messages:
    3,364
    Gender:
    Male
    First Name:
    Harlan
    Maricopa, Az
    Vehicle:
    '01 Prerunner, '03 cbr600rr, '09 R1
    After new exhaust. But I'm still convinced I have an issue even though it hasn't popped again... just trying to figure out how to diagnose it. I do get a big power boost at wot, at around 3500rpm, but no hesitation.. idk at this point I'm tempted to just buy the dang sensor and see what happens.
     
  7. May 9, 2015 at 12:30 AM
    #7
    NightProwler

    NightProwler Well-Known Member

    Joined:
    Nov 12, 2013
    Member:
    #116470
    Messages:
    3,364
    Gender:
    Male
    First Name:
    Harlan
    Maricopa, Az
    Vehicle:
    '01 Prerunner, '03 cbr600rr, '09 R1
    Not sure if this will really show anything. (And hope I'm not hijacking here but seems you've settled on a new maf) But I've been messing with torque app, tried a couple line charts of maf readings at wot from a stop up until 3rd gear. Here's the two tests I did..
    First is in grams per second. Drop off was after shifting into 3rd and letting off
    Second is cfm per second. A few seconds after 3rd.

    Anything look abnormal?
    Screenshot_2015-05-07-00-54-38_zpsf55wfr_ee20c7a974c8f722b70e4d0325dd72843e857655.jpg
    Screenshot_2015-05-07-00-58-11_zpsxlcxdb_05ae3cf05193336c1b609a4c05335510ad5a3ddd.jpg
     
  8. May 9, 2015 at 9:10 AM
    #8
    mtucker

    mtucker Tacoma addict

    Joined:
    Aug 3, 2009
    Member:
    #20610
    Messages:
    300
    Gender:
    Male
    First Name:
    Matt
    Escondido, CA.
    Vehicle:
    03 Prerunner DC
    Replaced chrome badges with Sockmonkey black badges, painted billet grill black, K&N cold air intake, my corner light turn signal circuit, Speedfreek traction bars, RAAMaudio BXT/Ensolite, Stereo: Kenwood KIV-701 USB/Bluetooth deck, 10" Pioneer shallow sub behind the rear seat, Infinity 6822cf 6x8 front and rear doors, Fosgate P400-2 (sub), US Acoustics USX-4065 (four main speakers)
    I'm not much of a mechanic, but since you don't have hesitation at WOT or near WOT I am not sure the MAF will help you much. My hesitation at WOT got worse over the years and eventually became hesitation at >75% throttle then I started getting CEL for P0171.
    Your grams/second MAF looks pretty good (similar to what I was getting after installing the new MAF). Here are my before and after new MAF screen grabs.

    Before new MAF.
    The MAF went just over 88g/s at approx 4600RPM.
    [​IMG]

    After the MAF, the hesitation was gone.
    I went a little higher in RPM in this test (since it was running so much better and wasn't hesitating). At about 4900RPM, the MAF showed 120 g/s. Even if you try to eyeball the MAF reading for 4600RPM for apples to apples, the MAF was showing around 110g/s. The old MAF was definitely reporting too low.
    [​IMG]

    After this, I replaced the K&N "cold air intake" that was put on by the first owner with a used stock intake setup that I bought from someone locally and the truck runs outstanding now.
     
    NightProwler likes this.
  9. May 9, 2015 at 12:55 PM
    #9
    Boosted TRD

    Boosted TRD [OP] your what hurts!?!?!?

    Joined:
    Dec 13, 2012
    Member:
    #93007
    Messages:
    742
    Gender:
    Male
    First Name:
    Zeb
    So Cal
    Vehicle:
    00 TRD SR5 4x4 5-spd supercharged, Cantilever L/T.
    TRD Supercharger, URD 7th injector, 2.2" S/C pulley, light weight crank pulley, CAI, CB exhaust, Camburg Mid-Travel front, LSK Cantilever L/T rear
    Air flow meter did the trick! Now getting my 7th injector kit put in along with the 2.2" S/C pulley & light weight crank pulley. Should hopefully be a whole new animal!
     
    NightProwler likes this.

Products Discussed in

To Top