1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

cel is on i have a slew of codes

Discussion in '1st Gen. Tacomas (1995-2004)' started by toysr5man, Nov 4, 2010.

  1. Nov 4, 2010 at 3:58 PM
    #1
    toysr5man

    toysr5man [OP] Auto thrasher

    Joined:
    Aug 2, 2010
    Member:
    #41131
    Messages:
    54
    Gender:
    Male
    First Name:
    Doug
    downtown, castile ny
    Vehicle:
    03 tundra trd. 01 taco 4x4 4cyl.
    5100 billys, add a leaf, 6.5 ' meyer plow, 265/75/16. diff drop, tundra brake upgrade, wheelers stainless stell braided brake lines, steering column mod
    hi guys.
    i bought a 01 tacoma acouple months back. it didnt run when i bought it. we found i had a broken flex plate. we replaced with a used one and she runs good. ive been tinkering with it for a while now. i put it on the road today, and of course the cel light came on. it was on when i bought it but having the battery unhooked it went off. i had been running it around the yard and it stayed off.

    so here comes the typical question why is it on? lol.
    i have three codes
    p0125
    p0141
    p1135.

    these codes are off a mac scanner, these are in the order they apper.
    i have been researching on here and am more confused then when i started.

    my buddy with the scanner checked the coolant temp. in park with his foot on the gas, about 1500 rpm's it read at a high reading of 194 degrees. so i believe the t-stat is working fine. at a idle it read 180.

    when i got done with my buddy and his mac scanner i had advance auto double check it. thy matched his codes in the same order.

    there suggestion was to start with the cooloant temp switch. so theres no confusion cause i could be getting it wrong. its not the switch for the gauge but the one for the ecm.

    so my real question is, if this was your truck where would you start? in some of the old posts i went through , i could tell there where some people on here that really new there shit. hoping one of you guys will chime in.

    thanks again
    and before i forget she is an 01 taco 4x4 4cl 2.7l auto.
    any help is appreciated
    thanks
    doug
     
To Top