1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Cel!!! No

Discussion in 'Performance and Tuning' started by ETaco23, Oct 25, 2009.

  1. Oct 25, 2009 at 2:19 PM
    #1
    ETaco23

    ETaco23 [OP] Marshall offroad Fabrication

    Joined:
    Feb 2, 2008
    Member:
    #4544
    Messages:
    5,331
    Gender:
    Male
    First Name:
    Evan
    PNW
    Vehicle:
    13' Pyrite Mica TRD Offroad DCSB 4x4
    Color Match Grille, Bed mat, Icon's with JBA UCA's, Dakars and 295 BFG KO2, Bora 1" spacers, Snugtop Canopy, and my "Marshall Fabrication" Rock Sliders.
    I got a check engine light today, and went to auto zone to get the codes. its the 881. 2,3,and 4
    all having to do with emmisions. So what do you guys think I should try?
    I was planning on getting a new AF sensor soon, so maybe that will do the trick?:eek:
     
  2. Oct 25, 2009 at 2:23 PM
    #2
    paintdiddy

    paintdiddy Machine gun shits

    Joined:
    Oct 12, 2008
    Member:
    #9924
    Messages:
    10,307
    Gender:
    Male
    First Name:
    shithead
    nj and not from "the jersey shore"
    Vehicle:
    silver bullet
    try testing the egr valve. mine took a crap on my 02. the little square box underneath it went bad as well. mine was a 4 banger so lay out would be different
     
  3. Oct 25, 2009 at 2:32 PM
    #3
    ETaco23

    ETaco23 [OP] Marshall offroad Fabrication

    Joined:
    Feb 2, 2008
    Member:
    #4544
    Messages:
    5,331
    Gender:
    Male
    First Name:
    Evan
    PNW
    Vehicle:
    13' Pyrite Mica TRD Offroad DCSB 4x4
    Color Match Grille, Bed mat, Icon's with JBA UCA's, Dakars and 295 BFG KO2, Bora 1" spacers, Snugtop Canopy, and my "Marshall Fabrication" Rock Sliders.
    just replaced it not to long ago. But thanks for the oppinion man!
     
  4. Oct 25, 2009 at 2:34 PM
    #4
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,156
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    A "P08**" code is a tranny issue.....But I cant find a P0881 code anywhere in the service manual. Are you SURE thats the correct code?
     
  5. Oct 25, 2009 at 3:10 PM
    #5
    ETaco23

    ETaco23 [OP] Marshall offroad Fabrication

    Joined:
    Feb 2, 2008
    Member:
    #4544
    Messages:
    5,331
    Gender:
    Male
    First Name:
    Evan
    PNW
    Vehicle:
    13' Pyrite Mica TRD Offroad DCSB 4x4
    Color Match Grille, Bed mat, Icon's with JBA UCA's, Dakars and 295 BFG KO2, Bora 1" spacers, Snugtop Canopy, and my "Marshall Fabrication" Rock Sliders.
    oh, I see where the code is! sorry
    its a P0420
     
  6. Oct 25, 2009 at 3:28 PM
    #6
    ETaco23

    ETaco23 [OP] Marshall offroad Fabrication

    Joined:
    Feb 2, 2008
    Member:
    #4544
    Messages:
    5,331
    Gender:
    Male
    First Name:
    Evan
    PNW
    Vehicle:
    13' Pyrite Mica TRD Offroad DCSB 4x4
    Color Match Grille, Bed mat, Icon's with JBA UCA's, Dakars and 295 BFG KO2, Bora 1" spacers, Snugtop Canopy, and my "Marshall Fabrication" Rock Sliders.
    I ordered a new A/F sensor from Rockauto for 140. Bc I know its probably a good idea to change it at 111k miles. But If that doesnt help, what should I try next? rear o2 or cat.?
     
  7. Oct 25, 2009 at 3:32 PM
    #7
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,156
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    That code doesnt have anything to do with the MAF. Check for exhaust leaks. It could also be the Sensor 2 O2 sensor, or the cat.
     
  8. Oct 25, 2009 at 3:32 PM
    #8
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,156
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Oopps....You rdered an AF sensor. YES. Thats a good thing to change.
     
  9. Oct 25, 2009 at 3:37 PM
    #9
    ETaco23

    ETaco23 [OP] Marshall offroad Fabrication

    Joined:
    Feb 2, 2008
    Member:
    #4544
    Messages:
    5,331
    Gender:
    Male
    First Name:
    Evan
    PNW
    Vehicle:
    13' Pyrite Mica TRD Offroad DCSB 4x4
    Color Match Grille, Bed mat, Icon's with JBA UCA's, Dakars and 295 BFG KO2, Bora 1" spacers, Snugtop Canopy, and my "Marshall Fabrication" Rock Sliders.
    Well I dont think I have a leak, I checked for leaks after Installing my Headers really well. And Im verry parranoid about that type of stuff, But I will check everything out again. But I dont hear one.
    And I really hope its not the cat, bc I had to cut and weld that flange on it for my headers, and that was a PITA, and dont want to have to re-do that! Damn this sucks!
     
  10. Oct 25, 2009 at 3:52 PM
    #10
    ETaco23

    ETaco23 [OP] Marshall offroad Fabrication

    Joined:
    Feb 2, 2008
    Member:
    #4544
    Messages:
    5,331
    Gender:
    Male
    First Name:
    Evan
    PNW
    Vehicle:
    13' Pyrite Mica TRD Offroad DCSB 4x4
    Color Match Grille, Bed mat, Icon's with JBA UCA's, Dakars and 295 BFG KO2, Bora 1" spacers, Snugtop Canopy, and my "Marshall Fabrication" Rock Sliders.
    Im ganna try disconnecting the battery first, bc I never did when installing the headers and having all my leaking problems. lol So this is step one.
     
  11. Oct 25, 2009 at 4:25 PM
    #11
    ETaco23

    ETaco23 [OP] Marshall offroad Fabrication

    Joined:
    Feb 2, 2008
    Member:
    #4544
    Messages:
    5,331
    Gender:
    Male
    First Name:
    Evan
    PNW
    Vehicle:
    13' Pyrite Mica TRD Offroad DCSB 4x4
    Color Match Grille, Bed mat, Icon's with JBA UCA's, Dakars and 295 BFG KO2, Bora 1" spacers, Snugtop Canopy, and my "Marshall Fabrication" Rock Sliders.
    well the CEL is off now, And I hope it stays off!
     
  12. Oct 26, 2009 at 9:13 PM
    #12
    ETaco23

    ETaco23 [OP] Marshall offroad Fabrication

    Joined:
    Feb 2, 2008
    Member:
    #4544
    Messages:
    5,331
    Gender:
    Male
    First Name:
    Evan
    PNW
    Vehicle:
    13' Pyrite Mica TRD Offroad DCSB 4x4
    Color Match Grille, Bed mat, Icon's with JBA UCA's, Dakars and 295 BFG KO2, Bora 1" spacers, Snugtop Canopy, and my "Marshall Fabrication" Rock Sliders.
    Is it true that it can take almost 50 to 70 miles for a CEL to come back on, after clearing codes/disconecting battery?
     
  13. Oct 26, 2009 at 9:15 PM
    #13
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    yep......sometimes...it may be a couple hundred miles.....sometimes,in my case.....i cleared it and it came back on 2 minutes later.
     
  14. Oct 26, 2009 at 9:15 PM
    #14
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,156
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Sometimes. Most times it comes on sooner.
     
  15. Oct 26, 2009 at 9:22 PM
    #15
    08pretaco

    08pretaco Almost there

    Joined:
    Sep 26, 2008
    Member:
    #9502
    Messages:
    9,059
    Gender:
    Male
    First Name:
    Oliver
    az
    Vehicle:
    2014 Tundra 4x4 CM 5.7L SR5
    AFE pro dry s, Husky X-act Contour
    do you have a 2.7? cause mine through that also and i just tightened up the recirc valve
     
  16. Oct 26, 2009 at 9:25 PM
    #16
    ETaco23

    ETaco23 [OP] Marshall offroad Fabrication

    Joined:
    Feb 2, 2008
    Member:
    #4544
    Messages:
    5,331
    Gender:
    Male
    First Name:
    Evan
    PNW
    Vehicle:
    13' Pyrite Mica TRD Offroad DCSB 4x4
    Color Match Grille, Bed mat, Icon's with JBA UCA's, Dakars and 295 BFG KO2, Bora 1" spacers, Snugtop Canopy, and my "Marshall Fabrication" Rock Sliders.
    no its the 3.4L
    I geuss I will just wait and see if it comes back. thanks guys!
     
To Top