1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Cheap 4.3 TFT Screen Power Help

Discussion in 'Audio & Video' started by yog182, Nov 12, 2012.

  1. Nov 12, 2012 at 4:17 PM
    #1
    yog182

    yog182 [OP] NewbSauce

    Joined:
    Oct 29, 2012
    Member:
    #90015
    Messages:
    15
    Gender:
    Male
    First Name:
    Nathan
    Harrisburg
    Vehicle:
    06 Taco TRD Off Road
    17 Procomp Rims 2.5 inch lift Flow Master Exhaust K&N Intake
    Hey guys and gals,

    I picked up a cheap 4.3 tft monitor on amazon to use with my tailgate back up camera and i cannot for the life of me to get it powered on. I ran the hot from the green wire from my compass and used the ground on the extra lights on top. This did not work. So i pulled the radio and ran it from the red switched power and ground and still no luck once its plugged in. I am stumped.. I even ran the mutimeter on the plug after it was connected and it had juice going through it. Any thoughts? Below is a link to the monitor.

    I checked the inline fuse and it does not look blown.

    http://www.amazon.com/gp/product/B006MPRFJQ/ref=oh_details_o01_s00_i00

    Any insight would be appreciated!!

    Thanks
     
  2. Nov 12, 2012 at 4:23 PM
    #2
    maineah

    maineah Well-Known Member

    Joined:
    Mar 24, 2011
    Member:
    #53641
    Messages:
    3,598
    Gender:
    Male
    First Name:
    Tim
    Maine
    Vehicle:
    4X4 SR5 V6 6spd
    Looks to have 2 video inputs try them both? Also there is a menu button on the back that do any thing?
     
  3. Nov 12, 2012 at 4:29 PM
    #3
    yog182

    yog182 [OP] NewbSauce

    Joined:
    Oct 29, 2012
    Member:
    #90015
    Messages:
    15
    Gender:
    Male
    First Name:
    Nathan
    Harrisburg
    Vehicle:
    06 Taco TRD Off Road
    17 Procomp Rims 2.5 inch lift Flow Master Exhaust K&N Intake
    It does have 2 inputs.. I have one rca cable that i ran from a factory tailgate handle camera using 18 gauge shielded wire and i soldered the end on. I tried both inputs and tried playing with the menu button on the back and nothing.. I figured i would at least get a blue screen or something that flickers on with first start.
     
  4. Nov 13, 2012 at 4:20 AM
    #4
    maineah

    maineah Well-Known Member

    Joined:
    Mar 24, 2011
    Member:
    #53641
    Messages:
    3,598
    Gender:
    Male
    First Name:
    Tim
    Maine
    Vehicle:
    4X4 SR5 V6 6spd
    You should get a menu screen even with out a connection. Amazon is real good about returns.
     
  5. Nov 15, 2012 at 8:08 AM
    #5
    yog182

    yog182 [OP] NewbSauce

    Joined:
    Oct 29, 2012
    Member:
    #90015
    Messages:
    15
    Gender:
    Male
    First Name:
    Nathan
    Harrisburg
    Vehicle:
    06 Taco TRD Off Road
    17 Procomp Rims 2.5 inch lift Flow Master Exhaust K&N Intake
    It actually did need a input. Found that my source was bad and the screen works fine. After changing out the plugs it works like a charm. Thanks a lot!
     
To Top