1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Check engine light flashing, motor running bad

Discussion in '4 Cylinder' started by alboy, Aug 26, 2008.

  1. Aug 26, 2008 at 8:14 PM
    #1
    alboy

    alboy [OP] Member

    Joined:
    Feb 21, 2008
    Member:
    #4869
    Messages:
    10
    florida
    Vehicle:
    98 SR5 4 wheel drive
    feels like not all cylinders are firing. ran codes and got p0125, p0401, and p1300. also just had some welding done to exhaust and i know they never disconnected my battery could have something to do with it?
     
  2. Aug 26, 2008 at 10:05 PM
    #2
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    13,614
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2007 4.0L 4x4 TRD Sport Access Cab A
    Advantage Torza top (tri-fold), Husky floor mats, RuffTuff seat covers, C2C hood struts, Homelink mirror, USA Spec PA15-Toy (120gig Classic & 8gig nano), Garmin Nuvi 660, Protecta Bed mat, Pop-n-lock, TSB Springs, Scangauge II, Heated drivers seat, Fumoto drain valve, Aries pushbar, PIAA 540 fog lights, Hood scoop grahics, Flowmaster 50 series dual catback exhaust, RainX Latitude windshield wipers, Husky rear floor liner (ontop of folded down seats). Console Vault.
    Did you do any research on the codes?

    Check out this website and scroll down to look up the codes:
    http://www.troublecodes.net/Toyota/

    Happy reading!

    P0125 - Insufficient Coolant Temperature for Closed Loop Fuel Control.
    http://www.parksoffroad.com/tacomamods/maintitems/enginecode/cip0125.pdf

    P0401 - EGR Flow Insufficient.
    http://www.tankota.net/repair/Repair_Manual/03tacoma/di/eg2rzfe3/cip0401.pdf

    P1300 - Igniter Circuit - No. 1.
    http://www.parksoffroad.com/tacomamods/maintitems/enginecode/cip1300.pdf
     
  3. Aug 27, 2008 at 6:21 PM
    #3
    sormi

    sormi Active Member

    Joined:
    May 17, 2008
    Member:
    #6695
    Messages:
    31
    Texas
    Vehicle:
    Plane Jane with SR5
    So did you get it fixed? Did the welding cause any problems? I'd like to know seeing i'm about to have a muffler put in.
     
  4. Aug 27, 2008 at 11:19 PM
    #4
    alboy

    alboy [OP] Member

    Joined:
    Feb 21, 2008
    Member:
    #4869
    Messages:
    10
    florida
    Vehicle:
    98 SR5 4 wheel drive
    problem fixed replaced plug wires. misfiring was the problem.
     
  5. Aug 27, 2008 at 11:23 PM
    #5
    tacomaman06

    tacomaman06 Carolina Alliance: Lead, follow, or get the hell o Thor

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,352
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '13 Silverado ext cab
    you wont have any trouble at all with a cel just having a muffler welded in.
     
To Top