1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

check engine light on and high idling? i need help

Discussion in '2nd Gen. Tacomas (2005-2015)' started by sdTACOmaniac, Nov 17, 2009.

  1. Nov 17, 2009 at 7:31 PM
    #1
    sdTACOmaniac

    sdTACOmaniac [OP] Member

    Joined:
    Jan 12, 2009
    Member:
    #12499
    Messages:
    9
    Gender:
    Male
    san diego
    Vehicle:
    05 prerunner SR5 k&n intake ,debadged
    k&n cold intake
    hey fellas i hardly ever post threads , but i do get a lot of help and good tips from all of you .much apreciated . i changed my spark plugs and cleaned my throttle body today .i have a k&n cai so i cleaned that .cleaned MAF also. started it up , check engine light was on and it was idling high @1500. i couldn t seem to find any threads discussing this issue .
     
  2. Nov 17, 2009 at 8:02 PM
    #2
    J_DORSETT

    J_DORSETT Member

    Joined:
    Nov 10, 2009
    Member:
    #25752
    Messages:
    9
    Gender:
    Male
    First Name:
    Justin
    League City, TX
    Is it throttle by wire? and it is not good for the maf to be cleaned. ruins a lot of them.
     
  3. Nov 17, 2009 at 8:06 PM
    #3
    WilsonTheDog

    WilsonTheDog Kylie's dad

    Joined:
    Nov 17, 2007
    Member:
    #3496
    Messages:
    4,837
    Gender:
    Male
    First Name:
    Eric
    Myrtle Beach SC
    Vehicle:
    07 Prerunner SR5 DC/SB V6
    Magnaflow 12576 muffler & chrome tip, Westin step bars, 27% tint, Pop N Lock, AFE ProdryS, bed mat, Husky liners, D-rings added, Access Literider tonneau, Pioneer 4-ways all around, GY Wrangler Duratracs 265/75/16, 5100's @ 1.75", 1.5" AAL
    Have an Autozone near you? Have them read the code.
     
  4. Nov 18, 2009 at 7:49 AM
    #4
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,731
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    It's fine and recommended to clean the MAF. You just need to be careful and use the proper cleaner.
     
  5. Nov 18, 2009 at 8:35 AM
    #5
    tacoeater

    tacoeater Well-Known Member

    Joined:
    Oct 19, 2009
    Member:
    #24532
    Messages:
    107
    Gender:
    Male
    First Name:
    Johnny
    Missouri
    Vehicle:
    07 TRD
    Weather Tech floor mats
    A high or eradic idle can be caused by a vaccuum leak. Check and make sure you didn't knock any vaccuum lines off while changing the plugs.
     
To Top