1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

check engine light on p0420

Discussion in 'Technical Chat' started by tacowade, Dec 6, 2010.

  1. Dec 6, 2010 at 9:46 PM
    #1
    tacowade

    tacowade [OP] Active Member

    Joined:
    Dec 6, 2010
    Member:
    #47279
    Messages:
    35
    Gender:
    Male
    First Name:
    Wade
    deerwood,mn
    Vehicle:
    95tacoma4x4
    CEL on p0420 replaced o2 sensors and cat. Still comes on. What else could cause this?
     
  2. Dec 6, 2010 at 9:48 PM
    #2
    ppham444

    ppham444 Well-Known Member

    Joined:
    Mar 28, 2010
    Member:
    #34175
    Messages:
    1,505
    Gender:
    Male
    First Name:
    Phuong
    Portland, OR
    Vehicle:
    2010 Double cab 4X4 TRD Sport with JBL
    Redline Tuning hood struts, tinted windows, FX-R HID projector retrofit headlights, AMP power steps
    420 huh? Sounds like the Taco wants to smoke some weed.
     
  3. Dec 7, 2010 at 9:14 PM
    #3
    tacowade

    tacowade [OP] Active Member

    Joined:
    Dec 6, 2010
    Member:
    #47279
    Messages:
    35
    Gender:
    Male
    First Name:
    Wade
    deerwood,mn
    Vehicle:
    95tacoma4x4
    What do u mean? If I could make my truck run on weed it might run better.
     
  4. Feb 9, 2011 at 8:58 PM
    #4
    The Munster

    The Munster I like turtles!!!

    Joined:
    Oct 7, 2010
    Member:
    #44355
    Messages:
    140
    Gender:
    Male
    First Name:
    Lance
    Moody AFB, GA
    Did you buy a factory cat and sensor (post cat????) if you bought a aftermarket cat thats why the MIL light comes on. aftermarket just aren't efficient enough for the ecm. buy a factory cat
     
To Top