1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Check Engine light Question

Discussion in 'Technical Chat' started by Chomag, Jun 27, 2008.

  1. Jun 27, 2008 at 2:44 PM
    #1
    Chomag

    Chomag [OP] Well-Known Member

    Joined:
    Jun 9, 2008
    Member:
    #7201
    Messages:
    111
    San Antonio TX.
    Vehicle:
    05 4X4 TRD sport
    Flowmaster Org. 40
    Hey peeps,

    My check Engine light came on early this morning while I was heading off to work. So when I got home I flipped threw the manual and followed what might be causing it such as checking the fugal cap. However the light stayed on. So I jumped on here and found out from you guys that I could go get the codes checked for free at Autozone.

    Anyway, before I started getting ready to head off to Autozone something possessed me to disconnect the battery while I went to go get showered off. Well a long story short- I reconnected the battery and now the check light is no longer lit. Now I know what you might be thinking, and wondering what I might be worried about then. Well other then checking the Fuel cap I didn't do anything else to fix what may have created the malfunction.

    Do you guys have any idea what it could have been causing the check engine light to indicate a malfunction? Might I of screwed up the computer by reseting it leaving me with no codes to get checked out, or would the computer still show me a malfunction if there was still an issue. I just hope it wont come back to bite me later on.

    Maybe all this worry is all for nothing and whatever it is is now somehow corrected, I just would like to know of your thoughts and advice you might have.

    Thanks!
     
  2. Jun 27, 2008 at 2:56 PM
    #2
    tacoskim

    tacoskim Tuned By Gadget

    Joined:
    Mar 13, 2008
    Member:
    #5252
    Messages:
    2,395
    Gender:
    Male
    Los Angeles, CA
    Vehicle:
    09 TRD 4x4 Pyrite Mica
    Stock
    do you have any mods done to ur truck?
     
  3. Jun 27, 2008 at 2:57 PM
    #3
    tacomaman06

    tacomaman06 Carolina Alliance: Lead, follow, or get the hell o Staff Member

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,305
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '13 Silverado ext cab
    are you positive its the check engine light and not the service engine soon light??? just wondering.
     
  4. Jun 27, 2008 at 2:57 PM
    #4
    Chomag

    Chomag [OP] Well-Known Member

    Joined:
    Jun 9, 2008
    Member:
    #7201
    Messages:
    111
    San Antonio TX.
    Vehicle:
    05 4X4 TRD sport
    Flowmaster Org. 40
    That I do, I have a Flowmaster 40 muffler put in. None other then that though.
     
  5. Jun 27, 2008 at 2:59 PM
    #5
    Chomag

    Chomag [OP] Well-Known Member

    Joined:
    Jun 9, 2008
    Member:
    #7201
    Messages:
    111
    San Antonio TX.
    Vehicle:
    05 4X4 TRD sport
    Flowmaster Org. 40
    IT is... Well was the check engine light lol
     
  6. Jun 27, 2008 at 3:04 PM
    #6
    tacomaman06

    tacomaman06 Carolina Alliance: Lead, follow, or get the hell o Staff Member

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,305
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '13 Silverado ext cab
    hmmm.....not sure then. if it comes on again......get autozone to pull the codes and we can go from there.
     
  7. Jun 27, 2008 at 3:07 PM
    #7
    Chomag

    Chomag [OP] Well-Known Member

    Joined:
    Jun 9, 2008
    Member:
    #7201
    Messages:
    111
    San Antonio TX.
    Vehicle:
    05 4X4 TRD sport
    Flowmaster Org. 40
    One thing to side note that I forgot to mention, was that I noticed that my engine coolent level was very low ( pretty far below the low level mark in the reservor) could that may have been a cause the warning light? I havn't filled it up though, but I'll for sure be doing this as soon as I head back into town.
     
  8. Jun 27, 2008 at 3:10 PM
    #8
    tacoskim

    tacoskim Tuned By Gadget

    Joined:
    Mar 13, 2008
    Member:
    #5252
    Messages:
    2,395
    Gender:
    Male
    Los Angeles, CA
    Vehicle:
    09 TRD 4x4 Pyrite Mica
    Stock
    when was the last time u got service on ur truck?
     
  9. Jun 27, 2008 at 3:10 PM
    #9
    Chomag

    Chomag [OP] Well-Known Member

    Joined:
    Jun 9, 2008
    Member:
    #7201
    Messages:
    111
    San Antonio TX.
    Vehicle:
    05 4X4 TRD sport
    Flowmaster Org. 40
    Yeah, I believe you are probably right. I think I am just being a bit over protective over my new baby lol. If it happens to come back on again I'll just do that.

    Thanks a ton though!
     
  10. Jun 28, 2008 at 4:15 AM
    #10
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    13,831
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2007 4.0L 4x4 TRD Sport Access Cab A
    Advantage Torza top (tri-fold), Husky floor mats, RuffTuff seat covers, C2C hood struts, Homelink mirror, USA Spec PA15-Toy (120gig Classic & 8gig nano), Garmin Nuvi 660, Protecta Bed mat, Pop-n-lock, TSB Springs, Scangauge II, Heated drivers seat, Fumoto drain valve, Aries pushbar, PIAA 540 fog lights, Hood scoop grahics, Flowmaster 50 series dual catback exhaust, RainX Latitude windshield wipers, Husky rear floor liner (ontop of folded down seats). Console Vault.
    What year truck and how many miles?
     
To Top