1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

check engine light??

Discussion in '1st Gen. Tacomas (1995-2004)' started by 04prerunner, Jul 20, 2010.

  1. Jul 20, 2010 at 5:09 AM
    #1
    04prerunner

    04prerunner [OP] Well-Known Member

    Joined:
    Jan 19, 2010
    Member:
    #29676
    Messages:
    410
    Gender:
    Male
    First Name:
    kyle
    tampa, Fl
    Vehicle:
    2004 prerunner
    stock
    it comes on frequently then goes away. Im assuming theres a reason for this?? it never stays on permanently which makes me think that its just a maintanence reminder or something?

    I have 2004 2.7L Dcab

    I know it could be a million things, but my truck just hit 73,000 miles

    if anyone has an idea, I would appreciate it. thanks :D
     
  2. Jul 20, 2010 at 5:25 AM
    #2
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,805
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    You will have to get the code read before we are able to help. It could be anything. Stop by your local auto parts store and have them read it for you.
     
  3. Jul 20, 2010 at 6:15 AM
    #3
    04prerunner

    04prerunner [OP] Well-Known Member

    Joined:
    Jan 19, 2010
    Member:
    #29676
    Messages:
    410
    Gender:
    Male
    First Name:
    kyle
    tampa, Fl
    Vehicle:
    2004 prerunner
    stock
    awesome. thanks
     
  4. Jul 20, 2010 at 7:23 AM
    #4
    IamTacO

    IamTacO red balls got me!

    Joined:
    Jan 31, 2010
    Member:
    #30401
    Messages:
    703
    Gender:
    Male
    First Name:
    adam
    QC az
    Vehicle:
    01 Prerunner SR5 TRD-Offroad
    4x2 Prerunner. Hankook Dynapro ATM rf10 265-65-16, e-locker FTW! Morimoto d2s bi-xenon HID projectors, Philips 85122+ 4300K, Cobra 75 w/ 3' firefly, Kenwood KDC-MP342U w/ SIRIUS, Line-x bed liner, 4' coretrax(black)
    do you reset the cel or does it go away on its own? from my experience with my old wrx, the flashing cel means a misfire. but get it checked anyways. auto zone use to check them for free
     
  5. Jul 20, 2010 at 7:38 AM
    #5
    04prerunner

    04prerunner [OP] Well-Known Member

    Joined:
    Jan 19, 2010
    Member:
    #29676
    Messages:
    410
    Gender:
    Male
    First Name:
    kyle
    tampa, Fl
    Vehicle:
    2004 prerunner
    stock
    the check engine light never flashes. it just pops on, then pops off after awhile. I havent seen it flash yet
     
  6. Jul 20, 2010 at 7:53 AM
    #6
    IamTacO

    IamTacO red balls got me!

    Joined:
    Jan 31, 2010
    Member:
    #30401
    Messages:
    703
    Gender:
    Male
    First Name:
    adam
    QC az
    Vehicle:
    01 Prerunner SR5 TRD-Offroad
    4x2 Prerunner. Hankook Dynapro ATM rf10 265-65-16, e-locker FTW! Morimoto d2s bi-xenon HID projectors, Philips 85122+ 4300K, Cobra 75 w/ 3' firefly, Kenwood KDC-MP342U w/ SIRIUS, Line-x bed liner, 4' coretrax(black)
    doubtful its a misfisre then. should check it soon though
     
To Top