1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Check Engine Light

Discussion in '2nd Gen. Tacomas (2005-2015)' started by johnnyboyupnorth, Feb 28, 2009.

  1. Feb 28, 2009 at 6:08 PM
    #1
    johnnyboyupnorth

    johnnyboyupnorth [OP] Member

    Joined:
    Dec 22, 2008
    Member:
    #11820
    Messages:
    13
    Gender:
    Male
    Eastern Canada
    Vehicle:
    4 cylinder 5 spd
    Nada Thing :-)
    Hi all,

    Quick question. I own an 09 AC 2.7 L. It has roughly 6000 km on it. Today while I was driving down the highway, the CEL and the traction control lights came on. Now it seems as though I don't have that active traction control when I am driving. Has this happened to anyone else? I am sure it's not a big deal, but the truck is brand new.

    Thanks!

    John
     
  2. Feb 28, 2009 at 6:10 PM
    #2
    Lentsnh

    Lentsnh Well-Known Member

    Joined:
    Nov 22, 2008
    Member:
    #10953
    Messages:
    9,547
    Gender:
    Male
    Vehicle:
    2007 Hummer H3 Tactical Edition
    None yet- Future: HIDs, Tinted tails, LED interior lights,
    It comes on if the computer notices that your not getting enough traction.


    the CEL light usually means its time for a oil change.
     
  3. Feb 28, 2009 at 6:13 PM
    #3
    johnnyboyupnorth

    johnnyboyupnorth [OP] Member

    Joined:
    Dec 22, 2008
    Member:
    #11820
    Messages:
    13
    Gender:
    Male
    Eastern Canada
    Vehicle:
    4 cylinder 5 spd
    Nada Thing :-)
    Thanks for the quick reply. I just had the first oil change on Friday at the dealership. I should have been more descriptive. Both lights are on now. The CEL and right below it, that "slippery" light. It's very icy out, and the tail end has wiggled loose a few times on the way home.
     
  4. Feb 28, 2009 at 6:27 PM
    #4
    Lentsnh

    Lentsnh Well-Known Member

    Joined:
    Nov 22, 2008
    Member:
    #10953
    Messages:
    9,547
    Gender:
    Male
    Vehicle:
    2007 Hummer H3 Tactical Edition
    None yet- Future: HIDs, Tinted tails, LED interior lights,
    the dealership probably forgot to reset the CEL light. Yeah it was just watching out for you. :thumbsup:
     
  5. Feb 28, 2009 at 6:29 PM
    #5
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,155
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    there is a maintinance light that comes on for service. The CEL indicates a problem.....
     
  6. Feb 28, 2009 at 6:58 PM
    #6
    johnnyboyupnorth

    johnnyboyupnorth [OP] Member

    Joined:
    Dec 22, 2008
    Member:
    #11820
    Messages:
    13
    Gender:
    Male
    Eastern Canada
    Vehicle:
    4 cylinder 5 spd
    Nada Thing :-)
    so that other light means oil change?
     
  7. Feb 28, 2009 at 7:05 PM
    #7
    Lentsnh

    Lentsnh Well-Known Member

    Joined:
    Nov 22, 2008
    Member:
    #10953
    Messages:
    9,547
    Gender:
    Male
    Vehicle:
    2007 Hummer H3 Tactical Edition
    None yet- Future: HIDs, Tinted tails, LED interior lights,
    CEL light can mean anything really from oil change to a misfire. But when it comes on its a good idea to take it to the dealership.

    the other light is your traction control. or in the picture below the oil canister means add more oil
     
  8. Feb 28, 2009 at 7:05 PM
    #8
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,155
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    If you have the yellow "ckeck" light with the pic of an engine:
    [​IMG]


    Get the code read
     
  9. Mar 1, 2009 at 8:52 AM
    #9
    Brunes

    Brunes abides.

    Joined:
    May 31, 2008
    Member:
    #7011
    Messages:
    17,641
    Gender:
    Male
    First Name:
    Rotorhead
    DC or New Jersey - Depends on the day....
    Vehicle:
    08 Red/Graphite and Satin Black
    Inside: Tint, Wet Okole 1/2 Piped Red/Black Covers, Black Weathertech Digital Fit Mats, URD Short Throw w/ TWM Weighted Knob, USA Spec iPod adapter. Outside: 4300K Retro w/ Angel Eyes and Red Shrouds, 5000K Blazer Fog Light Retrofit, Debadge, Bed Locking Handle, Satin Black Rims Performance: TRD/Steigmeier Blower w/ 2.7 Pulley. 668 Injectors and 320 LPH AEM Fuel pump. URD UCON and 7th Injector. DTLT Headers, URD Y-Pipe, Wicked Flow Muffler. Suspension: Both: OME Shocks Front: 886X's and TC UCAs Rear: Dakars Armor: Relentless Front Bumper Relentless High Clearance Rear w/ Tire/Rotopax Swing Out Relentless Front, Mid, and TCase skids BAMF Diff Skid Recovery and Spares: Fullsize Spare Tire 2x2 gal Rotopax 1x1 gal Rotopax 1x1 gal Water Rotopax Warn 9.5XP-S Winch Hi-Lift Extreme 60" Ironman Off-Road Recovery Kit
    I've never seen the CEL come on for an oil change- the "Maint Req'd" comes on ONLY for oil changes. The CEL comes on for engine issues.

    If you see the Maint Req'd Light- Have it/Change the oil. If you see the CEL-Get the code read (for free @ Autozone) and figure out if you can repair it for yourself-If you can't- take it to the dealer.
     
  10. Mar 1, 2009 at 8:58 AM
    #10
    Stangman

    Stangman Active Member

    Joined:
    Nov 9, 2008
    Member:
    #10601
    Messages:
    29
    Gender:
    Male
    Edgewood,MD
    Vehicle:
    06 Tacoma SR5
    2.5 " lift,32 " tires, Black taillights, Trd Sport seats, Smitybilt side steps and bull bar, CCFL Black Headlights, Overhead compass console, Auto Dimming Rear View Mirror
    When ever the comp detects a problem with a sensor or whatnot, it will turn the cel light on. Nothing to do with oil change. When this happens, the comp disable the traction control until the problem is repaired. But on the upside...it is still covered.
     
  11. Mar 2, 2009 at 8:21 AM
    #11
    johnnyboyupnorth

    johnnyboyupnorth [OP] Member

    Joined:
    Dec 22, 2008
    Member:
    #11820
    Messages:
    13
    Gender:
    Male
    Eastern Canada
    Vehicle:
    4 cylinder 5 spd
    Nada Thing :-)
    I took it into the dealership today. They told me that the computer is fried. They also told me that they have no replacement in North America. I can't drive it, and it's at the dealership. I can't believe this. I would expect this sort of thing if I drove a Sunfire or something like that...
     
  12. Mar 2, 2009 at 8:24 AM
    #12
    longbow

    longbow I see you now..................

    Joined:
    Jun 26, 2008
    Member:
    #7586
    Messages:
    4,041
    Gender:
    Male
    First Name:
    Bill
    Indiana
    Vehicle:
    05 Tacoma Silver Mica TRD 4 Door
    Toy-tec Coil over lift, Eibach 700 lb springs, Sway bar relocate, Total Chaos UCA's, Moto metal wheels, BFG mudterrians, HID, custom 3 piece grill, Highlift jack w/custom mount, Highlift jack cover, bed matt, de-badged 100%, storage box lock mod, using defrost w/o AC mod, short antenna mod, horn re-locate, Tire Gate flat spare tire mount, engine cover painted, bed light (1) mod, wreck bar carrier, Blue Sea 5026 fuse block, center console outlet, flash light mod, Blue Sea inline fuse, Shrockworks sliders, All-Pro front bumper, Piaa 510 driving lights, Warn shackles front, Kennesaw rear bumper, "Tag Boltz" plate lights, Warn shackles rear, Warn M8000 winch, devil horns, BHLM, weathech liners front and rear.....T.W. sticker of course. Custom Sock bed decal for Michele
    Had mine come on a few times, they forgot to reset it, got free service out of it. It came on also after the gas cap cracked it's pressure thingy. Fixed free of charge.

    Scare the crap out of you sometimes huh
     
  13. Mar 2, 2009 at 8:26 AM
    #13
    Brunes

    Brunes abides.

    Joined:
    May 31, 2008
    Member:
    #7011
    Messages:
    17,641
    Gender:
    Male
    First Name:
    Rotorhead
    DC or New Jersey - Depends on the day....
    Vehicle:
    08 Red/Graphite and Satin Black
    Inside: Tint, Wet Okole 1/2 Piped Red/Black Covers, Black Weathertech Digital Fit Mats, URD Short Throw w/ TWM Weighted Knob, USA Spec iPod adapter. Outside: 4300K Retro w/ Angel Eyes and Red Shrouds, 5000K Blazer Fog Light Retrofit, Debadge, Bed Locking Handle, Satin Black Rims Performance: TRD/Steigmeier Blower w/ 2.7 Pulley. 668 Injectors and 320 LPH AEM Fuel pump. URD UCON and 7th Injector. DTLT Headers, URD Y-Pipe, Wicked Flow Muffler. Suspension: Both: OME Shocks Front: 886X's and TC UCAs Rear: Dakars Armor: Relentless Front Bumper Relentless High Clearance Rear w/ Tire/Rotopax Swing Out Relentless Front, Mid, and TCase skids BAMF Diff Skid Recovery and Spares: Fullsize Spare Tire 2x2 gal Rotopax 1x1 gal Rotopax 1x1 gal Water Rotopax Warn 9.5XP-S Winch Hi-Lift Extreme 60" Ironman Off-Road Recovery Kit
    That sucks Johnny- Good luck!!
     
  14. Mar 2, 2009 at 8:56 AM
    #14
    Jester243

    Jester243 mod status????

    Joined:
    Jun 25, 2008
    Member:
    #7552
    Messages:
    10,004
    Gender:
    Male
    First Name:
    Dan
    Spokane, WA
    Vehicle:
    2016 Trail Premium 4Runner w/ KDSS
    Too bad on the computer, let us know how it goes... subscribed.
     
  15. Mar 2, 2009 at 8:58 AM
    #15
    johnnyboyupnorth

    johnnyboyupnorth [OP] Member

    Joined:
    Dec 22, 2008
    Member:
    #11820
    Messages:
    13
    Gender:
    Male
    Eastern Canada
    Vehicle:
    4 cylinder 5 spd
    Nada Thing :-)
    Thanks Gents. I'll let you know. They have a couple of days until I start burning houses down.
     
  16. Mar 4, 2009 at 12:44 PM
    #16
    johnnyboyupnorth

    johnnyboyupnorth [OP] Member

    Joined:
    Dec 22, 2008
    Member:
    #11820
    Messages:
    13
    Gender:
    Male
    Eastern Canada
    Vehicle:
    4 cylinder 5 spd
    Nada Thing :-)
    Well I never got the call I had expected. In fact I didn't get any call, so I called them to see what progress had been made. The Service Manager took my call, told me that the parts were back-ordered for a week. I told him I wasn't happy and I'd call him back tomorrow. He told me that I could call as often as I wanted, but the fact remained that the parts wouldn't be in. He told me if I had a complaint to let the General Manager know, then hung up on me.

    I've ordered 99 cent hamburgers from McDonald's with better customer service. If I was rude or threatening, I could see someone losing their patience; we're all human. But I have never been treated so rudely in my life. With the economy in the state it's in, you would think that customer service woudn't be in a recession as well.

    The reason I bought this truck was because of a used Tercel I owned years ago. It performed flawlessly for years. My new truck died before its first oil change was due.

    I called the Toyota Customer Service number and registered a complaint. I was fed the usual BS about "working tirelessly to effect a solution" and that the back ordered parts would be made a priority.

    My experience thus far with Toyota makes me want to sell the truck, pay off the loan and buy a Nissan Frontier or something. With all I read about how great these trucks are, I am thinking I got the wrong truck from the wrong dealer.
     
  17. Mar 4, 2009 at 12:49 PM
    #17
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,837
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    Fried? That is hard to believe. Did they give you the code? Give the truck a chance. I am sure it will change your mind. The comps in Tacos are very stable. I am thinking they screwed it up somehow.
     
  18. Mar 4, 2009 at 4:25 PM
    #18
    johnnyboyupnorth

    johnnyboyupnorth [OP] Member

    Joined:
    Dec 22, 2008
    Member:
    #11820
    Messages:
    13
    Gender:
    Male
    Eastern Canada
    Vehicle:
    4 cylinder 5 spd
    Nada Thing :-)

    Fried was what I overheard the mechanic say. They spoke of multiple codes, and flashing it did nothing. After they had flashed it, the codes came back.

    Toyota of Canada called me tonight. Apparently I was "mistaken by the Service Manager's tone", and he "denies knowledge of any incident which would have resulted in him ending a telephone conversation prematurely". It's painfully obvious when someone slams the phone down on another person.

    Given what I've read here about Tacomas, and with the instant help I get from fellow owners, I'll take the last piece of advice and let the truck grow on me. I will, however, enjoy the conversation that I will have with that man when I pick my truck up. I might quote the dealership's owner's letter that he wrote to me days after I drove the truck off the lot: "Our commitment to you has only just begun". I've seen more commitment in a Labrador Retriever in heat...
     
  19. Mar 4, 2009 at 4:35 PM
    #19
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,837
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    That last part is funny, lab in heat. I personally promise you will enjoy the truck. I bought my first one in 98. It was a 93 PU. Traded it in for a 98 taco. Then the buyback and got a Tundy. I have never own another brand truck. Sold on yota's for the last ten years.
     
  20. Mar 6, 2009 at 4:47 PM
    #20
    johnnyboyupnorth

    johnnyboyupnorth [OP] Member

    Joined:
    Dec 22, 2008
    Member:
    #11820
    Messages:
    13
    Gender:
    Male
    Eastern Canada
    Vehicle:
    4 cylinder 5 spd
    Nada Thing :-)
    I got my truck back tonight. 4 days early. They told me that the o2 sensor was faulty. Seems ok, but my trustworthiness has taken a beating.

    It was actually comical when I went in to get the truck at the dealership. The little pint of pi$$ of a man who hung up on me before who sounded 7'5" on the phone stood no higher than 4' 9" and couldn't look me in the eye today...

    Seeing how 98tacoma27 has a weakness for redheads, and I share that similar weakness, I'll assume that the truck was repaired in good order.

    It's good to have the baby back.
     
To Top