1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Clarion NX702 iPod connection issues

Discussion in 'Audio & Video' started by pollock21, Jul 24, 2014.

  1. pollock21

    pollock21 [OP] Well-Known Member

    Joined:
    Nov 30, 2010
    Member:
    #46950
    Messages:
    209
    Gender:
    Male
    First Name:
    Brian
    Cornelius, NC
    Vehicle:
    '11 Tacoma DC, TRD Sport 4x4
    Just installed my NX702 and everything is working well for the most part. All except my iPod. It's pretty well plug and play, nothing complicated about it. But it's buggy as all get out.

    Sometimes the whole unit will freeze up requiring a power cycle, controls for it are pretty laggy, but mostly it'll recognize the iPod, play a few songs, then it will drop out and default to radio. I'll unplug the iPod and plug it back in and it will fire up. Tonight it started playing random songs that had nothing to do with the song I selected. I'm leaning towards the cable, but could be something in the head unit. Been searching all around the web for similar cases to no avail.

    Anyone running clarion seen any issues like this and if so, what did you find was the issue?
     
To Top