1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Clock Problems - Strange

Discussion in '1st Gen. Tacomas' started by cshoe98, Nov 19, 2007.

  1. cshoe98

    cshoe98 [OP] Member

    Joined:
    Nov 14, 2007
    Member:
    #3454
    Messages:
    22
    Chillicothe/Athens Ohio
    Vehicle:
    '98 SR5
    Dirt/Snow off road tires, Westin Bed X-Tender, Rain & bug guards, Nerf bars.
    So my stock, in dash clock has been having some troubles. Every now and then I have to push on the faceplate of the clock for it to show up.... Like I will start my truck up and the clock does not show up. As if its broke or something. When I push lightly on the faceplate the numbers start to show up, the harder I push the darker the numbers get.

    Its really strange...and hard to explain.... Wondering if any of you have had the same problem?
     
  2. 350TacoZilla

    350TacoZilla Well-Known Member

    Joined:
    Sep 22, 2007
    Member:
    #2767
    Messages:
    1,106
    Clear Spring MD
    2.7L 3RZ,K&N filter, 4" deck plate mod,flowmaster 40 series,3" body lift,3" suspension lift,35's. I also have another tacoma a 97 with a 350 small block in it on a 1972 blazer frame...
    never heard of the problem but you may be able to fix it by taking clock out of the dash and seeing if the backing is loose... (like where it plugs in)
     
  3. Dcrooks84

    Dcrooks84 Sir Anal Loin of Beef

    Joined:
    Nov 3, 2007
    Member:
    #3347
    Messages:
    475
    Gender:
    Male
    Ohio
    Vehicle:
    05 double cab SR5 Pkg #8 lng bd 4X4
    Removed secondary air filter, Fog light anytime, Map light mod, Scan Gauge II, Polished Stainless Steel Westin E-Series Bull Bar, Black GrilleCraft Grille, Borla CatBack Exhaust
    I agree, it sounds like you would have some sort of a loose connection. If you find that all the wires are connected correctly I would check to see if you might possibly have a broken solder.
     
  4. 2003greenbean

    2003greenbean Carolina Alliance Costal Div

    Joined:
    Jan 7, 2007
    Member:
    #672
    Messages:
    913
    socaste,sc
    Vehicle:
    03 trd
    cold air intake, step bars, custom grill, 3in lift,12 in audiobahn sub, 285/75/16 procomp tires, 20% tint,
    check on ebay for a new one
     
  5. A1CGuches

    A1CGuches Oregon Alliance: Founder

    Joined:
    Dec 10, 2007
    Member:
    #3785
    Messages:
    54
    DMAFB, Arizona
    Vehicle:
    01 Taco
    Custom snorkel/intake, 6" lift, 35X12.5 mt's, flowmaster 40 seriers, performance clutch, custom skid plate, grille, everything is black on green, rotrex supercharger, 7th injector kit, urd short throw shifter, thorely header, kks speed limit defender...and more to come
    Or go to the Wal-Mart and get a ten dollar wrist watch...then like ive said before mount some toggle switches in its place.
     
  6. Don G

    Don G Old Goat

    Joined:
    Oct 18, 2007
    Member:
    #3110
    Messages:
    1,200
    Southern Tier New York
    Vehicle:
    "08" Tacoma Access Cab TRD Sport 4X4
    Good idea! !! You can't see the dang things in the daytime anyway:D

    Don G
     
  7. Taco95

    Taco95 Active Member

    Joined:
    Mar 27, 2007
    Member:
    #1166
    Messages:
    36
    Ha ha atleast yours isn't like mine! Mine use to not work at all, i thought it was completely broke. Then one day i started it up and it came on. well about 30 mins later it went out and it doesn't come on unless you hit the clock LOL i kinda like it, keeps me occupied while im driving.:D

    its not really something i can complain about, like someone else said just get a wrist watch you can't see the damn things anyways.
     
  8. A1CGuches

    A1CGuches Oregon Alliance: Founder

    Joined:
    Dec 10, 2007
    Member:
    #3785
    Messages:
    54
    DMAFB, Arizona
    Vehicle:
    01 Taco
    Custom snorkel/intake, 6" lift, 35X12.5 mt's, flowmaster 40 seriers, performance clutch, custom skid plate, grille, everything is black on green, rotrex supercharger, 7th injector kit, urd short throw shifter, thorely header, kks speed limit defender...and more to come
    haha yeah mine worked for about ten minutes after i bought it then it went bad...so i mounted the toggle switch for my auxillary back up lights there.
     
  9. cshoe98

    cshoe98 [OP] Member

    Joined:
    Nov 14, 2007
    Member:
    #3454
    Messages:
    22
    Chillicothe/Athens Ohio
    Vehicle:
    '98 SR5
    Dirt/Snow off road tires, Westin Bed X-Tender, Rain & bug guards, Nerf bars.

    Yeah I have to hit mine pretty much to get it to work...

    My CD player I had installed shows the time so I am not that worried about it... just found it really STRANGE.

    Mounting a switch there though is a good idea.... I might have to do that.
     
  10. A1CGuches

    A1CGuches Oregon Alliance: Founder

    Joined:
    Dec 10, 2007
    Member:
    #3785
    Messages:
    54
    DMAFB, Arizona
    Vehicle:
    01 Taco
    Custom snorkel/intake, 6" lift, 35X12.5 mt's, flowmaster 40 seriers, performance clutch, custom skid plate, grille, everything is black on green, rotrex supercharger, 7th injector kit, urd short throw shifter, thorely header, kks speed limit defender...and more to come
    If you have any questions on what to do or remove when you do it just ask.
     
  11. TPain

    TPain Boss

    Joined:
    Sep 21, 2012
    Member:
    #87426
    Messages:
    300
    Gender:
    Male
    First Name:
    Tanner
    Asheville, NC
    Vehicle:
    01 SR5 Supercharged
    I know this is almost a 6 year old thread but was this problem ever fixed? My clock does the same exact thing.
     
  12. oldblue1968chevy

    oldblue1968chevy Well-Known Member

    Joined:
    Nov 26, 2012
    Member:
    #91916
    Messages:
    1,541
    Gender:
    Male
    First Name:
    John
    Spokane WA/Viola TN
    Vehicle:
    2000 Toyota Tacoma V6 TRD
    Stock
    bump mine too
     
To Top