1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Clunking sound after bump.

Discussion in 'Suspension' started by Freestyler, Jan 19, 2012.

  1. Jan 19, 2012 at 4:09 PM
    #1
    Freestyler

    Freestyler [OP] Well-Known Member

    Joined:
    May 13, 2009
    Member:
    #17184
    Messages:
    101
    Gender:
    Male
    Duvall Washington
    Vehicle:
    05 TRD off road
    6" Pro Comp, 315/70/17 Pro Cromp Xtreme mt on 17x8 ultra Goliaths, K&N intake, Westin Sportsman, Flowmaster Exhaust, Alpine Speakers and Amp, JL 8 Inch SUB, Pioneer AVH-P3300 BT, 35W 5k HID Healights and Fogs, 100W 6k HID converted 800 series KC Lights.
    So this is sort of a long story, but it has been snowing very hard where I live for about 5 days now and yesterday and hit a rather large ice chunk going about 15 ish mph. It didnt seem like anything out of the ordinary and ive gone over worse things in my truck before, but now Ive got this sort of clunking sound coming from my front left area of the truck when I drive. Also I just drove it around my parking light and it seems to shutter when i stop, could just be the snow but it seems like it is more than it should be.

    I had my lift installed for me, I dont really know whats goin on down there so i hardly know what to look for, If anyone has any ideas please let me know, I'm sort of afraid to drive it right now.

    Edit: I was also using 4wd if this could help anyone diagnose my problem
     
To Top